me
/
guix
Archived
1
0
Fork 0

gnu: orc: Update to 0.4.31.

* gnu/packages/patches/orc-typedef-enum.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gstreamer.scm (orc): Update to 0.4.31.
[source](patches): Remove.
master
Marius Bakke 2019-12-10 16:05:49 +01:00
parent cb669c0951
commit 99732a8f22
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 21 deletions

View File

@ -1212,7 +1212,6 @@ dist_patch_DATA = \
%D%/packages/patches/openssl-c-rehash-in.patch \
%D%/packages/patches/openssl-CVE-2019-1559.patch \
%D%/packages/patches/open-zwave-hidapi.patch \
%D%/packages/patches/orc-typedef-enum.patch \
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
%D%/packages/patches/osip-CVE-2017-7853.patch \
%D%/packages/patches/ots-no-include-missing-file.patch \

View File

@ -69,15 +69,14 @@
(define-public orc
(package
(name "orc")
(version "0.4.30")
(version "0.4.31")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
(patches (search-patches "orc-typedef-enum.patch"))
(sha256
(base32
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
"0xb0c7q3xv1ldmz5ipybazb01gy3cijj8622dcx7rbm9lq85zax0"))))
(build-system meson-build-system)
(arguments
`(#:phases

View File

@ -1,17 +0,0 @@
Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
Taken from upstream:
https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
diff --git a/orc/orctarget.h b/orc/orctarget.h
--- a/orc/orctarget.h
+++ b/orc/orctarget.h
@@ -19,7 +19,7 @@ enum {
ORC_TARGET_FAST_DENORMAL = (1<<31)
};
-enum {
+typedef enum {
ORC_TARGET_POWERPC_64BIT = (1<<0),
ORC_TARGET_POWERPC_LE = (1<<1),
ORC_TARGET_POWERPC_ALTIVEC = (1<<2),