me
/
guix
Archived
1
0
Fork 0

gnu: ccache: Update to 4.4.2.

* gnu/packages/ccache.scm (ccache): Update to 4.4.2.
[source]: Remove patch.
[arguments]: Substitute nonexistent compgen.
* gnu/packages/patches/ccache-fix-basedir-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2021-10-03 16:09:27 +02:00
parent dfa6e6cad5
commit 9b9c74eaa7
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 8 additions and 33 deletions

View File

@ -915,7 +915,6 @@ dist_patch_DATA = \
%D%/packages/patches/calibre-remove-test-unrar.patch \
%D%/packages/patches/casync-renameat2-declaration.patch \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
%D%/packages/patches/ccache-fix-basedir-test.patch \
%D%/packages/patches/circos-remove-findbin.patch \
%D%/packages/patches/cdparanoia-fpic.patch \
%D%/packages/patches/cdrtools-3.01-mkisofs-isoinfo.patch \

View File

@ -31,16 +31,14 @@
(define-public ccache
(package
(name "ccache")
(version "4.4.1")
(version "4.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ccache/ccache/releases/download/v"
version "/ccache-" version ".tar.xz"))
(sha256
(base32 "0nc1mlmj92lfa25d12nzf5n55az6zfx38n0z1qqkkzjxn6sxzmpb"))
(patches
(search-patches "ccache-fix-basedir-test.patch"))))
(base32 "186b5lfbdd48cvbxqv2yh93pgr8lhahl1jzw00k2rmjzmbxwl04j"))))
(build-system cmake-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
("which" ,(@ (gnu packages base) which))))
@ -53,9 +51,13 @@
#:phases
(modify-phases %standard-phases
(add-before 'configure 'setup-tests
(add-before 'configure 'fix-shell
;; Run early whilst we're still in the source directory.
(lambda _
(substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
(substitute* (list "test/run"
"test/suites/base.bash"
"unittest/test_hashutil.cpp")
(("compgen -e") "env | cut -d= -f1")
(("#!/bin/sh") (string-append "#!" (which "sh"))))))
(add-before 'check 'set-home
;; Tests require a writable HOME.

View File

@ -1,26 +0,0 @@
From ad18f15287b83cee5a45b63e02b31c6a601a134f Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 27 Sep 2021 19:36:30 +0200
Subject: [PATCH] gnu: ccache: Fix basedir test.
Applied upstream.
---
test/suites/basedir.bash | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/suites/basedir.bash b/test/suites/basedir.bash
index 479c632..34e5cb7 100644
--- a/test/suites/basedir.bash
+++ b/test/suites/basedir.bash
@@ -269,7 +269,7 @@ EOF
EOF
backdate test.h
- pwd="$(/bin/pwd -P)"
+ pwd="$(pwd -P)"
$REAL_COMPILER -c $pwd/test.c 2>reference.stderr
CCACHE_ABSSTDERR=1 CCACHE_BASEDIR="$pwd" $CCACHE_COMPILE -c $pwd/test.c 2>ccache.stderr
--
2.33.0