gnu: python-seaborn: Update to 0.11.1.
* gnu/packages/patches/python-seaborn-kde-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-xyz.scm (python-seaborn): Use it, and update to 0.11.1.master
parent
3125255cc5
commit
9bfc4a8187
|
@ -1633,6 +1633,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python2-pygobject-2-deprecation.patch \
|
%D%/packages/patches/python2-pygobject-2-deprecation.patch \
|
||||||
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
||||||
%D%/packages/patches/python-robotframework-source-date-epoch.patch \
|
%D%/packages/patches/python-robotframework-source-date-epoch.patch \
|
||||||
|
%D%/packages/patches/python-seaborn-kde-test.patch \
|
||||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||||
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
||||||
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
||||||
|
|
|
@ -0,0 +1,36 @@
|
||||||
|
This patch is an excerpt of this upstream commit:
|
||||||
|
|
||||||
|
commit 0a24478a550132f1882e5be5f5dbc0fc446a8a6c
|
||||||
|
Author: Michael Waskom <mwaskom@users.noreply.github.com>
|
||||||
|
Date: Mon Dec 21 18:44:58 2020 -0500
|
||||||
|
|
||||||
|
Raise minimal supported Python to 3.7 and bump requirements (#2396)
|
||||||
|
|
||||||
|
It fixes the failure of 'test_weights'.
|
||||||
|
|
||||||
|
--- a/seaborn/tests/test_distributions.py
|
||||||
|
+++ b/seaborn/tests/test_distributions.py
|
||||||
|
@@ -709,21 +708,17 @@ class TestKDEPlotUnivariate:
|
||||||
|
integral = integrate.trapz(ydata, np.log10(xdata))
|
||||||
|
assert integral == pytest.approx(1)
|
||||||
|
|
||||||
|
- @pytest.mark.skipif(
|
||||||
|
- LooseVersion(scipy.__version__) < "1.2.0",
|
||||||
|
- reason="Weights require scipy >= 1.2.0"
|
||||||
|
- )
|
||||||
|
def test_weights(self):
|
||||||
|
|
||||||
|
x = [1, 2]
|
||||||
|
weights = [2, 1]
|
||||||
|
|
||||||
|
- ax = kdeplot(x=x, weights=weights)
|
||||||
|
+ ax = kdeplot(x=x, weights=weights, bw_method=.1)
|
||||||
|
|
||||||
|
xdata, ydata = ax.lines[0].get_xydata().T
|
||||||
|
|
||||||
|
- y1 = ydata[np.argwhere(np.abs(xdata - 1).min())]
|
||||||
|
- y2 = ydata[np.argwhere(np.abs(xdata - 2).min())]
|
||||||
|
+ y1 = ydata[np.abs(xdata - 1).argmin()]
|
||||||
|
+ y2 = ydata[np.abs(xdata - 2).argmin()]
|
||||||
|
|
||||||
|
assert y1 == pytest.approx(2 * y2)
|
|
@ -8800,13 +8800,14 @@ SVG, EPS, PNG and terminal output.")
|
||||||
(define-public python-seaborn
|
(define-public python-seaborn
|
||||||
(package
|
(package
|
||||||
(name "python-seaborn")
|
(name "python-seaborn")
|
||||||
(version "0.10.0")
|
(version "0.11.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "seaborn" version))
|
(uri (pypi-uri "seaborn" version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1ffbms4kllihfycf6j57dziq4imgdjw03sqgifh5wzcd2d743zjr"))))
|
(base32 "1b81p9s6li3b606ivgbynrh102fclwlw74m8qxzsii9pv6p8xrs4"))
|
||||||
|
(patches (search-patches "python-seaborn-kde-test.patch"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
|
Reference in New Issue