me
/
guix
Archived
1
0
Fork 0

gnu: Add kdiagram.

* gnu/packages/kde.scm (kdiagram): New variable.
* packages/patches/kdiagram-Fix-missing-link-libraries.patch: New file.
* gnu/local.mk: Add it.
master
Hartmut Goebel 2020-01-20 01:45:38 +01:00
parent 639b6ead0c
commit 9d95d8bd12
No known key found for this signature in database
GPG Key ID: 634A8DFFD3F631DF
3 changed files with 55 additions and 0 deletions

View File

@ -1053,6 +1053,7 @@ dist_patch_DATA = \
%D%/packages/patches/libziparchive-add-includes.patch \
%D%/packages/patches/localed-xorg-keyboard.patch \
%D%/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch \
%D%/packages/patches/kdiagram-Fix-missing-link-libraries.patch \
%D%/packages/patches/kiki-level-selection-crash.patch \
%D%/packages/patches/kiki-makefile.patch \
%D%/packages/patches/kiki-missing-includes.patch \

View File

@ -325,6 +325,37 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
;; kdevplatform was merged into kdevelop as of 5.2.x
(define-deprecated kdevplatform kdevelop)
(define-public kdiagram
(package
(name "kdiagram")
(version "2.6.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/kdiagram/" version
"/kdiagram-" version ".tar.xz"))
(sha256
(base32 "1c6dbp9gssjrx59z8yxzq1ay56pnw7h28symjrv0gcvhxyjirrxx"))
(patches (search-patches
"kdiagram-Fix-missing-link-libraries.patch"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)))
(inputs
`(("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
(home-page "https://cgit.kde.org/kdiagram.git/")
(synopsis "Libraries for creating business diagrams")
(description "This package provides libraries for integrating business
diagrams in Qt-based applications.
@code{KCharts} provides an implementation of the ODF Chart specification. It
supports stock charts, box charts, and whisker charts. @code{KGantt} provides
a module for implementing ODF Gantt charts, which are bar charts that
illustrate project schedules.")
(license license:gpl2+)))
(define-public krita
(package
(name "krita")

View File

@ -0,0 +1,23 @@
From c59acf1f54a2cd760e55082a01593a31a690d786 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Wed, 22 Jan 2020 00:56:27 +0100
Subject: [PATCH] Fix missing link libraries.
These are only actually missing if the libraries reside in different
prefixes, as it is the case in Guix or Nix.
---
examples/Bars/Simple/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/examples/Bars/Simple/CMakeLists.txt b/examples/Bars/Simple/CMakeLists.txt
index be2a6fc..b13befb 100644
--- a/examples/Bars/Simple/CMakeLists.txt
+++ b/examples/Bars/Simple/CMakeLists.txt
@@ -1,3 +1,3 @@
add_executable(BarsSimple main.cpp)
-target_link_libraries(BarsSimple KChart Qt5::Widgets)
+target_link_libraries(BarsSimple KChart Qt5::Widgets Qt5::Svg)
--
2.21.1