gnu: poppler: Update to 0.74.0.
* gnu/packages/patches/scribus-poppler-0.73.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/scribus.scm (scribus)[source](patches): Add it. * gnu/packages/pdf.scm (poppler): Update to 0.74.0. [arguments]: Adjust renamed configure flag. * gnu/packages/tex.scm (texlive-bin)[arguments]: Add phase 'use-code-for-even-newer-poppler'.master
parent
35b259eed0
commit
9df397508d
|
@ -1220,6 +1220,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||
%D%/packages/patches/scribus-poppler.patch \
|
||||
%D%/packages/patches/scribus-poppler-0.73.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
Fix build with Poppler 0.73.
|
||||
|
||||
This is an amalgamation of these upstream commits:
|
||||
https://github.com/scribusproject/scribus/commit/d34e59bfe495250ba023ba0f99e672ee32300a27
|
||||
https://github.com/scribusproject/scribus/commit/c43a89030026f8ffab5070b6935daee8bd74838a
|
||||
|
||||
diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
|
||||
index c46448b80a..4dac7c3983 100644
|
||||
--- a/scribus/plugins/import/pdf/slaoutput.h
|
||||
+++ b/scribus/plugins/import/pdf/slaoutput.h
|
||||
@@ -28,7 +28,9 @@ for which a new license (GPL+exception) is in place.
|
||||
#include "selection.h"
|
||||
#include "vgradient.h"
|
||||
|
||||
+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 73, 0)
|
||||
#include <poppler/goo/gtypes.h>
|
||||
+#endif
|
||||
#include <poppler/Object.h>
|
||||
#include <poppler/OutputDev.h>
|
||||
#include <poppler/Gfx.h>
|
||||
diff --git a/scribus/plugins/import/pdf/importpdfconfig.h b/scribus/plugins/import/pdf/importpdfconfig.h
|
||||
index f6b3950377..80ac796501 100644
|
||||
--- a/scribus/plugins/import/pdf/importpdfconfig.h
|
||||
+++ b/scribus/plugins/import/pdf/importpdfconfig.h
|
||||
@@ -37,4 +37,11 @@ for which a new license (GPL+exception) is in place.
|
||||
#define getCString c_str
|
||||
#endif
|
||||
|
||||
+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 73, 0)
|
||||
+#define Guchar unsigned char
|
||||
+#define Gushort unsigned short
|
||||
+#define Guint unsigned int
|
||||
+#define Gulong unsigned long
|
||||
+#endif
|
||||
+
|
||||
#endif
|
|
@ -83,14 +83,14 @@
|
|||
(define-public poppler
|
||||
(package
|
||||
(name "poppler")
|
||||
(version "0.72.0")
|
||||
(version "0.74.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://poppler.freedesktop.org/poppler-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0lfs1b1jfamxl13zbl5n448dqvl9n8frbv8180y7b7kfyaw7wx61"))))
|
||||
"0bvb0yq9zsl2b811j4l4x0vf8g5lgmqbndkb2hvgsrr5639rzq4j"))))
|
||||
(build-system cmake-build-system)
|
||||
;; FIXME:
|
||||
;; use libcurl: no
|
||||
|
@ -122,7 +122,7 @@
|
|||
#:configure-flags
|
||||
(let* ((out (assoc-ref %outputs "out"))
|
||||
(lib (string-append out "/lib")))
|
||||
(list "-DENABLE_XPDF_HEADERS=ON" ; to install header files
|
||||
(list "-DENABLE_UNSTABLE_API_ABI_HEADERS=ON" ;to install header files
|
||||
"-DENABLE_ZLIB=ON"
|
||||
(string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
|
||||
(string-append "-DCMAKE_INSTALL_RPATH=" lib)))))
|
||||
|
|
|
@ -97,7 +97,9 @@
|
|||
(file-name "scribus-poppler-0.70.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr"))))))
|
||||
"0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr"))))
|
||||
|
||||
(search-patches "scribus-poppler-0.73.patch")))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -200,6 +200,15 @@
|
|||
(copy-file "texk/web2c/pdftexdir/pdftosrc-newpoppler.cc"
|
||||
"texk/web2c/pdftexdir/pdftosrc.cc")
|
||||
#t))
|
||||
(add-after 'use-code-for-new-poppler 'use-code-for-even-newer-poppler
|
||||
(lambda _
|
||||
;; Adjust for deprecated types in Poppler 0.73.
|
||||
(substitute* (append
|
||||
(find-files "texk/web2c/luatexdir/" "\\.(cc|w)$")
|
||||
'("texk/web2c/pdftexdir/pdftosrc.cc"))
|
||||
(("Guint") "unsigned int")
|
||||
(("Guchar") "unsigned char"))
|
||||
#t))
|
||||
(add-after 'unpack 'disable-failing-test
|
||||
(lambda _
|
||||
;; FIXME: This test fails on 32-bit architectures since Glibc 2.28:
|
||||
|
|
Reference in New Issue