gnu: llvm-9: Standardize patch level.
Having a non-standard (different than 1) patch level requirement means the patches cannot be composed easily from different origins. The following command was used to remove one level from the llvm-9 patches: sed -e 's|^--- a/|--- |' -e 's|^+++ b/|+++ |' \ gnu/packages/patches/llvm-9* -i * gnu/packages/llvm.scm (llvm-9)[source]: Drop the patch-flags field. Re-indent list of patches. * gnu/packages/patches/llvm-9-fix-bitcast-miscompilation.patch: Strip one level. * gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch: Likewise. * gnu/packages/patches/llvm-9-fix-scev-miscompilation.patch: Likewise.master
parent
199ebb1298
commit
9e4c24ef90
|
@ -602,11 +602,10 @@ of programming tools as well as libraries with equivalent functionality.")
|
|||
(sha256
|
||||
(base32
|
||||
"16hwp3qa54c3a3v7h8nlw0fh5criqh0hlr1skybyk0cz70gyx880"))
|
||||
(patch-flags '("-p2"))
|
||||
(patches (search-patches
|
||||
"llvm-9-fix-bitcast-miscompilation.patch"
|
||||
"llvm-9-fix-scev-miscompilation.patch"
|
||||
"llvm-9-fix-lpad-miscompilation.patch"))))))
|
||||
"llvm-9-fix-bitcast-miscompilation.patch"
|
||||
"llvm-9-fix-scev-miscompilation.patch"
|
||||
"llvm-9-fix-lpad-miscompilation.patch"))))))
|
||||
|
||||
(define-public clang-runtime-9
|
||||
(clang-runtime-from-llvm
|
||||
|
|
|
@ -36,8 +36,8 @@ Differential Revision: https://reviews.llvm.org/D70844
|
|||
|
||||
diff --git a/llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp b/llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
|
||||
index 2c9ba203fbf3..0af3de300e77 100644
|
||||
--- a/llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
|
||||
+++ b/llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
|
||||
--- llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
|
||||
+++ llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
#include "llvm/IR/DIBuilder.h"
|
||||
#include "llvm/IR/PatternMatch.h"
|
||||
|
@ -158,8 +158,8 @@ index 2c9ba203fbf3..0af3de300e77 100644
|
|||
|
||||
diff --git a/llvm/test/Transforms/InstCombine/cast.ll b/llvm/test/Transforms/InstCombine/cast.ll
|
||||
index b6d1eda0601d..3ce8de033422 100644
|
||||
--- a/llvm/test/Transforms/InstCombine/cast.ll
|
||||
+++ b/llvm/test/Transforms/InstCombine/cast.ll
|
||||
--- llvm/test/Transforms/InstCombine/cast.ll
|
||||
+++ llvm/test/Transforms/InstCombine/cast.ll
|
||||
@@ -824,7 +824,7 @@ define i64 @test59(i8 %A, i8 %B) {
|
||||
|
||||
define <3 x i32> @test60(<4 x i32> %call4) {
|
||||
|
|
|
@ -15,8 +15,8 @@ PR45261
|
|||
|
||||
diff --git a/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp b/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
|
||||
index 5ac3606dc662..2638b1e8a05c 100644
|
||||
--- a/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
|
||||
+++ b/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
|
||||
--- llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
|
||||
+++ llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
|
||||
@@ -225,6 +225,21 @@ static bool isRegUsedByPhiNodes(unsigned DefReg,
|
||||
return false;
|
||||
}
|
||||
|
@ -50,8 +50,8 @@ index 5ac3606dc662..2638b1e8a05c 100644
|
|||
}
|
||||
diff --git a/llvm/test/CodeGen/X86/sink-local-value.ll b/llvm/test/CodeGen/X86/sink-local-value.ll
|
||||
index b0e511ac1189..f7d861ac9b6c 100644
|
||||
--- a/llvm/test/CodeGen/X86/sink-local-value.ll
|
||||
+++ b/llvm/test/CodeGen/X86/sink-local-value.ll
|
||||
--- llvm/test/CodeGen/X86/sink-local-value.ll
|
||||
+++ llvm/test/CodeGen/X86/sink-local-value.ll
|
||||
@@ -145,6 +145,42 @@ try.cont: ; preds = %entry, %lpad
|
||||
; CHECK: retl
|
||||
|
||||
|
|
|
@ -21,8 +21,8 @@ llvm-svn: 373184
|
|||
|
||||
diff --git a/llvm/lib/Analysis/ScalarEvolution.cpp b/llvm/lib/Analysis/ScalarEvolution.cpp
|
||||
index 354ae05bb841..c29fc5dbccfb 100644
|
||||
--- a/llvm/lib/Analysis/ScalarEvolution.cpp
|
||||
+++ b/llvm/lib/Analysis/ScalarEvolution.cpp
|
||||
--- llvm/lib/Analysis/ScalarEvolution.cpp
|
||||
+++ llvm/lib/Analysis/ScalarEvolution.cpp
|
||||
@@ -4992,7 +4992,7 @@ const SCEV *ScalarEvolution::createSimpleAffineAddRec(PHINode *PN,
|
||||
// overflow.
|
||||
if (auto *BEInst = dyn_cast<Instruction>(BEValueV))
|
||||
|
@ -34,8 +34,8 @@ index 354ae05bb841..c29fc5dbccfb 100644
|
|||
}
|
||||
diff --git a/llvm/test/Analysis/ScalarEvolution/limit-depth.ll b/llvm/test/Analysis/ScalarEvolution/limit-depth.ll
|
||||
index db68a4f84c91..6fdf8c5df974 100644
|
||||
--- a/llvm/test/Analysis/ScalarEvolution/limit-depth.ll
|
||||
+++ b/llvm/test/Analysis/ScalarEvolution/limit-depth.ll
|
||||
--- llvm/test/Analysis/ScalarEvolution/limit-depth.ll
|
||||
+++ llvm/test/Analysis/ScalarEvolution/limit-depth.ll
|
||||
@@ -46,7 +46,7 @@ define void @test_mul(i32 %a, i32 %b, i32 %c, i32 %d, i32 %e, i32 %f) {
|
||||
define void @test_sext(i32 %a, i32 %b, i32 %c, i32 %d, i32 %e, i32 %f) {
|
||||
; CHECK-LABEL: @test_sext
|
||||
|
@ -47,8 +47,8 @@ index db68a4f84c91..6fdf8c5df974 100644
|
|||
|
||||
diff --git a/llvm/test/Analysis/ScalarEvolution/nsw.ll b/llvm/test/Analysis/ScalarEvolution/nsw.ll
|
||||
index 69427368625d..ca24f9d4a04b 100644
|
||||
--- a/llvm/test/Analysis/ScalarEvolution/nsw.ll
|
||||
+++ b/llvm/test/Analysis/ScalarEvolution/nsw.ll
|
||||
--- llvm/test/Analysis/ScalarEvolution/nsw.ll
|
||||
+++ llvm/test/Analysis/ScalarEvolution/nsw.ll
|
||||
@@ -163,7 +163,7 @@ bb5: ; preds = %bb2
|
||||
declare void @f(i32)
|
||||
|
||||
|
@ -60,8 +60,8 @@ index 69427368625d..ca24f9d4a04b 100644
|
|||
%add = add nsw i32 %v, 1
|
||||
diff --git a/llvm/test/Analysis/ScalarEvolution/trip-count12.ll b/llvm/test/Analysis/ScalarEvolution/trip-count12.ll
|
||||
index 5e7d72d5e4f3..d0086ee2e6ac 100644
|
||||
--- a/llvm/test/Analysis/ScalarEvolution/trip-count12.ll
|
||||
+++ b/llvm/test/Analysis/ScalarEvolution/trip-count12.ll
|
||||
--- llvm/test/Analysis/ScalarEvolution/trip-count12.ll
|
||||
+++ llvm/test/Analysis/ScalarEvolution/trip-count12.ll
|
||||
@@ -1,7 +1,7 @@
|
||||
; RUN: opt < %s -analyze -scalar-evolution | FileCheck %s
|
||||
|
||||
|
@ -73,8 +73,8 @@ index 5e7d72d5e4f3..d0086ee2e6ac 100644
|
|||
define zeroext i16 @test(i16* nocapture %p, i32 %len) nounwind readonly {
|
||||
diff --git a/llvm/test/Analysis/ScalarEvolution/trip-count9.ll b/llvm/test/Analysis/ScalarEvolution/trip-count9.ll
|
||||
index c0a1d12fa00e..9a080b34743f 100644
|
||||
--- a/llvm/test/Analysis/ScalarEvolution/trip-count9.ll
|
||||
+++ b/llvm/test/Analysis/ScalarEvolution/trip-count9.ll
|
||||
--- llvm/test/Analysis/ScalarEvolution/trip-count9.ll
|
||||
+++ llvm/test/Analysis/ScalarEvolution/trip-count9.ll
|
||||
@@ -179,7 +179,7 @@ exit:
|
||||
}
|
||||
|
||||
|
|
Reference in New Issue