gnu: ffmpeg-jami: Enable pipewire support.
* gnu/packages/video.scm (ffmpeg-jami) [arguments]: Update configure flags. [inputs]: Add pipewire. * gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch: Fix includes. Change-Id: Ife3bf532496bc06144c1cbbcea50e406a58ecc7amaster
parent
def8733e03
commit
9e5d9f4a2d
|
@ -75,7 +75,7 @@ new file mode 100644
|
||||||
index 0000000000..ff9c3468ab
|
index 0000000000..ff9c3468ab
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/libavfilter/vsrc_pipewiregrab.c
|
+++ b/libavfilter/vsrc_pipewiregrab.c
|
||||||
@@ -0,0 +1,1373 @@
|
@@ -0,0 +1,1375 @@
|
||||||
+/*
|
+/*
|
||||||
+ * PipeWire input grabber (ScreenCast)
|
+ * PipeWire input grabber (ScreenCast)
|
||||||
+ * Copyright (C) 2024 Savoir-faire Linux, Inc.
|
+ * Copyright (C) 2024 Savoir-faire Linux, Inc.
|
||||||
|
@ -117,6 +117,8 @@ index 0000000000..ff9c3468ab
|
||||||
+#include <sys/mman.h>
|
+#include <sys/mman.h>
|
||||||
+#include <sys/queue.h>
|
+#include <sys/queue.h>
|
||||||
+
|
+
|
||||||
|
+#include "libavfilter/formats.h"
|
||||||
|
+#include "libavfilter/video.h"
|
||||||
+#include "libavutil/internal.h"
|
+#include "libavutil/internal.h"
|
||||||
+#include "libavutil/mathematics.h"
|
+#include "libavutil/mathematics.h"
|
||||||
+#include "libavutil/opt.h"
|
+#include "libavutil/opt.h"
|
||||||
|
|
|
@ -2050,6 +2050,11 @@ audio/video codec library.")
|
||||||
"--disable-programs"
|
"--disable-programs"
|
||||||
"--disable-postproc"
|
"--disable-postproc"
|
||||||
|
|
||||||
|
"--enable-libpipewire"
|
||||||
|
"--enable-filter=pipewiregrab"
|
||||||
|
"--enable-indev=lavfi"
|
||||||
|
"--enable-decoder=wrapped_avframe"
|
||||||
|
|
||||||
"--disable-protocols"
|
"--disable-protocols"
|
||||||
"--enable-protocol=crypto"
|
"--enable-protocol=crypto"
|
||||||
"--enable-protocol=file"
|
"--enable-protocol=file"
|
||||||
|
@ -2257,7 +2262,9 @@ audio/video codec library.")
|
||||||
"--enable-encoder=vp8_vaapi"
|
"--enable-encoder=vp8_vaapi"
|
||||||
"--enable-encoder=mjpeg_vaapi"
|
"--enable-encoder=mjpeg_vaapi"
|
||||||
"--enable-encoder=hevc_vaapi")
|
"--enable-encoder=hevc_vaapi")
|
||||||
'())))))))
|
'())))))
|
||||||
|
(inputs (modify-inputs (package-inputs ffmpeg)
|
||||||
|
(append pipewire)))))
|
||||||
|
|
||||||
(define-public ffmpegthumbnailer
|
(define-public ffmpegthumbnailer
|
||||||
(package
|
(package
|
||||||
|
|
Reference in New Issue