From 9f33d76c33545ea2f47981ba5ec5936cdf767f3f Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Mon, 7 Jan 2019 16:40:27 +0100
Subject: [PATCH] gnu: Add r-qlcmatrix.

* gnu/packages/cran.scm (r-qlcmatrix): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0b59c8f832..b1a23b9eb1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8794,3 +8794,30 @@ large datasets (> 100,000 samples) very efficiently.")
     (synopsis "Combinatorics utilities")
     (description "This package provides assorted routines for combinatorics.")
     (license license:gpl2)))
+
+(define-public r-qlcmatrix
+  (package
+    (name "r-qlcmatrix")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "qlcMatrix" version))
+       (sha256
+        (base32
+         "0iqkcvvy8rxlk0s83sjq57dd6fadb18p5z31lzy0gnzv1hsy1x8y"))))
+    (properties `((upstream-name . "qlcMatrix")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-docopt" ,r-docopt)
+       ("r-matrix" ,r-matrix)
+       ("r-slam" ,r-slam)
+       ("r-sparsesvd" ,r-sparsesvd)))
+    (home-page "https://cran.r-project.org/web/packages/qlcMatrix")
+    (synopsis "Sparse matrix functions for quantitative language comparison")
+    (description
+     "This package provides an extension of the functionality of the Matrix
+package for using sparse matrices.  Some of the functions are very general,
+while other are highly specific for the special data format used for
+@dfn{quantitative language comparison} (QLC).")
+    (license license:gpl3)))