me
/
guix
Archived
1
0
Fork 0

gnu: hplip: Update to 3.20.9 [security fixes].

* gnu/packages/cups.scm (hplip): Update to 3.20.9.
[source]: Add hplip-fix-bug-1898438.patch.
[arguments]: Follow upstream defaults.
* gnu/packages/patches/hplip-fix-bug-1898438.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Tobias Geerinckx-Rice 2020-10-04 13:35:46 +02:00
parent 85c84b1071
commit a2f2513724
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 24 additions and 6 deletions

View File

@ -1134,6 +1134,7 @@ dist_patch_DATA = \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hurd-cross.patch \
%D%/packages/patches/hurd-xattr.patch \
%D%/packages/patches/hplip-fix-bug-1898438.patch \
%D%/packages/patches/hplip-remove-imageprocessor.patch \
%D%/packages/patches/hydra-disable-darcs-test.patch \
%D%/packages/patches/icecat-makeicecat.patch \

View File

@ -415,16 +415,17 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
(version "3.20.6")
(version "3.20.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
"083w58wpvvm6sir6rf5dwx3r0rman9sv1zpl26chl0a88crjsjy6"))
"1prdbp410405xrfggjc7y34nzljg7jnbgjzalgv4khwwma4i299n"))
(modules '((guix build utils)))
(patches (search-patches "hplip-remove-imageprocessor.patch"))
(patches (search-patches "hplip-fix-bug-1898438.patch"
"hplip-remove-imageprocessor.patch"))
(snippet
'(begin
;; Delete non-free blobs: .so files, pre-compiled
@ -465,10 +466,7 @@ should only be used as part of the Guix cups-pk-helper service.")
(assoc-ref %outputs "out") "/lib")
;; Disable until mime.types merging works (FIXME).
"--disable-fax-build"
"--enable-hpcups-install"
"--enable-new-hpcups"
"--enable-cups_ppd_install"
"--enable-cups_drv_install"
;; TODO add foomatic drv install eventually.
;; TODO --enable-policykit eventually.
,(string-append "--with-cupsfilterdir="

View File

@ -0,0 +1,19 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 04 Oct 2020 13:28:49 +0200
Subject: [PATCH] gnu: hplip: Fix non-network builds (bug #1898438)
Reported as <https://bugs.launchpad.net/hplip/+bug/1898438>.
diff -Naur a/scan/sane/hpaio.c b/scan/sane/hpaio.c
--- a/scan/sane/hpaio.c 1970-01-01 01:00:01.000000000 +0100
+++ b/scan/sane/hpaio.c 2020-10-04 13:26:34.665244052 +0200
@@ -36,7 +36,9 @@
#include <string.h>
#include <cups/cups.h>
#include "hpmud.h"
+#ifdef HAVE_LIBNETSNMP
#include "avahiDiscovery.h"
+#endif
#include "hp_ipp.h"
#include "soap.h"
#include "soapht.h"