me
/
guix
Archived
1
0
Fork 0

gnu: picard: Update to 2.8.3, modernize package.

* gnu/packages/music.scm (picard): Update to 2.8.3.
[source]: Remove patch.
[arguments]: Use G-expressions. Remove trailing #t.
[native-inputs]: Remove input labels.
[inputs]: Add python-fasteners, python-pyyaml, python-markdown, python-pyjwt. Remove a transitive
dependency on QtWebKit. See <https://issues.guix.gnu.org/53289> for more information about this change.
* gnu/packages/patches/picard-fix-id3-rename-test.patch: Remove it.
* gnu/local.mk (dist_path_DATA): Update accordingly.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
master
kiasoc5 2022-09-24 01:39:00 -04:00 committed by Mathieu Othacehe
parent 0f66ef9aa9
commit a47a051e3d
No known key found for this signature in database
GPG Key ID: 8354763531769CA6
3 changed files with 26 additions and 33 deletions

View File

@ -1653,7 +1653,6 @@ dist_patch_DATA = \
%D%/packages/patches/phoronix-test-suite-fsdg.patch \
%D%/packages/patches/php-bug-74093-test.patch \
%D%/packages/patches/php-curl-compat.patch \
%D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pinball-system-ltdl.patch \

View File

@ -3524,7 +3524,7 @@ event-based scripts for scrobbling, notifications, etc.")
(define-public picard
(package
(name "picard")
(version "2.4.4")
(version "2.8.3")
(source (origin
(method url-fetch)
(uri (string-append
@ -3532,30 +3532,35 @@ event-based scripts for scrobbling, notifications, etc.")
"picard/picard-" version ".tar.gz"))
(sha256
(base32
"1c5l7i43jaj3s4wklc0cba6nn2x9cmpcggk4q4h9m1bci2xilsiy"))
(patches (search-patches "picard-fix-id3-rename-test.patch"))))
"0h4yk1y4k23hkfk7k2in27rd34ani857m0vvn7xa8vxizz951dka"))))
(build-system python-build-system)
(arguments
'(#:use-setuptools? #f
#:configure-flags
(list "--root=/"
;; Don't phone home or show Check for Update… in the Help menu.
"--disable-autoupdate")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "picard/const/__init__.py"
(("pyfpcalc")
(string-append
"pyfpcalc', '"
(assoc-ref inputs "chromaprint") "/bin/fpcalc")))
#t)))))
(list
#:use-setuptools? #f
#:configure-flags
#~(list "--root=/"
;; Don't phone home or show Check for Update… in the Help menu.
"--disable-autoupdate")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "picard/const/__init__.py"
(("pyfpcalc")
(string-append
"pyfpcalc', '"
(assoc-ref inputs "chromaprint") "/bin/fpcalc"))))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("python-dateutil" ,python-dateutil)))
(list gettext-minimal python-dateutil))
(inputs
(list chromaprint python-discid python-pyqt python-mutagen))
(list chromaprint
python-discid
python-pyqt-without-qtwebkit
python-mutagen
python-fasteners
python-pyyaml
python-markdown
python-pyjwt))
(home-page "https://picard.musicbrainz.org/")
(synopsis "Graphical music tagging application")
(description

View File

@ -1,11 +0,0 @@
Index: b/test/formats/test_id3.py
===================================================================
--- a/test/formats/test_id3.py
+++ b/test/formats/test_id3.py
@@ -266,5 +266,5 @@
def test_rename_txxx_tags(self):
file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
- filename = self.copy_file_tmp(file_path, 'mp3')
+ filename = self.copy_file_tmp(file_path, '.mp3')
raw_metadata = load_raw(filename)
self.assertIn('TXXX:Artists', raw_metadata)