me
/
guix
Archived
1
0
Fork 0

gnu: r-sapa: Patch call of dstebz routine.

* gnu/packages/patches/r-sapa-lapack.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/cran.scm (r-sapa)[source]: Add it.

Change-Id: I17354c4e8b3a0f322e17c9a1e17bc37c93630105
master
Ricardo Wurmus 2024-01-30 15:06:24 +01:00
parent a874d44053
commit a4e75305e2
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
3 changed files with 27 additions and 1 deletions

View File

@ -1969,6 +1969,7 @@ dist_patch_DATA = \
%D%/packages/patches/renpy-use-system-fribidi.patch \
%D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
%D%/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch \
%D%/packages/patches/r-sapa-lapack.patch \
%D%/packages/patches/ri-li-modernize_cpp.patch \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \

View File

@ -62,6 +62,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@ -11144,7 +11145,8 @@ sapa R packages.")
(uri (cran-uri "sapa" version))
(sha256
(base32
"0kj681rd4c2lvqr926lb6f4qwp281x5274dg6vbk8pf5y7s0qlpc"))))
"0kj681rd4c2lvqr926lb6f4qwp281x5274dg6vbk8pf5y7s0qlpc"))
(patches (search-patches "r-sapa-lapack.patch"))))
(build-system r-build-system)
(propagated-inputs
(list r-ifultools r-splus2r))

View File

@ -0,0 +1,23 @@
From 5eb1faf8ee2eac3057ef55c99dd3083242559b9e Mon Sep 17 00:00:00 2001
From: dbpercival <dbpercival@gmail.com>
Date: Sat, 8 Jul 2023 16:26:35 -0700
Subject: [PATCH] Update sapa_lapack.c
Stephen's suggested change
---
src/sapa_lapack.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/sapa_lapack.c b/src/sapa_lapack.c
index eff4851..a520e33 100644
--- a/src/sapa_lapack.c
+++ b/src/sapa_lapack.c
@@ -102,7 +102,7 @@ SEXP R_sapa_dpss(SEXP nsample, SEXP ntaper, SEXP bandwidth)
ISPLIT,
WORK1,
IWORK1,
- &INFO);
+ &INFO FCONE FCONE);
// if (INFO != 0)
// error(_("error code %d from LAPACK routine '%s'"), info, "dstebz");