gnu: agda: Update to 2.6.4.
* gnu/packages/agda.scm (agda): Update to 2.6.4. Also build with optimizations and cluster counting support. * gnu/packages/patches/agda-use-sphinx-5.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I98a66678ec401b9201d9fd3a0f606fff9767b4bcmaster
parent
5cb2574243
commit
a521757306
|
@ -900,6 +900,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/agda-categories-remove-incompatible-flags.patch \
|
%D%/packages/patches/agda-categories-remove-incompatible-flags.patch \
|
||||||
%D%/packages/patches/agda-categories-use-find.patch \
|
%D%/packages/patches/agda-categories-use-find.patch \
|
||||||
%D%/packages/patches/agda-libdirs-env-variable.patch \
|
%D%/packages/patches/agda-libdirs-env-variable.patch \
|
||||||
|
%D%/packages/patches/agda-use-sphinx-5.patch \
|
||||||
%D%/packages/patches/agda-stdlib-use-runhaskell.patch \
|
%D%/packages/patches/agda-stdlib-use-runhaskell.patch \
|
||||||
%D%/packages/patches/agg-am_c_prototype.patch \
|
%D%/packages/patches/agg-am_c_prototype.patch \
|
||||||
%D%/packages/patches/agg-2.5-gcc8.patch \
|
%D%/packages/patches/agg-2.5-gcc8.patch \
|
||||||
|
|
|
@ -44,7 +44,7 @@
|
||||||
(define-public agda
|
(define-public agda
|
||||||
(package
|
(package
|
||||||
(name "agda")
|
(name "agda")
|
||||||
(version "2.6.3")
|
(version "2.6.4")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -53,12 +53,14 @@
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1s7zd01i8pmvi90ywx497kc07z50nah7h0fc2dn6jzb132k5sh1q"))
|
(base32 "0n4avd58j45rdcmnwgrmz5s0ril0z4n2z711mwwbahl50f7359ky"))
|
||||||
(patches (search-patches "agda-libdirs-env-variable.patch"))))
|
(patches (search-patches "agda-libdirs-env-variable.patch"
|
||||||
|
"agda-use-sphinx-5.patch"))))
|
||||||
(build-system haskell-build-system)
|
(build-system haskell-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
(list ghc-aeson
|
(list ghc-aeson
|
||||||
ghc-alex
|
ghc-alex
|
||||||
|
ghc-ansi-terminal
|
||||||
ghc-async
|
ghc-async
|
||||||
ghc-blaze-html
|
ghc-blaze-html
|
||||||
ghc-boxes
|
ghc-boxes
|
||||||
|
@ -73,9 +75,11 @@
|
||||||
ghc-monad-control
|
ghc-monad-control
|
||||||
ghc-murmur-hash
|
ghc-murmur-hash
|
||||||
ghc-parallel
|
ghc-parallel
|
||||||
|
ghc-peano
|
||||||
ghc-regex-tdfa
|
ghc-regex-tdfa
|
||||||
ghc-split
|
ghc-split
|
||||||
ghc-strict
|
ghc-strict
|
||||||
|
ghc-text-icu
|
||||||
ghc-unordered-containers
|
ghc-unordered-containers
|
||||||
ghc-uri-encode
|
ghc-uri-encode
|
||||||
ghc-vector-hashtables
|
ghc-vector-hashtables
|
||||||
|
@ -91,6 +95,7 @@
|
||||||
(guix build utils)
|
(guix build utils)
|
||||||
(srfi srfi-26)
|
(srfi srfi-26)
|
||||||
(ice-9 match))
|
(ice-9 match))
|
||||||
|
#:configure-flags #~(list "-foptimise-heavily" "-fenable-cluster-counting")
|
||||||
#:phases
|
#:phases
|
||||||
#~(modify-phases %standard-phases
|
#~(modify-phases %standard-phases
|
||||||
;; This allows us to call the 'agda' binary before installing.
|
;; This allows us to call the 'agda' binary before installing.
|
||||||
|
|
|
@ -0,0 +1,51 @@
|
||||||
|
From 99ed1b59ef73fd35053810f6a09e034e1513caee Mon Sep 17 00:00:00 2001
|
||||||
|
Message-ID: <99ed1b59ef73fd35053810f6a09e034e1513caee.1698243851.git.dev@jpoiret.xyz>
|
||||||
|
From: Josselin Poiret <dev@jpoiret.xyz>
|
||||||
|
Date: Wed, 25 Oct 2023 16:23:32 +0200
|
||||||
|
Subject: [PATCH] Revert "Docs: bump Sphinx to 6.0.0"
|
||||||
|
|
||||||
|
From: Josselin Poiret <dev@jpoiret.xyz>
|
||||||
|
|
||||||
|
This reverts commit 40dd42eaa7c04e134fa38cb4f958414a76df27a7.
|
||||||
|
---
|
||||||
|
doc/user-manual/conf.py | 5 ++---
|
||||||
|
doc/user-manual/requirements.txt | 4 ++--
|
||||||
|
2 files changed, 4 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/doc/user-manual/conf.py b/doc/user-manual/conf.py
|
||||||
|
index 127f6582dc..d737ede19b 100644
|
||||||
|
--- a/doc/user-manual/conf.py
|
||||||
|
+++ b/doc/user-manual/conf.py
|
||||||
|
@@ -35,7 +35,7 @@ release = version
|
||||||
|
#
|
||||||
|
# If your change the version here also change it in the
|
||||||
|
# `requirements.txt` file [Issue #1936].
|
||||||
|
-needs_sphinx = '6.0.0'
|
||||||
|
+needs_sphinx = '5.0.0'
|
||||||
|
|
||||||
|
# Add any Sphinx extension module names here, as strings. They can be
|
||||||
|
# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
|
||||||
|
@@ -43,8 +43,7 @@ needs_sphinx = '6.0.0'
|
||||||
|
extensions = [
|
||||||
|
'sphinx.ext.imgmath',
|
||||||
|
'sphinx.ext.ifconfig',
|
||||||
|
- 'sphinx.ext.imgconverter',
|
||||||
|
- 'sphinxcontrib.jquery'
|
||||||
|
+ 'sphinx.ext.imgconverter'
|
||||||
|
]
|
||||||
|
|
||||||
|
# Add any paths that contain templates here, relative to this directory.
|
||||||
|
diff --git a/doc/user-manual/requirements.txt b/doc/user-manual/requirements.txt
|
||||||
|
index 384b1466b4..656e6c9ac0 100644
|
||||||
|
--- a/doc/user-manual/requirements.txt
|
||||||
|
+++ b/doc/user-manual/requirements.txt
|
||||||
|
@@ -1,2 +1,2 @@
|
||||||
|
-Sphinx >= 7.2.5
|
||||||
|
-sphinx_rtd_theme >= 1.3.0
|
||||||
|
+Sphinx >= 5.0.0, != 5.2.0.post0
|
||||||
|
+sphinx_rtd_theme >= 1.0
|
||||||
|
|
||||||
|
base-commit: 08b79a684d712ba3dc4b26e5052ec49f49f5ff6c
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
Reference in New Issue