From a5df30816e69593ef660705ac5c5a3a022c45403 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:45:04 +0200
Subject: [PATCH] gnu: Add texlive-bophook.

* gnu/packages/tex.scm (texlive-bophook): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2aee6f7a73..79edbca706 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -74741,6 +74741,28 @@ The @code{\\switch} command (which is also expandable) has the form:
 expression>@} ...  ... \\otherwise ... \\endswitch}.")
     (license license:lppl)))
 
+(define-public texlive-bophook
+  (package
+    (name "texlive-bophook")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bophook/" "source/latex/bophook/"
+                   "tex/latex/bophook/")
+             (base32
+              "1zxaxrgjs4rpdsb2mbk4zslhy64md2m7ngc5p7w8cyjf1f7swb2h")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (home-page "https://ctan.org/pkg/bophook")
+    (synopsis "Provides an @code{\\AtBeginPage} hook")
+    (description
+     "Using the @code{\\AtBeginPage} hook provided by this package, you can add
+material in the background of a page.  @code{\\PageLayout} can be used to give
+page makeup commands to be executed on every page (e.g., depending on the page
+style).")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar