me
/
guix
Archived
1
0
Fork 0

gnu: cdrkit-libre: Fix cross-compiling.

* gnu/packages/cdrom.scm (cdrkit-libre)[source]: Add patch.
* gnu/packages/patches/cdrkit-libre-cross-compile.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
master
Efraim Flashner 2021-12-10 12:57:35 +02:00
parent 8908c82bf9
commit a66642f744
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 34 additions and 0 deletions

View File

@ -925,6 +925,7 @@ dist_patch_DATA = \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
%D%/packages/patches/circos-remove-findbin.patch \
%D%/packages/patches/cdparanoia-fpic.patch \
%D%/packages/patches/cdrkit-libre-cross-compile.patch \
%D%/packages/patches/cdrtools-3.01-mkisofs-isoinfo.patch \
%D%/packages/patches/ceph-disable-cpu-optimizations.patch \
%D%/packages/patches/ceph-boost-compat.patch \

View File

@ -929,6 +929,7 @@ Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
(sha256
(base32
"0g2zyzb56czh429qy87lvaddzjnlcq8c616ddxsmsshz3clhyzrh"))
(patches (search-patches "cdrkit-libre-cross-compile.patch"))
(modules '((guix build utils)))
(snippet
#~(begin

View File

@ -0,0 +1,32 @@
Patch extracted from a set of patches to cross-compile ffmeg and dependencies for mingw-w64.
https://github.com/Warblefly/MultimediaTools-mingw-w64/commit/01e30a17637b67afd65c1e24302f8daf94b19b32#diff-503bd595ad2a49840cc56acdb3432487a20a0acb7981ce83be51fe311216de8f
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 99a69fd..e5ba8a7 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -35,8 +35,6 @@ endif(VA_LIST_IS_ARRAY)
INCLUDE(TestBigEndian)
TEST_BIG_ENDIAN(WORDS_BIGENDIAN)
-TRY_RUN(BITFIELDS_HTOL TEST_DUMMY ${CMAKE_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/test_BITFIELDS_HTOL.c)
-
INCLUDE(CheckIncludeFiles)
#SET(CMAKE_REQUIRED_INCLUDES "/usr/include;/usr/local/include")
diff --git a/include/xconfig.h.in b/include/xconfig.h.in
index c130600..476c00b 100644
--- a/include/xconfig.h.in
+++ b/include/xconfig.h.in
@@ -233,7 +233,11 @@
/* If using network byte order */
#cmakedefine WORDS_BIGENDIAN
/* If high bits come first in structures */
-#cmakedefine BITFIELDS_HTOL
+#ifdef WORDS_BIGENDIAN
+#define BITFIELDS_HTOL
+#else
+#define BITFIELDS_LTOH
+#endif
#define HAVE_C_BIGENDIAN /* Flag that WORDS_BIGENDIAN test was done */
#define HAVE_C_BITFIELDS /* Flag that BITFIELDS_HTOL test was done */