gnu: openmw: Update to 0.48.0.
* gnu/packages/game-development.scm (openmw): Update to 0.48.0. * gnu/packages/graphics.scm (openmw-openscenegraph): Update to commit 68c5c5. Change-Id: I5e1ae0d59ead8de7976714cb82e8d514c308f19a Signed-off-by: Ludovic Courtès <ludo@gnu.org>
parent
ad0c116508
commit
a90bc8b6a8
|
@ -1728,7 +1728,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
|
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
|
||||||
%D%/packages/patches/openjdk-21-fix-rpath.patch \
|
%D%/packages/patches/openjdk-21-fix-rpath.patch \
|
||||||
%D%/packages/patches/openmpi-mtl-priorities.patch \
|
%D%/packages/patches/openmpi-mtl-priorities.patch \
|
||||||
%D%/packages/patches/openmw-assume-nonconst-SIGSTKSZ.patch \
|
|
||||||
%D%/packages/patches/openssh-trust-guix-store-directory.patch \
|
%D%/packages/patches/openssh-trust-guix-store-directory.patch \
|
||||||
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
||||||
%D%/packages/patches/openrgb-unbundle-hueplusplus.patch \
|
%D%/packages/patches/openrgb-unbundle-hueplusplus.patch \
|
||||||
|
|
|
@ -109,8 +109,10 @@
|
||||||
#:use-module (gnu packages readline)
|
#:use-module (gnu packages readline)
|
||||||
#:use-module (gnu packages qt)
|
#:use-module (gnu packages qt)
|
||||||
#:use-module (gnu packages sdl)
|
#:use-module (gnu packages sdl)
|
||||||
|
#:use-module (gnu packages serialization)
|
||||||
#:use-module (gnu packages speech)
|
#:use-module (gnu packages speech)
|
||||||
#:use-module (gnu packages sphinx)
|
#:use-module (gnu packages sphinx)
|
||||||
|
#:use-module (gnu packages sqlite)
|
||||||
#:use-module (gnu packages stb)
|
#:use-module (gnu packages stb)
|
||||||
#:use-module (gnu packages texinfo)
|
#:use-module (gnu packages texinfo)
|
||||||
#:use-module (gnu packages textutils)
|
#:use-module (gnu packages textutils)
|
||||||
|
@ -1841,38 +1843,37 @@ of use.")
|
||||||
(define-public openmw
|
(define-public openmw
|
||||||
(package
|
(package
|
||||||
(name "openmw")
|
(name "openmw")
|
||||||
(version "0.47.0")
|
(version "0.48.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
(url "https://github.com/OpenMW/openmw")
|
(url "https://github.com/OpenMW/openmw")
|
||||||
(commit (string-append "openmw-" version))))
|
(commit (string-append "openmw-" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32 "0amkxfylk1l67d2igihnhhql62xr89wvg1sxbq2rnhczf6vxaj6f"))))
|
||||||
"19mcbnjl4279qalb97msf965bjax48mx1r1qczyvwhn28h6n3bsy"))
|
|
||||||
(patches (search-patches "openmw-assume-nonconst-SIGSTKSZ.patch"))))
|
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; No test target
|
`(#:tests? #f ;No test target
|
||||||
#:configure-flags
|
#:configure-flags (list "-DDESIRED_QT_VERSION=5"
|
||||||
(list "-DDESIRED_QT_VERSION=5"
|
"-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON")))
|
||||||
"-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON")))
|
(native-inputs (list boost doxygen pkg-config))
|
||||||
(native-inputs
|
(inputs (list bullet
|
||||||
(list boost doxygen pkg-config))
|
ffmpeg
|
||||||
(inputs
|
libxt
|
||||||
(list bullet
|
lz4
|
||||||
ffmpeg-4 ; https://gitlab.com/OpenMW/openmw/-/issues/6631
|
mygui-gl ;OpenMW does not need Ogre.
|
||||||
libxt
|
openal
|
||||||
lz4
|
openmw-openscenegraph
|
||||||
mygui-gl ; OpenMW does not need Ogre.
|
qtbase-5
|
||||||
openal
|
recastnavigation
|
||||||
openmw-openscenegraph
|
sdl2
|
||||||
qtbase-5
|
unshield
|
||||||
recastnavigation
|
icu4c
|
||||||
sdl2
|
yaml-cpp
|
||||||
unshield))
|
luajit
|
||||||
|
sqlite))
|
||||||
(synopsis "Re-implementation of the RPG Morrowind engine")
|
(synopsis "Re-implementation of the RPG Morrowind engine")
|
||||||
(description
|
(description
|
||||||
"OpenMW is a game engine which reimplements and extends the one that runs
|
"OpenMW is a game engine which reimplements and extends the one that runs
|
||||||
|
|
|
@ -1490,11 +1490,11 @@ in Julia).")
|
||||||
(define-public openmw-openscenegraph
|
(define-public openmw-openscenegraph
|
||||||
;; OpenMW prefers its own fork of openscenegraph:
|
;; OpenMW prefers its own fork of openscenegraph:
|
||||||
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
|
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
|
||||||
(let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
|
(let ((commit "68c5c573d47766507bfb191e0c8d213b1997ad20"))
|
||||||
(hidden-package
|
(hidden-package
|
||||||
(package
|
(package
|
||||||
(inherit openscenegraph)
|
(inherit openscenegraph)
|
||||||
(version (git-version "3.6" "2" commit))
|
(version (git-version "3.6" "3" commit))
|
||||||
(outputs (list "out"))
|
(outputs (list "out"))
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
|
@ -1505,7 +1505,7 @@ in Julia).")
|
||||||
(file-name (git-file-name (package-name openscenegraph) version))
|
(file-name (git-file-name (package-name openscenegraph) version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
|
"12xgdmymjh4rb7djzniy15lvi45y0x4i0l5swf031r8g4zn72v2n"))))
|
||||||
(arguments
|
(arguments
|
||||||
(substitute-keyword-arguments (package-arguments openscenegraph)
|
(substitute-keyword-arguments (package-arguments openscenegraph)
|
||||||
((#:configure-flags flags)
|
((#:configure-flags flags)
|
||||||
|
|
|
@ -1,39 +0,0 @@
|
||||||
From 98a7d90ee258ceef9c70b0b2955d0458ec46f048 Mon Sep 17 00:00:00 2001
|
|
||||||
From: elsid <elsid.mail@gmail.com>
|
|
||||||
Date: Fri, 24 Sep 2021 19:40:29 +0200
|
|
||||||
Subject: [PATCH] Assume SIGSTKSZ is not a constant
|
|
||||||
|
|
||||||
SIGSTKSZ is not defined as constant since glibc 2.34:
|
|
||||||
https://sourceware.org/git/?p=glibc.git;a=commit;h=6c57d320484988e87e446e2e60ce42816bf51d53
|
|
||||||
---
|
|
||||||
components/crashcatcher/crashcatcher.cpp | 5 ++---
|
|
||||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/components/crashcatcher/crashcatcher.cpp b/components/crashcatcher/crashcatcher.cpp
|
|
||||||
index 86571e1e3a..c828e1ca81 100644
|
|
||||||
--- a/components/crashcatcher/crashcatcher.cpp
|
|
||||||
+++ b/components/crashcatcher/crashcatcher.cpp
|
|
||||||
@@ -56,8 +56,6 @@ static const char exec_err[] = "!!! Failed to exec debug process\n";
|
|
||||||
|
|
||||||
static char argv0[PATH_MAX];
|
|
||||||
|
|
||||||
-static char altstack[SIGSTKSZ];
|
|
||||||
-
|
|
||||||
|
|
||||||
static struct {
|
|
||||||
int signum;
|
|
||||||
@@ -475,9 +473,10 @@ int crashCatcherInstallHandlers(int argc, char **argv, int num_signals, int *sig
|
|
||||||
|
|
||||||
/* Set an alternate signal stack so SIGSEGVs caused by stack overflows
|
|
||||||
* still run */
|
|
||||||
+ static char* altstack = new char [SIGSTKSZ];
|
|
||||||
altss.ss_sp = altstack;
|
|
||||||
altss.ss_flags = 0;
|
|
||||||
- altss.ss_size = sizeof(altstack);
|
|
||||||
+ altss.ss_size = SIGSTKSZ;
|
|
||||||
sigaltstack(&altss, nullptr);
|
|
||||||
|
|
||||||
memset(&sa, 0, sizeof(sa));
|
|
||||||
--
|
|
||||||
GitLab
|
|
||||||
|
|
Reference in New Issue