gnu: netcdf: Update to 4.7.4.
This will fix an issue building qgis. * gnu/packages/maths.scm (netcdf): Update to 4.7.4. [source]: Remove the netcdf-tst_h_par.patch, also change the naming of the source tarball, as the name seems to have changed for recent releases. [inputs]: Update hdf5 and add curl. * gnu/packages/patches/netcdf-tst_h_par.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove deleted patch.
parent
24b233d45c
commit
a9291a28b2
|
@ -1355,7 +1355,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/m4-gnulib-libio.patch \
|
%D%/packages/patches/m4-gnulib-libio.patch \
|
||||||
%D%/packages/patches/ncompress-fix-softlinks.patch \
|
%D%/packages/patches/ncompress-fix-softlinks.patch \
|
||||||
%D%/packages/patches/netcdf-date-time.patch \
|
%D%/packages/patches/netcdf-date-time.patch \
|
||||||
%D%/packages/patches/netcdf-tst_h_par.patch \
|
|
||||||
%D%/packages/patches/netpbm-CVE-2017-2586.patch \
|
%D%/packages/patches/netpbm-CVE-2017-2586.patch \
|
||||||
%D%/packages/patches/netpbm-CVE-2017-2587.patch \
|
%D%/packages/patches/netpbm-CVE-2017-2587.patch \
|
||||||
%D%/packages/patches/netsurf-message-timestamp.patch \
|
%D%/packages/patches/netsurf-message-timestamp.patch \
|
||||||
|
|
|
@ -1538,17 +1538,17 @@ similar to MATLAB, GNU Octave or SciPy.")
|
||||||
(define-public netcdf
|
(define-public netcdf
|
||||||
(package
|
(package
|
||||||
(name "netcdf")
|
(name "netcdf")
|
||||||
(version "4.4.1.1")
|
(version "4.7.4")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://ftp.unidata.ucar.edu/pub/netcdf/"
|
(uri (string-append
|
||||||
"netcdf-" version ".tar.gz"))
|
"https://www.unidata.ucar.edu/downloads/netcdf/ftp/"
|
||||||
|
"netcdf-c-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1blc7ik5yin7i0ls2kag0a9xjk12m0dzx6v1x88az3ras3scci2d"))
|
"1a2fpp15a2rl1m50gcvvzd9y6bavl6vjf9zzf63sz5gdmq06yiqf"))
|
||||||
(patches (search-patches "netcdf-date-time.patch"
|
(patches (search-patches "netcdf-date-time.patch"))))
|
||||||
"netcdf-tst_h_par.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("m4" ,m4)
|
`(("m4" ,m4)
|
||||||
|
@ -1556,10 +1556,8 @@ similar to MATLAB, GNU Octave or SciPy.")
|
||||||
("graphviz" ,graphviz)))
|
("graphviz" ,graphviz)))
|
||||||
(inputs
|
(inputs
|
||||||
`(("hdf4" ,hdf4-alt)
|
`(("hdf4" ,hdf4-alt)
|
||||||
|
("hdf5" ,hdf5)
|
||||||
;; XXX: The 'tst_nccopy4.sh' test fails when using hdf5-1.10.
|
("curl" ,curl)
|
||||||
("hdf5" ,hdf5-1.8)
|
|
||||||
|
|
||||||
("zlib" ,zlib)
|
("zlib" ,zlib)
|
||||||
("libjpeg" ,libjpeg-turbo)))
|
("libjpeg" ,libjpeg-turbo)))
|
||||||
(arguments
|
(arguments
|
||||||
|
|
|
@ -3,9 +3,9 @@
|
||||||
@@ -13,7 +13,7 @@
|
@@ -13,7 +13,7 @@
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
/* Tell the user the version of netCDF. */
|
/** @internal The version string for the library, used by
|
||||||
|
* nc_inq_libvers(). */
|
||||||
-static const char nc_libvers[] = PACKAGE_VERSION " of "__DATE__" "__TIME__" $";
|
-static const char nc_libvers[] = PACKAGE_VERSION " of "__DATE__" "__TIME__" $";
|
||||||
+static const char nc_libvers[] = PACKAGE_VERSION" $";
|
+static const char nc_libvers[] = PACKAGE_VERSION " $";
|
||||||
|
|
||||||
/**
|
/**
|
||||||
\defgroup lib_version Library Version
|
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
From a83702834938b23cc2e843589aa223e2024a7e6f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Orion Poplawski <orion@cora.nwra.com>
|
|
||||||
Date: Tue, 29 Nov 2016 11:48:01 -0700
|
|
||||||
Subject: [PATCH] Add missing #include "err_macros.h" to tst_h_par.c
|
|
||||||
|
|
||||||
---
|
|
||||||
h5_test/tst_h_par.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/h5_test/tst_h_par.c b/h5_test/tst_h_par.c
|
|
||||||
index c3da7f4..a419d55 100644
|
|
||||||
--- a/h5_test/tst_h_par.c
|
|
||||||
+++ b/h5_test/tst_h_par.c
|
|
||||||
@@ -11,6 +11,7 @@
|
|
||||||
$Id: tst_h_par.c,v 1.15 2010/05/25 13:53:04 ed Exp $
|
|
||||||
*/
|
|
||||||
#include <nc_tests.h>
|
|
||||||
+#include "err_macros.h"
|
|
||||||
#include <hdf5.h>
|
|
||||||
|
|
||||||
/* Defining USE_MPE causes the MPE trace library to be used (and you
|
|
Reference in New Issue