gnu: Remove rapicorn.
* gnu/packages/graphics.scm (rapicorn): Delete variable. * gnu/packages/patches/rapicorn-isnan.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): De-register it.
parent
00dff2c768
commit
aad73bb58e
|
@ -1747,7 +1747,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ragel-char-signedness.patch \
|
||||
%D%/packages/patches/randomjungle-disable-static-build.patch \
|
||||
%D%/packages/patches/range-v3-build-with-gcc10.patch \
|
||||
%D%/packages/patches/rapicorn-isnan.patch \
|
||||
%D%/packages/patches/rapidjson-gcc-compat.patch \
|
||||
%D%/packages/patches/raptor2-heap-overflow.patch \
|
||||
%D%/packages/patches/ratpoints-sturm_and_rp_private.patch \
|
||||
|
|
|
@ -1361,73 +1361,6 @@ realistic reflections, shading, perspective and other effects.")
|
|||
(home-page "http://www.povray.org/")
|
||||
(license license:agpl3+)))
|
||||
|
||||
(define-public rapicorn
|
||||
(package
|
||||
(name "rapicorn")
|
||||
(version "16.0.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://testbit.eu/pub/dists/rapicorn/"
|
||||
"rapicorn-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1y51yjrpsihas1jy905m9p3r8iiyhq6bwi2690c564i5dnix1f9d"))
|
||||
(patches (search-patches "rapicorn-isnan.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-tests
|
||||
(lambda _
|
||||
;; Our grep does not support perl regular expressions.
|
||||
(substitute* "taptool.sh"
|
||||
(("grep -P") "grep -E"))
|
||||
;; Disable path tests because we cannot access /bin or /sbin.
|
||||
(substitute* "rcore/tests/multitest.cc"
|
||||
(("TCMP \\(Path::equals \\(\"/bin\"") "//"))
|
||||
#t))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda _
|
||||
;; The test suite requires a running X server (with DISPLAY
|
||||
;; number 99 or higher).
|
||||
(system "Xvfb :99 &")
|
||||
(setenv "DISPLAY" ":99")
|
||||
#t))
|
||||
(add-after 'unpack 'replace-fhs-paths
|
||||
(lambda _
|
||||
(substitute* (cons "Makefile.decl"
|
||||
(find-files "." "^Makefile\\.in$"))
|
||||
(("/bin/ls") (which "ls"))
|
||||
(("/usr/bin/env") (which "env")))
|
||||
#t)))))
|
||||
;; These libraries are listed in the "Required" section of the pkg-config
|
||||
;; file.
|
||||
(propagated-inputs
|
||||
(list librsvg cairo pango libxml2 python2-enum34))
|
||||
(inputs
|
||||
`(("gdk-pixbuf" ,gdk-pixbuf)
|
||||
("libpng" ,libpng-1.2)
|
||||
("readline" ,readline)
|
||||
("libcroco" ,libcroco)
|
||||
("python" ,python-2)
|
||||
("cython" ,python2-cython)))
|
||||
(native-inputs
|
||||
`(("pandoc" ,pandoc)
|
||||
("bison" ,bison)
|
||||
("flex" ,flex)
|
||||
("doxygen" ,doxygen)
|
||||
("graphviz" ,graphviz)
|
||||
("intltool" ,intltool)
|
||||
("pkg-config" ,pkg-config)
|
||||
("xvfb" ,xorg-server-for-tests)))
|
||||
(home-page "https://rapicorn.testbit.org/")
|
||||
(synopsis "Toolkit for rapid development of user interfaces")
|
||||
(description
|
||||
"Rapicorn is a toolkit for rapid development of user interfaces in C++
|
||||
and Python. The user interface is designed in a declarative markup language
|
||||
and is connected to the programming logic using data bindings and commands.")
|
||||
(license license:mpl2.0)))
|
||||
|
||||
(define-public ctl
|
||||
(package
|
||||
(name "ctl")
|
||||
|
|
|
@ -1,87 +0,0 @@
|
|||
From e0c8341b3e4e13778bcde00d477e461ea8e94306 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Westerfeld <stefan@space.twc.de>
|
||||
Date: Fri, 22 Apr 2016 18:03:37 +0200
|
||||
Subject: [PATCH 031/176] RCORE: compile fixes for KUbuntu 16.04/gcc
|
||||
5.3.1-14ubuntu2
|
||||
|
||||
Rapicorn uses isnan(...) and isinf(...) from cmath.h, however on KUbuntu 16.04
|
||||
it should use std::isnan(...) and std::isinf(...) instead. Patch below.
|
||||
|
||||
Acked-by: Tim Janik <timj@gnu.org>
|
||||
---
|
||||
rcore/strings.cc | 10 +++++-----
|
||||
rcore/tests/benchrcore.cc | 4 ++--
|
||||
rcore/tests/strings.cc | 4 ++--
|
||||
3 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/rcore/strings.cc b/rcore/strings.cc
|
||||
index d5b0216..8b3bc3f 100644
|
||||
--- a/rcore/strings.cc
|
||||
+++ b/rcore/strings.cc
|
||||
@@ -437,7 +437,7 @@ static long double
|
||||
libc_strtold (const char *nptr, char **endptr)
|
||||
{
|
||||
const long double result = strtold (nptr, endptr);
|
||||
- if (isnan (result) && std::signbit (result) == 0)
|
||||
+ if (std::isnan (result) && std::signbit (result) == 0)
|
||||
{
|
||||
const char *p = nptr;
|
||||
while (isspace (*p))
|
||||
@@ -500,9 +500,9 @@ string_to_double (const char *dblstring, const char **endptr)
|
||||
String
|
||||
string_from_float (float value)
|
||||
{
|
||||
- if (isnan (value))
|
||||
+ if (std::isnan (value))
|
||||
return std::signbit (value) ? "-NaN" : "+NaN";
|
||||
- if (isinf (value))
|
||||
+ if (std::isinf (value))
|
||||
return std::signbit (value) ? "-Infinity" : "+Infinity";
|
||||
return string_format ("%.7g", value);
|
||||
}
|
||||
@@ -511,9 +511,9 @@ string_from_float (float value)
|
||||
String
|
||||
string_from_double (double value)
|
||||
{
|
||||
- if (isnan (value))
|
||||
+ if (std::isnan (value))
|
||||
return std::signbit (value) ? "-NaN" : "+NaN";
|
||||
- if (isinf (value))
|
||||
+ if (std::isinf (value))
|
||||
return std::signbit (value) ? "-Infinity" : "+Infinity";
|
||||
return string_format ("%.17g", value);
|
||||
}
|
||||
diff --git a/rcore/tests/benchrcore.cc b/rcore/tests/benchrcore.cc
|
||||
index 3899a08..12fde16 100644
|
||||
--- a/rcore/tests/benchrcore.cc
|
||||
+++ b/rcore/tests/benchrcore.cc
|
||||
@@ -188,8 +188,8 @@ test_random_numbers()
|
||||
const double rf = random_frange (989617512, 9876547656);
|
||||
TASSERT (rf >= 989617512 && rf < 9876547656);
|
||||
}
|
||||
- TASSERT (isnan (random_frange (NAN, 1)));
|
||||
- TASSERT (isnan (random_frange (0, NAN)));
|
||||
+ TASSERT (std::isnan (random_frange (NAN, 1)));
|
||||
+ TASSERT (std::isnan (random_frange (0, NAN)));
|
||||
#if 0 // example penalty paid in random_int64()
|
||||
size_t i, j = 0;
|
||||
for (i = 0; i < 100; i++)
|
||||
diff --git a/rcore/tests/strings.cc b/rcore/tests/strings.cc
|
||||
index 468a6e6..dae3e3d 100644
|
||||
--- a/rcore/tests/strings.cc
|
||||
+++ b/rcore/tests/strings.cc
|
||||
@@ -311,9 +311,9 @@ string_conversions (void)
|
||||
TCMP (string_to_double ("-0.5"), ==, -0.5);
|
||||
double tfloat;
|
||||
tfloat = string_to_double ("+NAN");
|
||||
- assert (isnan (tfloat) && std::signbit (tfloat) == 0);
|
||||
+ assert (std::isnan (tfloat) && std::signbit (tfloat) == 0);
|
||||
tfloat = string_to_double ("-NAN");
|
||||
- assert (isnan (tfloat) && std::signbit (tfloat) == 1);
|
||||
+ assert (std::isnan (tfloat) && std::signbit (tfloat) == 1);
|
||||
TCMP (string_capitalize ("fOO bar"), ==, "Foo Bar");
|
||||
TCMP (string_capitalize ("foo BAR BAZ", 2), ==, "Foo Bar BAZ");
|
||||
}
|
||||
--
|
||||
2.9.1
|
||||
|
Reference in New Issue