gnu: rust-nettle-sys-2: Update to 2.2.0.
* gnu/packages/crates-io.scm (rust-nettle-sys-2): Update to 2.2.0. [source]: Remove patch. [cargo-inputs]: Add rust-cc-1, rust-libc-0.2, rust-tempfile-3, rust-vcpkg-0.2. Replace rust-bindgen-0.51 with 0.63. * gnu/packages/patches/rust-nettle-sys-disable-vendor.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a6aadf5a7b
commit
ab008c4a90
3 changed files with 8 additions and 54 deletions
|
@ -1917,7 +1917,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
|
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
|
||||||
%D%/packages/patches/rust-ndarray-0.14-remove-blas-src.patch \
|
%D%/packages/patches/rust-ndarray-0.14-remove-blas-src.patch \
|
||||||
%D%/packages/patches/rust-nettle-disable-vendor.patch \
|
%D%/packages/patches/rust-nettle-disable-vendor.patch \
|
||||||
%D%/packages/patches/rust-nettle-sys-disable-vendor.patch \
|
|
||||||
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
|
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
|
||||||
%D%/packages/patches/rust-webbrowser-remove-unsupported-os.patch \
|
%D%/packages/patches/rust-webbrowser-remove-unsupported-os.patch \
|
||||||
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
|
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
|
||||||
|
|
|
@ -38520,15 +38520,14 @@ cryptographic library.")
|
||||||
(define-public rust-nettle-sys-2
|
(define-public rust-nettle-sys-2
|
||||||
(package
|
(package
|
||||||
(name "rust-nettle-sys")
|
(name "rust-nettle-sys")
|
||||||
(version "2.0.4")
|
(version "2.2.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (crate-uri "nettle-sys" version))
|
(uri (crate-uri "nettle-sys" version))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1yq1w6dlcmg89x529i7s20j29afdhgim7qnsa7978fszzwrr6qmq"))
|
(base32 "0wwa7pmxdz7yl9jwybml2kmrj3i87jcn0h0cdc5xl0lhgcs1rs5m"))))
|
||||||
(patches (search-patches "rust-nettle-sys-disable-vendor.patch"))))
|
|
||||||
(build-system cargo-build-system)
|
(build-system cargo-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list clang pkg-config))
|
(list clang pkg-config))
|
||||||
|
@ -38536,8 +38535,12 @@ cryptographic library.")
|
||||||
(list nettle))
|
(list nettle))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:cargo-inputs
|
`(#:cargo-inputs
|
||||||
(("rust-bindgen" ,rust-bindgen-0.51)
|
(("rust-bindgen" ,rust-bindgen-0.63)
|
||||||
("rust-pkg-config" ,rust-pkg-config-0.3))))
|
("rust-cc" ,rust-cc-1)
|
||||||
|
("rust-libc" ,rust-libc-0.2)
|
||||||
|
("rust-pkg-config" ,rust-pkg-config-0.3)
|
||||||
|
("rust-tempfile" ,rust-tempfile-3)
|
||||||
|
("rust-vcpkg" ,rust-vcpkg-0.2))))
|
||||||
(home-page "https://gitlab.com/sequoia-pgp/nettle-sys")
|
(home-page "https://gitlab.com/sequoia-pgp/nettle-sys")
|
||||||
(synopsis "Low-level Rust bindings for the Nettle cryptographic library")
|
(synopsis "Low-level Rust bindings for the Nettle cryptographic library")
|
||||||
(description "This package provides low-level Rust bindings for the Nettle
|
(description "This package provides low-level Rust bindings for the Nettle
|
||||||
|
|
|
@ -1,48 +0,0 @@
|
||||||
Subject: nettle-sys: clear out "vendored" feature cruft from build.rs
|
|
||||||
From: Daniel Kahn Gillmor's avatarDaniel Kahn Gillmor <dkg@fifthhorseman.net>
|
|
||||||
|
|
||||||
https://salsa.debian.org/rust-team/debcargo-conf/-/commit/0c71150ad26bb66a8396dcdab055181af232ddc5
|
|
||||||
https://sources.debian.org/src/rust-nettle-sys/2.0.4-3/debian/patches/disable-vendor.diff/
|
|
||||||
--- a/Cargo.toml 2019-10-23 13:08:07.000000000 -0400
|
|
||||||
+++ b/Cargo.toml 2019-10-23 14:08:46.644064014 -0400
|
|
||||||
@@ -29,12 +29,9 @@
|
|
||||||
version = "0.51.1"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
-[build-dependencies.nettle-src]
|
|
||||||
-version = "3.5.1-0"
|
|
||||||
-optional = true
|
|
||||||
-
|
|
||||||
[build-dependencies.pkg-config]
|
|
||||||
version = "0.3"
|
|
||||||
|
|
||||||
[features]
|
|
||||||
vendored = ["nettle-src"]
|
|
||||||
+nettle-src = []
|
|
||||||
diff --git a/build.rs b/build.rs
|
|
||||||
index 44f7af3..ede4b2f 100644
|
|
||||||
--- a/build.rs
|
|
||||||
+++ b/build.rs
|
|
||||||
@@ -1,7 +1,5 @@
|
|
||||||
extern crate bindgen;
|
|
||||||
extern crate pkg_config;
|
|
||||||
-#[cfg(feature = "vendored")]
|
|
||||||
-extern crate nettle_src;
|
|
||||||
|
|
||||||
use std::env;
|
|
||||||
use std::fs;
|
|
||||||
@@ -36,14 +34,6 @@ fn main() {
|
|
||||||
println!("cargo:rerun-if-env-changed=NETTLE_STATIC");
|
|
||||||
println!("cargo:rerun-if-env-changed={}", NETTLE_PREGENERATED_BINDINGS);
|
|
||||||
|
|
||||||
- #[cfg(feature = "vendored")]
|
|
||||||
- {
|
|
||||||
- let artifacts = nettle_src::Build::new().build();
|
|
||||||
- println!("cargo:vendored=1");
|
|
||||||
- env::set_var("PKG_CONFIG_PATH",
|
|
||||||
- artifacts.lib_dir().join("pkgconfig"));
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
let nettle = pkg_config::probe_library("nettle hogweed").unwrap();
|
|
||||||
|
|
||||||
let mode = match env::var_os("NETTLE_STATIC") {
|
|
Reference in a new issue