me
/
guix
Archived
1
0
Fork 0

gnu: xdotool: Update to 3.20160805.1.

* gnu/packages/xdisorg.scm (xdotool): Update to 3.20160805.1.
[source](patches): Remove.
[arguments]: Create output directory.
* gnu/packages/patches/xdotool-fix-makefile.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Marius Bakke 2018-08-01 12:32:16 +02:00
parent 0027e09415
commit ad430c7127
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 7 additions and 25 deletions

View File

@ -1220,7 +1220,6 @@ dist_patch_DATA = \
%D%/packages/patches/x265-fix-ppc64le-build.patch \
%D%/packages/patches/xapian-revert-5489fb2f8.patch \
%D%/packages/patches/xboing-CVE-2004-0149.patch \
%D%/packages/patches/xdotool-fix-makefile.patch \
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
%D%/packages/patches/xf86-video-geode-glibc-2.20.patch \

View File

@ -1,16 +0,0 @@
Fix Makefile, which missed including a necessary library for compiling in the
0.5.0 release.
See https://github.com/jordansissel/xdotool/pull/81 for more information.
--- xdotool-3.20150503.1/Makefile 2014-10-20 13:05:34.000000000 -0700
+++ xdotool-3.20150503.1/Makefile 2016-02-05 14:44:18.652734272 -0800
@@ -28,7 +28,7 @@
CFLAGS+=-g # TODO(sissel): Comment before release
CFLAGS+=$(CPPFLAGS)
-DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama
+DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama -lxkbcommon
DEFAULT_INC=-I/usr/X11R6/include -I/usr/local/include
XDOTOOL_LIBS=$(shell pkg-config --libs x11 2> /dev/null || echo "$(DEFAULT_LIBS)") $(shell sh platform.sh extralibs)

View File

@ -222,7 +222,7 @@ X11 (yet).")
(define-public xdotool
(package
(name "xdotool")
(version "3.20150503.1")
(version "3.20160805.1")
(source
(origin
(method url-fetch)
@ -231,8 +231,7 @@ X11 (yet).")
version "/xdotool-" version ".tar.gz"))
(sha256
(base32
"1lcngsw33fy9my21rdiz1gs474bfdqcfxjrnfggbx4aypn1nhcp8"))
(patches (search-patches "xdotool-fix-makefile.patch"))))
"1a6c1zr86zb53352yxv104l76l8x21gfl2bgw6h21iphxpv5zgim"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; Test suite requires a lot of black magic
@ -240,11 +239,11 @@ X11 (yet).")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(setenv "PREFIX" (assoc-ref outputs "out"))
(setenv "LDFLAGS"
(string-append "-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
(setenv "CC" "gcc"))))))
(let ((out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/lib"))
(setenv "PREFIX" out)
(setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
(setenv "CC" "gcc")))))))
(native-inputs `(("perl" ,perl))) ; for pod2man
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)