gnu: spice: Fix CVE-2016-9577 and CVE-2016-9578.
* gnu/packages/patches/spice-CVE-2016-9577.patch, gnu/packages/patches/spice-CVE-2016-9578-1.patch, gnu/packages/patches/spice-CVE-2016-9578-2.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/spice.scm (spice)[source]: Use them.master
parent
dcb550e599
commit
ae953ead0f
|
@ -900,6 +900,9 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/slim-login.patch \
|
||||
%D%/packages/patches/slurm-configure-remove-nonfree-contribs.patch \
|
||||
%D%/packages/patches/soprano-find-clucene.patch \
|
||||
%D%/packages/patches/spice-CVE-2016-9577.patch \
|
||||
%D%/packages/patches/spice-CVE-2016-9578-1.patch \
|
||||
%D%/packages/patches/spice-CVE-2016-9578-2.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
%D%/packages/patches/swish-e-search.patch \
|
||||
|
|
|
@ -0,0 +1,33 @@
|
|||
Prevent buffer overflow when reading large messages.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1401603
|
||||
https://access.redhat.com/security/cve/CVE-2016-9577
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9577
|
||||
https://security-tracker.debian.org/tracker/CVE-2016-9577
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=5f96b596353d73bdf4bb3cd2de61e48a7fd5b4c3
|
||||
|
||||
From 5f96b596353d73bdf4bb3cd2de61e48a7fd5b4c3 Mon Sep 17 00:00:00 2001
|
||||
From: Frediano Ziglio <fziglio@redhat.com>
|
||||
Date: Tue, 29 Nov 2016 16:46:56 +0000
|
||||
Subject: main-channel: Prevent overflow reading messages from client
|
||||
|
||||
diff --git a/server/main_channel.c b/server/main_channel.c
|
||||
index 0ecc9df..1fc3915 100644
|
||||
--- a/server/main_channel.c
|
||||
+++ b/server/main_channel.c
|
||||
@@ -1026,6 +1026,9 @@ static uint8_t *main_channel_alloc_msg_rcv_buf(RedChannelClient *rcc,
|
||||
|
||||
if (type == SPICE_MSGC_MAIN_AGENT_DATA) {
|
||||
return reds_get_agent_data_buffer(mcc, size);
|
||||
+ } else if (size > sizeof(main_chan->recv_buf)) {
|
||||
+ /* message too large, caller will log a message and close the connection */
|
||||
+ return NULL;
|
||||
} else {
|
||||
return main_chan->recv_buf;
|
||||
}
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
|
@ -0,0 +1,33 @@
|
|||
Prevent possible DoS during protocol handshake.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1399566
|
||||
https://access.redhat.com/security/cve/CVE-2016-9578
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9578
|
||||
https://security-tracker.debian.org/tracker/CVE-2016-9578
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=f66dc643635518e53dfbe5262f814a64eec54e4a
|
||||
|
||||
From 1c6517973095a67c8cb57f3550fc1298404ab556 Mon Sep 17 00:00:00 2001
|
||||
From: Frediano Ziglio <fziglio@redhat.com>
|
||||
Date: Tue, 13 Dec 2016 14:39:48 +0000
|
||||
Subject: Prevent possible DoS attempts during protocol handshake
|
||||
|
||||
diff --git a/server/reds.c b/server/reds.c
|
||||
index f40b65c..86a33d5 100644
|
||||
--- a/server/reds.c
|
||||
+++ b/server/reds.c
|
||||
@@ -2202,7 +2202,8 @@ static void reds_handle_read_header_done(void *opaque)
|
||||
|
||||
reds->peer_minor_version = header->minor_version;
|
||||
|
||||
- if (header->size < sizeof(SpiceLinkMess)) {
|
||||
+ /* the check for 4096 is to avoid clients to cause arbitrary big memory allocations */
|
||||
+ if (header->size < sizeof(SpiceLinkMess) || header->size > 4096) {
|
||||
reds_send_link_error(link, SPICE_LINK_ERR_INVALID_DATA);
|
||||
spice_warning("bad size %u", header->size);
|
||||
reds_link_free(link);
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
|
@ -0,0 +1,38 @@
|
|||
Fixes a potential buffer overflow in the protocol handling.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1399566
|
||||
https://access.redhat.com/security/cve/CVE-2016-9578
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9578
|
||||
https://security-tracker.debian.org/tracker/CVE-2016-9578
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=f66dc643635518e53dfbe5262f814a64eec54e4a
|
||||
|
||||
From f66dc643635518e53dfbe5262f814a64eec54e4a Mon Sep 17 00:00:00 2001
|
||||
From: Frediano Ziglio <fziglio@redhat.com>
|
||||
Date: Tue, 13 Dec 2016 14:40:10 +0000
|
||||
Subject: Prevent integer overflows in capability checks
|
||||
|
||||
diff --git a/server/reds.c b/server/reds.c
|
||||
index 86a33d5..9150454 100644
|
||||
--- a/server/reds.c
|
||||
+++ b/server/reds.c
|
||||
@@ -2110,6 +2110,14 @@ static void reds_handle_read_link_done(void *opaque)
|
||||
link_mess->num_channel_caps = GUINT32_FROM_LE(link_mess->num_channel_caps);
|
||||
link_mess->num_common_caps = GUINT32_FROM_LE(link_mess->num_common_caps);
|
||||
|
||||
+ /* Prevent DoS. Currently we defined only 13 capabilities,
|
||||
+ * I expect 1024 to be valid for quite a lot time */
|
||||
+ if (link_mess->num_channel_caps > 1024 || link_mess->num_common_caps > 1024) {
|
||||
+ reds_send_link_error(link, SPICE_LINK_ERR_INVALID_DATA);
|
||||
+ reds_link_free(link);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
num_caps = link_mess->num_common_caps + link_mess->num_channel_caps;
|
||||
caps = (uint32_t *)((uint8_t *)link_mess + link_mess->caps_offset);
|
||||
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
|
@ -208,7 +208,11 @@ which allows users to view a desktop computing environment.")
|
|||
"spice-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0za03i77j8i3g5l2np2j7vy8cqsdbkm9wbv4hjnaqq9xhz2sa0gr"))))
|
||||
"0za03i77j8i3g5l2np2j7vy8cqsdbkm9wbv4hjnaqq9xhz2sa0gr"))
|
||||
(patches
|
||||
(search-patches "spice-CVE-2016-9577.patch"
|
||||
"spice-CVE-2016-9578-1.patch"
|
||||
"spice-CVE-2016-9578-2.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("openssl" ,openssl)
|
||||
|
|
Reference in New Issue