distro: Add Perl.
* distro/base.scm (perl): New variable. * distro/patches/perl-no-sys-dirs.patch: New file. * Makefile.am (dist_patch_DATA): Add it.master
parent
321b099643
commit
b289e9f9dd
|
@ -48,6 +48,7 @@ dist_patch_DATA = \
|
||||||
distro/patches/m4-s_isdir.patch \
|
distro/patches/m4-s_isdir.patch \
|
||||||
distro/patches/make-impure-dirs.patch \
|
distro/patches/make-impure-dirs.patch \
|
||||||
distro/patches/findutils-absolute-paths.patch \
|
distro/patches/findutils-absolute-paths.patch \
|
||||||
|
distro/patches/perl-no-sys-dirs.patch \
|
||||||
distro/patches/readline-link-ncurses.patch \
|
distro/patches/readline-link-ncurses.patch \
|
||||||
distro/patches/tar-gets-undeclared.patch
|
distro/patches/tar-gets-undeclared.patch
|
||||||
|
|
||||||
|
|
|
@ -185,6 +185,56 @@ files (as archives).")
|
||||||
(license "GPLv3+")
|
(license "GPLv3+")
|
||||||
(home-page "http://www.gnu.org/software/tar/")))
|
(home-page "http://www.gnu.org/software/tar/")))
|
||||||
|
|
||||||
|
(define-public perl
|
||||||
|
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
|
||||||
|
(package
|
||||||
|
(name "perl")
|
||||||
|
(version "5.16.1")
|
||||||
|
(source (origin
|
||||||
|
(method http-fetch)
|
||||||
|
(uri (string-append "http://www.cpan.org/src/5.0/perl-"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
(lambda (system)
|
||||||
|
`(#:tests? #f
|
||||||
|
#:patches (list (assoc-ref %build-inputs "patch/no-sys-dirs"))
|
||||||
|
#:phases
|
||||||
|
(alist-replace
|
||||||
|
'configure
|
||||||
|
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||||
|
(let ((out (assoc-ref outputs "out"))
|
||||||
|
(libc (assoc-ref inputs "libc"))
|
||||||
|
(pwd (search-path (search-path-as-string->list
|
||||||
|
(getenv "PATH"))
|
||||||
|
"pwd")))
|
||||||
|
;; Use the right path for `pwd'.
|
||||||
|
(substitute* "dist/Cwd/Cwd.pm"
|
||||||
|
(("/bin/pwd") pwd))
|
||||||
|
|
||||||
|
(zero?
|
||||||
|
(system* "/bin/sh" "./Configure"
|
||||||
|
(string-append "-Dprefix=" out)
|
||||||
|
(string-append "-Dman1dir=" out "/share/man/man1")
|
||||||
|
(string-append "-Dman3dir=" out "/share/man/man3")
|
||||||
|
"-de" "-Dcc=gcc"
|
||||||
|
"-Uinstallusrbinperl"
|
||||||
|
"-Dinstallstyle=lib/perl5"
|
||||||
|
"-Duseshrplib"
|
||||||
|
(string-append "-Dlocincpth=" libc "/include")
|
||||||
|
(string-append "-Dloclibpth=" libc "/lib")))))
|
||||||
|
%standard-phases))))
|
||||||
|
(inputs `(("patch/no-sys-dirs" ,(search-patch "perl-no-sys-dirs.patch"))))
|
||||||
|
(description "Implementation of the Perl programming language")
|
||||||
|
(long-description
|
||||||
|
"Perl 5 is a highly capable, feature-rich programming language with over
|
||||||
|
24 years of development.")
|
||||||
|
(home-page "http://www.perl.org/")
|
||||||
|
(license "GPLv1+"))) ; or "Artistic"
|
||||||
|
|
||||||
(define-public gzip
|
(define-public gzip
|
||||||
(package
|
(package
|
||||||
(name "gzip")
|
(name "gzip")
|
||||||
|
@ -946,7 +996,7 @@ modification.")
|
||||||
"0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))))
|
"0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("m4" ,m4)
|
(native-inputs `(("m4" ,m4)
|
||||||
("perl" ,(nixpkgs-derivation* "perl"))))
|
("perl" ,perl)))
|
||||||
(description "GNU Libtool, a generic library support script")
|
(description "GNU Libtool, a generic library support script")
|
||||||
(long-description
|
(long-description
|
||||||
"GNU libtool is a generic library support script. Libtool hides the
|
"GNU libtool is a generic library support script. Libtool hides the
|
||||||
|
@ -1191,7 +1241,7 @@ call interface, and powerful string processing.")
|
||||||
(base32
|
(base32
|
||||||
"0i74jn47f6vs5kcvk8abvz3k08z32c9bbqw0sdjkdxwvr4jbczpv"))))
|
"0i74jn47f6vs5kcvk8abvz3k08z32c9bbqw0sdjkdxwvr4jbczpv"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("perl" ,(nixpkgs-derivation* "perl"))))
|
(native-inputs `(("perl" ,perl)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:modules ((guix build gnu-build-system)
|
`(#:modules ((guix build gnu-build-system)
|
||||||
(guix build utils)
|
(guix build utils)
|
||||||
|
|
|
@ -0,0 +1,156 @@
|
||||||
|
Don't long for headers and libraries in "traditional" locations.
|
||||||
|
|
||||||
|
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
|
||||||
|
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
|
--- perl-5.14.2-orig/Configure 2011-09-26 11:44:34.000000000 +0200
|
||||||
|
+++ perl-5.14.2/Configure 2012-01-20 17:05:23.089223129 +0100
|
||||||
|
@@ -106,15 +106,7 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
: Proper PATH setting
|
||||||
|
-paths='/bin /usr/bin /usr/local/bin /usr/ucb /usr/local /usr/lbin'
|
||||||
|
-paths="$paths /opt/bin /opt/local/bin /opt/local /opt/lbin"
|
||||||
|
-paths="$paths /usr/5bin /etc /usr/gnu/bin /usr/new /usr/new/bin /usr/nbin"
|
||||||
|
-paths="$paths /opt/gnu/bin /opt/new /opt/new/bin /opt/nbin"
|
||||||
|
-paths="$paths /sys5.3/bin /sys5.3/usr/bin /bsd4.3/bin /bsd4.3/usr/ucb"
|
||||||
|
-paths="$paths /bsd4.3/usr/bin /usr/bsd /bsd43/bin /opt/ansic/bin /usr/ccs/bin"
|
||||||
|
-paths="$paths /etc /usr/lib /usr/ucblib /lib /usr/ccs/lib"
|
||||||
|
-paths="$paths /sbin /usr/sbin /usr/libexec"
|
||||||
|
-paths="$paths /system/gnu_library/bin"
|
||||||
|
+paths=''
|
||||||
|
|
||||||
|
for p in $paths
|
||||||
|
do
|
||||||
|
@@ -1311,8 +1303,7 @@
|
||||||
|
archname=''
|
||||||
|
: Possible local include directories to search.
|
||||||
|
: Set locincpth to "" in a hint file to defeat local include searches.
|
||||||
|
-locincpth="/usr/local/include /opt/local/include /usr/gnu/include"
|
||||||
|
-locincpth="$locincpth /opt/gnu/include /usr/GNU/include /opt/GNU/include"
|
||||||
|
+locincpth=""
|
||||||
|
:
|
||||||
|
: no include file wanted by default
|
||||||
|
inclwanted=''
|
||||||
|
@@ -1328,17 +1319,12 @@
|
||||||
|
archobjs=''
|
||||||
|
libnames=''
|
||||||
|
: change the next line if compiling for Xenix/286 on Xenix/386
|
||||||
|
-xlibpth='/usr/lib/386 /lib/386'
|
||||||
|
+xlibpth=''
|
||||||
|
: Possible local library directories to search.
|
||||||
|
-loclibpth="/usr/local/lib /opt/local/lib /usr/gnu/lib"
|
||||||
|
-loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
|
||||||
|
+loclibpth=""
|
||||||
|
|
||||||
|
: general looking path for locating libraries
|
||||||
|
-glibpth="/lib /usr/lib $xlibpth"
|
||||||
|
-glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
|
||||||
|
-test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
|
||||||
|
-test -f /shlib/libc.so && glibpth="/shlib $glibpth"
|
||||||
|
-test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
|
||||||
|
+glibpth=""
|
||||||
|
|
||||||
|
: Private path used by Configure to find libraries. Its value
|
||||||
|
: is prepended to libpth. This variable takes care of special
|
||||||
|
@@ -1371,8 +1357,6 @@
|
||||||
|
libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
|
||||||
|
: We probably want to search /usr/shlib before most other libraries.
|
||||||
|
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
||||||
|
-glibpth=`echo " $glibpth " | sed -e 's! /usr/shlib ! !'`
|
||||||
|
-glibpth="/usr/shlib $glibpth"
|
||||||
|
: Do not use vfork unless overridden by a hint file.
|
||||||
|
usevfork=false
|
||||||
|
|
||||||
|
@@ -2380,7 +2364,6 @@
|
||||||
|
zip
|
||||||
|
"
|
||||||
|
pth=`echo $PATH | sed -e "s/$p_/ /g"`
|
||||||
|
-pth="$pth /lib /usr/lib"
|
||||||
|
for file in $loclist; do
|
||||||
|
eval xxx=\$$file
|
||||||
|
case "$xxx" in
|
||||||
|
@@ -4785,7 +4768,7 @@
|
||||||
|
: Set private lib path
|
||||||
|
case "$plibpth" in
|
||||||
|
'') if ./mips; then
|
||||||
|
- plibpth="$incpath/usr/lib /usr/local/lib /usr/ccs/lib"
|
||||||
|
+ plibpth="$incpath/usr/lib"
|
||||||
|
fi;;
|
||||||
|
esac
|
||||||
|
case "$libpth" in
|
||||||
|
@@ -8390,13 +8373,8 @@
|
||||||
|
echo " "
|
||||||
|
case "$sysman" in
|
||||||
|
'')
|
||||||
|
- syspath='/usr/share/man/man1 /usr/man/man1'
|
||||||
|
- syspath="$syspath /usr/man/mann /usr/man/manl /usr/man/local/man1"
|
||||||
|
- syspath="$syspath /usr/man/u_man/man1"
|
||||||
|
- syspath="$syspath /usr/catman/u_man/man1 /usr/man/l_man/man1"
|
||||||
|
- syspath="$syspath /usr/local/man/u_man/man1 /usr/local/man/l_man/man1"
|
||||||
|
- syspath="$syspath /usr/man/man.L /local/man/man1 /usr/local/man/man1"
|
||||||
|
- sysman=`./loc . /usr/man/man1 $syspath`
|
||||||
|
+ syspath=''
|
||||||
|
+ sysman=''
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
if $test -d "$sysman"; then
|
||||||
|
@@ -19721,9 +19699,10 @@
|
||||||
|
case "$full_ar" in
|
||||||
|
'') full_ar=$ar ;;
|
||||||
|
esac
|
||||||
|
+full_ar=ar
|
||||||
|
|
||||||
|
: Store the full pathname to the sed program for use in the C program
|
||||||
|
-full_sed=$sed
|
||||||
|
+full_sed=sed
|
||||||
|
|
||||||
|
: see what type gids are declared as in the kernel
|
||||||
|
echo " "
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Errno_pm.PL
|
||||||
|
--- perl-5.14.2-orig/ext/Errno/Errno_pm.PL 2011-09-26 11:44:34.000000000 +0200
|
||||||
|
+++ perl-5.14.2/ext/Errno/Errno_pm.PL 2012-01-20 17:02:07.938138311 +0100
|
||||||
|
@@ -137,11 +137,7 @@
|
||||||
|
if ($dep =~ /(\S+errno\.h)/) {
|
||||||
|
$file{$1} = 1;
|
||||||
|
}
|
||||||
|
- } elsif ($^O eq 'linux' &&
|
||||||
|
- $Config{gccversion} ne '' &&
|
||||||
|
- $Config{gccversion} !~ /intel/i
|
||||||
|
- # might be using, say, Intel's icc
|
||||||
|
- ) {
|
||||||
|
+ } elsif (0) {
|
||||||
|
# Some Linuxes have weird errno.hs which generate
|
||||||
|
# no #file or #line directives
|
||||||
|
my $linux_errno_h = -e '/usr/include/errno.h' ?
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
|
||||||
|
--- perl-5.14.2-orig/hints/freebsd.sh 2011-09-19 15:18:22.000000000 +0200
|
||||||
|
+++ perl-5.14.2/hints/freebsd.sh 2012-01-20 17:10:37.267924044 +0100
|
||||||
|
@@ -118,21 +118,21 @@
|
||||||
|
objformat=`/usr/bin/objformat`
|
||||||
|
if [ x$objformat = xaout ]; then
|
||||||
|
if [ -e /usr/lib/aout ]; then
|
||||||
|
- libpth="/usr/lib/aout /usr/local/lib /usr/lib"
|
||||||
|
- glibpth="/usr/lib/aout /usr/local/lib /usr/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
fi
|
||||||
|
lddlflags='-Bshareable'
|
||||||
|
else
|
||||||
|
- libpth="/usr/lib /usr/local/lib"
|
||||||
|
- glibpth="/usr/lib /usr/local/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
ldflags="-Wl,-E "
|
||||||
|
lddlflags="-shared "
|
||||||
|
fi
|
||||||
|
cccdlflags='-DPIC -fPIC'
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
- libpth="/usr/lib /usr/local/lib"
|
||||||
|
- glibpth="/usr/lib /usr/local/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
ldflags="-Wl,-E "
|
||||||
|
lddlflags="-shared "
|
||||||
|
cccdlflags='-DPIC -fPIC'
|
Reference in New Issue