gnu: xpra: Update to 4.3.1.
Fixes: <https://issues.guix.gnu.org/52869>. * gnu/packages/xorg.scm (xpra): Update to 4.3.1. [inputs]: Add libxres. * gnu/packages/patches/xpra-4.2-install_libs.patch: Adjust to updated setup.py.master
parent
927c589256
commit
b3b6373cd6
|
@ -1,22 +1,18 @@
|
|||
This workaround for Gentoo interferes with our use of --no-compile during
|
||||
the 'install stage.
|
||||
|
||||
--- a/setup.py 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/setup.py 2022-01-06 14:08:46.710437071 +0100
|
||||
@@ -561,12 +561,6 @@
|
||||
% (cython_version, min_version))
|
||||
--- a/setup.py 2022-01-04 10:10:05.039825000 +0100
|
||||
+++ b/setup.py 2022-01-06 15:10:31.952656039 +0100
|
||||
@@ -589,8 +589,6 @@
|
||||
})
|
||||
|
||||
def cython_add(extension, min_version="0.20"):
|
||||
- #gentoo does weird things, calls --no-compile with build *and* install
|
||||
- #then expects to find the cython modules!? ie:
|
||||
- #python2.7 setup.py build -b build-2.7 install --no-compile \
|
||||
- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
|
||||
def add_cython_ext(*args, **kwargs):
|
||||
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
|
||||
- return
|
||||
assert cython_ENABLED, "cython compilation is disabled"
|
||||
cython_version_check(min_version)
|
||||
from Cython.Distutils import build_ext
|
||||
@@ -1691,14 +1685,6 @@
|
||||
if cython_tracing_ENABLED:
|
||||
kwargs["define_macros"] = [
|
||||
@@ -1703,14 +1701,6 @@
|
||||
if uinput_ENABLED:
|
||||
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
|
||||
|
||||
|
|
|
@ -6315,14 +6315,14 @@ basic eye-candy effects.")
|
|||
(define-public xpra
|
||||
(package
|
||||
(name "xpra")
|
||||
(version "4.2.2")
|
||||
(version "4.3.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.xpra.org/src/xpra-"
|
||||
version ".tar.gz"))
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0nky9j07zq8d5ifx568dima7a0jgs8kwhcqbg8p6gsxlgq5zdw96"))
|
||||
(base32 "1adp790v9lq3v9pnkyf4skv69n2pd7fjqikzw145swhq9aginh5z"))
|
||||
(patches (search-patches "xpra-4.2-systemd-run.patch"
|
||||
"xpra-4.2-install_libs.patch"))))
|
||||
(build-system python-build-system)
|
||||
|
@ -6340,6 +6340,7 @@ basic eye-candy effects.")
|
|||
("libxcomposite" ,libxcomposite)
|
||||
("libxdamage" ,libxdamage)
|
||||
("libxext" ,libxext)
|
||||
("libxres" ,libxres)
|
||||
("gtk+" ,gtk+)
|
||||
("python-pycairo" ,python-pycairo)
|
||||
("python-pygobject" ,python-pygobject)
|
||||
|
|
Reference in New Issue