me
/
guix
Archived
1
0
Fork 0

gnu: elixir: Update to 1.10.0.

* gnu/packages/elixir.scm (elixir): Update to 1.10.0.
* gnu/packages/patches/elixir-path-length.patch: Update patch so it can
be applied to v1.10.0 source

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
master
Oskar Köök 2020-01-27 14:13:16 +02:00 committed by Marius Bakke
parent efd9742b24
commit b3e992e984
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 6 additions and 6 deletions

View File

@ -33,7 +33,7 @@
(define-public elixir (define-public elixir
(package (package
(name "elixir") (name "elixir")
(version "1.9.4") (version "1.10.0")
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
@ -42,7 +42,7 @@
(commit (string-append "v" version)))) (commit (string-append "v" version))))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "1l4318g35y4h0vi2w07ayc3jizw1xc3s7hdb47w6j3iw33y06g6b")) (base32 "1fz22c2jqqm2jvzxar11bh1djg3kqdn5rbxdddlz0cv6mfz7hvgv"))
(patches (search-patches "elixir-path-length.patch")))) (patches (search-patches "elixir-path-length.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments

View File

@ -5,11 +5,11 @@ after the substitution is made.
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -213,6 +213,7 @@ @@ -265,6 +265,7 @@ format: compile
TEST_ERLS = $(addprefix $(TEST_EBIN)/, $(addsuffix .beam, $(basename $(notdir $(wildcard $(TEST_ERL)/*.erl))))) $(call FORMAT)
test_formatted: compile test_formatted: compile
+ bin/elixir bin/mix format lib/mix/lib/mix/scm/git.ex + $(call FORMAT,lib/mix/lib/mix/scm/git.ex)
bin/elixir bin/mix format --check-formatted $(call FORMAT,--check-formatted)
test_erlang: compile $(TEST_ERLS) test_erlang: compile $(TEST_ERLS)