gnu: rust-openssl-sys-0.9: Update to 0.9.68.
* gnu/packages/crates-io.scm (rust-openssl-sys-0.9): Update to 0.9.68. * gnu/packages/patches/rust-openssl-sys-no-vendor.patch: Add note about supported versions of openssl.master
parent
7af3b82217
commit
b47e37a4fd
|
@ -31725,14 +31725,14 @@ system for OpenSSL.")
|
||||||
(define-public rust-openssl-sys-0.9
|
(define-public rust-openssl-sys-0.9
|
||||||
(package
|
(package
|
||||||
(name "rust-openssl-sys")
|
(name "rust-openssl-sys")
|
||||||
(version "0.9.64")
|
(version "0.9.68")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (crate-uri "openssl-sys" version))
|
(uri (crate-uri "openssl-sys" version))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1bsim2zk69q1dw6rixn48l1ci8bmz5kvbkgsks2ci079w0pzr7i0"))
|
(base32 "0l2ikxygkza3s5q3lvng4mhisdp2vdrvzkhpwhkx8vgnscjiymqw"))
|
||||||
(patches (search-patches "rust-openssl-sys-no-vendor.patch"))))
|
(patches (search-patches "rust-openssl-sys-no-vendor.patch"))))
|
||||||
(build-system cargo-build-system)
|
(build-system cargo-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
|
|
|
@ -2,6 +2,8 @@ https://sources.debian.org/data/main/r/rust-openssl-sys/0.9.53-1/debian/patches/
|
||||||
"MIT" licensed according to debian/copyright file
|
"MIT" licensed according to debian/copyright file
|
||||||
slightly modified to only change the vendored openssl-src dependency
|
slightly modified to only change the vendored openssl-src dependency
|
||||||
|
|
||||||
|
Starting from rust-openssl-sys@0.9.69 Cargo.toml starts searching for openssl-3.0.
|
||||||
|
|
||||||
--- a/Cargo.toml
|
--- a/Cargo.toml
|
||||||
+++ b/Cargo.toml
|
+++ b/Cargo.toml
|
||||||
@@ -31,14 +31,11 @@
|
@@ -31,14 +31,11 @@
|
||||||
|
|
Reference in New Issue