me
/
guix
Archived
1
0
Fork 0

gnu: kpackage: Fix build errors in dependent packages.

Fix build errors in dependent packages if PREFIX is different from ECM's
PREFIX - which is the case in Guix.  See <https://bugs.kde.org/424483> for
details.

* gnu/packages/patches/plasma-framework-fix-KF5PackageMacros.cmake.patch: New
  file.
* gnu/local.mk (dist_patch_DATA) Add it.
* packages/kde-frameworks.scm (package)[source]: Use this patch.
master
Hartmut Goebel 2020-10-25 21:29:52 +01:00
parent e3908ec5fb
commit b4941e30e3
No known key found for this signature in database
GPG Key ID: 634A8DFFD3F631DF
3 changed files with 28 additions and 1 deletions

View File

@ -1197,6 +1197,7 @@ dist_patch_DATA = \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
%D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch \
%D%/packages/patches/kmplayer-aarch64.patch \
%D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
%D%/packages/patches/kobodeluxe-paths.patch \

View File

@ -1963,7 +1963,8 @@ covers feedback and persistent events.")
"03rp7p7i8ihz5wg58gjs638jk7xbszknfiy2j3r979snc57g95mv"))
;; Default to: external paths/symlinks can be followed by a
;; package
(patches (search-patches "kpackage-allow-external-paths.patch"))))
(patches (search-patches "kpackage-allow-external-paths.patch"
"kpackage-fix-KF5PackageMacros.cmake.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))

View File

@ -0,0 +1,25 @@
From 668010ebc9fd84d9dc60f90b9a4ebf3c7054977f Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Sun, 25 Oct 2020 20:11:13 +0000
Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
See <https://bugs.kde.org/424483> for details.
---
KF5PackageMacros.cmake | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
index f4c1d1d..acd3798 100644
--- a/KF5PackageMacros.cmake
+++ b/KF5PackageMacros.cmake
@@ -1,6 +1,5 @@
-find_package(ECM 1.6.0 CONFIG REQUIRED)
-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
+include(KDEInstallDirs)
set(KPACKAGE_RELATIVE_DATA_INSTALL_DIR "kpackage")
--
GitLab