gnu: pulseaudio: increase timeout of thread test.
* gnu/packages/patches/pulseaudio-test-timeouts.patch: New file. * gnu/packages/pulseaudio.scm (pulseaudio): Add patch. * gnu-system.am (dist_patch_DATA): Add patch.master
parent
cdbca518ca
commit
b645425f71
|
@ -242,6 +242,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||||
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||||
gnu/packages/patches/procps-make-3.82.patch \
|
gnu/packages/patches/procps-make-3.82.patch \
|
||||||
|
gnu/packages/patches/pulseaudio-test-timeouts.patch \
|
||||||
gnu/packages/patches/python-fix-dbm.patch \
|
gnu/packages/patches/python-fix-dbm.patch \
|
||||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||||
gnu/packages/patches/qt4-tests.patch \
|
gnu/packages/patches/qt4-tests.patch \
|
||||||
|
|
|
@ -0,0 +1,19 @@
|
||||||
|
Increase the timeout of the thread test. Hydra was intermittedly
|
||||||
|
failing this test due to premature timeout, and slower machines
|
||||||
|
consistently fail.
|
||||||
|
|
||||||
|
Patch by Mark H Weaver <mhw@netris.org>.
|
||||||
|
|
||||||
|
--- pulseaudio/src/tests/thread-test.c.orig 2012-09-26 07:27:01.000000000 -0400
|
||||||
|
+++ pulseaudio/src/tests/thread-test.c 2013-10-31 22:53:23.224000184 -0400
|
||||||
|
@@ -152,6 +152,10 @@
|
||||||
|
s = suite_create("Thread");
|
||||||
|
tc = tcase_create("thread");
|
||||||
|
tcase_add_test(tc, thread_test);
|
||||||
|
+ /* the default timeout is too small,
|
||||||
|
+ * set it to a reasonable large one.
|
||||||
|
+ */
|
||||||
|
+ tcase_set_timeout(tc, 60 * 60);
|
||||||
|
suite_add_tcase(s, tc);
|
||||||
|
|
||||||
|
sr = srunner_create(s);
|
|
@ -22,6 +22,7 @@
|
||||||
#:use-module ((guix licenses)
|
#:use-module ((guix licenses)
|
||||||
#:renamer (symbol-prefix-proc 'l:))
|
#:renamer (symbol-prefix-proc 'l:))
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages linux)
|
#:use-module (gnu packages linux)
|
||||||
#:use-module (gnu packages oggvorbis)
|
#:use-module (gnu packages oggvorbis)
|
||||||
#:use-module (gnu packages pkg-config)
|
#:use-module (gnu packages pkg-config)
|
||||||
|
@ -141,7 +142,8 @@ parse JSON formatted strings back into the C representation of JSON objects.")
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1bndz4l8jxyq3zq128gzp3gryxl6yjs66j2y1d7yabw2n5mv7kim"))))
|
"1bndz4l8jxyq3zq128gzp3gryxl6yjs66j2y1d7yabw2n5mv7kim"))
|
||||||
|
(patches (list (search-patch "pulseaudio-test-timeouts.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags '("--localstatedir=/var" ;"--sysconfdir=/etc"
|
'(#:configure-flags '("--localstatedir=/var" ;"--sysconfdir=/etc"
|
||||||
|
|
Reference in New Issue