gnu: emacs: Update to 28.1.
* gnu/packages/emacs.scm (emacs): Update to 28.1 * gnu/packages/patches/emacs-exec-path.patch: Adjust accordingly. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch: Delete file. * gnu/local.mk: Remove it here.master
parent
c61746b8aa
commit
b65a1e4a21
|
@ -1030,7 +1030,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/emacs-exec-path.patch \
|
%D%/packages/patches/emacs-exec-path.patch \
|
||||||
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
||||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||||
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
|
|
||||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||||
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
|
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
|
||||||
|
|
|
@ -79,17 +79,16 @@
|
||||||
(define-public emacs
|
(define-public emacs
|
||||||
(package
|
(package
|
||||||
(name "emacs")
|
(name "emacs")
|
||||||
(version "27.2")
|
(version "28.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/emacs/emacs-"
|
(uri (string-append "mirror://gnu/emacs/emacs-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1ff182gjw9wqsbx1kj5gl2r5pbqhp4ar54g04j33fgz6g17cr9xl"))
|
"1qbmmmhnjhn4lvzsnyk7l5ganbi6wzbm38jc1a7hhyh3k78b7c98"))
|
||||||
(patches (search-patches "emacs-exec-path.patch"
|
(patches (search-patches "emacs-exec-path.patch"
|
||||||
"emacs-fix-scheme-indent-function.patch"
|
"emacs-fix-scheme-indent-function.patch"
|
||||||
"emacs-ignore-empty-xim-styles.patch"
|
|
||||||
"emacs-source-date-epoch.patch"))
|
"emacs-source-date-epoch.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
|
|
|
@ -4,13 +4,13 @@ with things like GCC being referenced.
|
||||||
|
|
||||||
--- a/lisp/loadup.el
|
--- a/lisp/loadup.el
|
||||||
+++ b/lisp/loadup.el
|
+++ b/lisp/loadup.el
|
||||||
@@ -481,7 +481,8 @@ lost after dumping")))
|
@@ -530,7 +530,8 @@ lost after dumping")))
|
||||||
((equal dump-mode "dump") "emacs")
|
((equal dump-mode "dump") "emacs")
|
||||||
((equal dump-mode "bootstrap") "emacs")
|
((equal dump-mode "bootstrap") "emacs")
|
||||||
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
||||||
- (t (error "unrecognized dump mode %s" dump-mode)))))
|
- (t (error "Unrecognized dump mode %s" dump-mode)))))
|
||||||
+ (t (error "unrecognized dump mode %s" dump-mode))))
|
+ (t (error "Unrecognized dump mode %s" dump-mode))))
|
||||||
+ (exec-path nil))
|
+ (exec-path nil))
|
||||||
(message "Dumping under the name %s" output)
|
(when (and (featurep 'native-compile)
|
||||||
(condition-case ()
|
(equal dump-mode "pdump"))
|
||||||
(delete-file output)
|
;; Don't enable this before bootstrap is completed, as the
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
Fix contributed upstream here:
|
|
||||||
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=42694.
|
|
||||||
|
|
||||||
Index: emacs-26.3/src/xfns.c
|
|
||||||
===================================================================
|
|
||||||
--- emacs-26.3.orig/src/xfns.c
|
|
||||||
+++ emacs-26.3/src/xfns.c
|
|
||||||
@@ -2628,6 +2628,8 @@ xic_free_xfontset (struct frame *f)
|
|
||||||
static XIMStyle
|
|
||||||
best_xim_style (XIMStyles *xim)
|
|
||||||
{
|
|
||||||
+ if (xim == NULL) goto out;
|
|
||||||
+
|
|
||||||
int i, j;
|
|
||||||
int nr_supported = ARRAYELTS (supported_xim_styles);
|
|
||||||
|
|
||||||
@@ -2636,6 +2638,7 @@ best_xim_style (XIMStyles *xim)
|
|
||||||
if (supported_xim_styles[i] == xim->supported_styles[j])
|
|
||||||
return supported_xim_styles[i];
|
|
||||||
|
|
||||||
+ out:
|
|
||||||
/* Return the default style. */
|
|
||||||
return XIMPreeditNothing | XIMStatusNothing;
|
|
||||||
}
|
|
Reference in New Issue