me
/
guix
Archived
1
0
Fork 0

gnu: freebayes: Update to 1.3.5.

* gnu/packages/bioinformatics.scm (freebayes): Update to 1.3.5.
[source]: Remove patch.
[arguments]: Adjust custom 'patch-source phase for changes in source.
[inputs]: Remove zlib.
* gnu/packages/patches/freebayes-devendor-deps.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2021-06-06 12:07:01 +03:00
parent 1fd8819fac
commit b65c02e2d3
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 7 additions and 162 deletions

View File

@ -1019,7 +1019,6 @@ dist_patch_DATA = \
%D%/packages/patches/fpc-reproducibility.patch \
%D%/packages/patches/fplll-std-fenv.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freebayes-devendor-deps.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch \

View File

@ -13572,7 +13572,7 @@ manipulations on VCF files.")
(define-public freebayes
(package
(name "freebayes")
(version "1.3.3")
(version "1.3.5")
(source (origin
(method git-fetch)
(uri (git-reference
@ -13580,8 +13580,7 @@ manipulations on VCF files.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0myz3giad7jqp6ricdfnig9ymlcps2h67mlivadvx97ngagm85z8"))
(patches (search-patches "freebayes-devendor-deps.patch"))
(base32 "1l0z88gq57kva677a6xri5g9k2d9h9lk5yk1q2xmq64wqhv7dvc3"))
(modules '((guix build utils)))
(snippet
'(begin
@ -13593,8 +13592,7 @@ manipulations on VCF files.")
("htslib" ,htslib)
("smithwaterman" ,smithwaterman)
("tabixpp" ,tabixpp)
("vcflib" ,vcflib)
("zlib" ,zlib)))
("vcflib" ,vcflib)))
(native-inputs
`(("bash-tap" ,bash-tap)
("bc" ,bc)
@ -13627,13 +13625,13 @@ manipulations on VCF files.")
(string-append bash-tap "/bin/bash-tap-bootstrap"))
(("source.*bash-tap-bootstrap")
(string-append "source " bash-tap "/bin/bash-tap-bootstrap")))
(substitute* "meson.build"
;; Some inputs aren't actually needed.
((".*bamtools/src.*") "")
((".*multichoose.*") ""))
(substitute* '("src/BedReader.cpp"
"src/BedReader.h")
(("../intervaltree/IntervalTree.h") "IntervalTree.h"))
(substitute* "meson.build"
;; Our pkg-config file is vcflib.pc
(("libvcflib") "vcflib")
(("vcflib_inc,") ""))
#t)))
(add-after 'unpack 'unpack-submodule-sources
(lambda* (#:key inputs #:allow-other-keys)

View File

@ -1,152 +0,0 @@
This patch is original to Guix, ongoing work to upstream bits as possible.
From 9acc56db5e7469f5976be38b52ba4993de98ee38 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 17 Jan 2021 13:27:17 +0200
Subject: [PATCH] devendor-dependants
---
meson.build | 84 +++++++++++++++++++++++++++++++++++++++++------------
1 file changed, 66 insertions(+), 18 deletions(-)
diff --git a/meson.build b/meson.build
index f6bf242..bded4af 100644
--- a/meson.build
+++ b/meson.build
@@ -9,8 +9,13 @@ project('freebayes', ['cpp', 'c'],
zlib_dep = dependency('zlib')
lzma_dep = dependency('liblzma')
+simde_dep = dependency('simde')
bzip2_dep = dependency('bz2lib', required: false)
htslib_dep = dependency('htslib', required : false)
+tabixpp_dep = dependency('tabixpp', required : false)
+fastahack_dep = dependency('fastahack', required : false)
+smithwaterman_dep = dependency('smithwaterman', required : false)
+vcflib_dep = dependency('vcflib', required: false)
thread_dep = dependency('threads')
if htslib_dep.found()
@@ -59,6 +64,56 @@ else
]
endif
+if tabixpp_dep.found()
+ tabixpp_includes = ''
+ tabixpp_src = []
+else
+ tabixpp_includes = [
+ 'vcflib/tabixpp',
+ ]
+ tabixpp_src = [
+ 'vcflib/tabixpp/tabix.cpp',
+ ]
+endif
+
+if vcflib_dep.found()
+ vcflib_includes = ''
+ vcflib_src = []
+else
+ vcflib_includes = [
+ 'vcflib/src',
+ 'vcflib/multichoose',
+ 'vcflib/filevercmp',
+ ]
+ vcflib_src = [
+ 'vcflib/src/Variant.cpp',
+ ]
+endif
+
+if fastahack_dep.found()
+ fastahack_src = []
+else
+ fastahack_src = [
+ 'vcflib/fastahack/Fasta.cpp',
+ 'vcflib/src/split.cpp',
+ ]
+endif
+
+if smithwaterman_dep.found()
+ smithwaterman_includes = ''
+ smithwaterman_src = []
+else
+ smithwaterman_includes = [
+ 'vcflib/smithwaterman',
+ ]
+ smithwaterman_src = [
+ 'vcflib/smithwaterman/SmithWatermanGotoh.cpp',
+ 'vcflib/smithwaterman/disorder.cpp',
+ 'vcflib/smithwaterman/Repeats.cpp',
+ 'vcflib/smithwaterman/LeftAlign.cpp',
+ 'vcflib/smithwaterman/IndelAllele.cpp',
+ ]
+endif
#
@@ -105,23 +160,18 @@ seqlib_src = [
]
vcflib_src = [
- 'vcflib/tabixpp/tabix.cpp',
- 'vcflib/src/Variant.cpp',
- 'vcflib/smithwaterman/SmithWatermanGotoh.cpp',
- 'vcflib/smithwaterman/disorder.cpp',
- 'vcflib/smithwaterman/Repeats.cpp',
- 'vcflib/smithwaterman/LeftAlign.cpp',
- 'vcflib/smithwaterman/IndelAllele.cpp',
+ vcflib_src,
+ tabixpp_src,
+ smithwaterman_src,
]
bamleftalign_src = [
'src/bamleftalign.cpp',
'src/IndelAllele.cpp',
'contrib/SeqLib/src/BamWriter.cpp',
- 'vcflib/fastahack/Fasta.cpp',
- 'vcflib/smithwaterman/LeftAlign.cpp',
- 'vcflib/smithwaterman/IndelAllele.cpp',
- 'vcflib/src/split.cpp',
+ fastahack_src,
+ smithwaterman_src,
+ vcflib_src,
'src/LeftAlign.cpp',
]
@@ -134,11 +184,9 @@ incdir = include_directories(
'ttmath',
'contrib',
'contrib/SeqLib',
- 'vcflib/src',
- 'vcflib/tabixpp',
- 'vcflib/smithwaterman',
- 'vcflib/multichoose',
- 'vcflib/filevercmp')
+ tabixpp_includes,
+ smithwaterman_includes,
+ vcflib_includes)
c_args = ['-fpermissive','-w']
cpp_args = ['-fpermissive','-w','-Wc++14-compat']
@@ -152,7 +200,7 @@ executable('freebayes',
include_directories : incdir,
cpp_args : cpp_args,
c_args : c_args,
- dependencies: [zlib_dep, lzma_dep, htslib_dep, thread_dep],
+ dependencies: [zlib_dep, lzma_dep, simde_dep, htslib_dep, tabixpp_dep, smithwaterman_dep, vcflib_dep, thread_dep],
install: true
)
@@ -165,7 +213,7 @@ executable('bamleftalign',
include_directories : incdir,
cpp_args : cpp_args,
c_args : c_args,
- dependencies: [zlib_dep, lzma_dep, htslib_dep, thread_dep],
+ dependencies: [zlib_dep, lzma_dep, simde_dep, htslib_dep, tabixpp_dep, fastahack_dep, smithwaterman_dep, vcflib_dep, thread_dep],
install: true
)
--
2.30.0