me
/
guix
Archived
1
0
Fork 0

gnu: curl, gnurl: Fix failing testcase 172.

* gnu/packages/patches/curl-fix-test172.patch: New file.
* gnu-system.am (dist_patch_DATA): Add the patch file.
* gnu/packages/gnunet.scm (gnurl): Apply the patch file.
* gnu/packages/curl.scm (curl): Apply the patch file.

Signed-off-by: Andreas Enge <andreas@enge.fr>
master
Sree Harsha Totakura 2014-02-11 19:17:33 +01:00 committed by Andreas Enge
parent 1680df13a8
commit b6b29c7737
4 changed files with 23 additions and 2 deletions

View File

@ -242,6 +242,7 @@ dist_patch_DATA = \
gnu/packages/patches/cdparanoia-fpic.patch \ gnu/packages/patches/cdparanoia-fpic.patch \
gnu/packages/patches/cmake-fix-tests.patch \ gnu/packages/patches/cmake-fix-tests.patch \
gnu/packages/patches/cpio-gets-undeclared.patch \ gnu/packages/patches/cpio-gets-undeclared.patch \
gnu/packages/patches/curl-fix-test172.patch \
gnu/packages/patches/dbus-localstatedir.patch \ gnu/packages/patches/dbus-localstatedir.patch \
gnu/packages/patches/diffutils-gets-undeclared.patch \ gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dmd-getpw.patch \ gnu/packages/patches/dmd-getpw.patch \

View File

@ -22,6 +22,7 @@
#:use-module (guix packages) #:use-module (guix packages)
#:use-module (guix download) #:use-module (guix download)
#:use-module (guix build-system gnu) #:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages compression) #:use-module (gnu packages compression)
#:use-module (gnu packages gnutls) #:use-module (gnu packages gnutls)
#:use-module (gnu packages groff) #:use-module (gnu packages groff)
@ -42,7 +43,11 @@
version ".tar.lzma")) version ".tar.lzma"))
(sha256 (sha256
(base32 (base32
"13bhfs41yf60ys2hrikqxjwfzaj0gm91kqzsgc5fr4grzmpm38nx")))) "13bhfs41yf60ys2hrikqxjwfzaj0gm91kqzsgc5fr4grzmpm38nx"))
(patches
;; This patch fixes testcase 172 which uses a hardcoded cookie
;; expiration value which is expired as of Feb 1, 2014.
(list (search-patch "curl-fix-test172.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls) (inputs `(("gnutls" ,gnutls)
("gss" ,gss) ("gss" ,gss)

View File

@ -144,7 +144,10 @@ and support for SSL3 and TLS.")
version ".tar.bz2")) version ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp")))) "0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp"))
;; This patch fixes testcase 172 which uses a hardcoded cookie
;; expiration value which is expired as of Feb 1, 2014.
(patches (list (search-patch "curl-fix-test172.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls) (inputs `(("gnutls" ,gnutls)
("libidn" ,libidn) ("libidn" ,libidn)

View File

@ -0,0 +1,12 @@
diff --git a/tests/data/test172 b/tests/data/test172
index b3efae9..3d53418 100644
--- a/tests/data/test172
+++ b/tests/data/test172
@@ -36,7 +36,7 @@ http://%HOSTIP:%HTTPPORT/we/want/172 -b log/jar172.txt -b "tool=curl; name=fool"
.%HOSTIP TRUE /silly/ FALSE 0 ismatch this
.%HOSTIP TRUE / FALSE 0 partmatch present
-%HOSTIP FALSE /we/want/ FALSE 1391252187 nodomain value
+%HOSTIP FALSE /we/want/ FALSE 2139150993 nodomain value
</file>
</client>