gnu: clamav: Update to 0.103.0.
* gnu/packages/antivirus.scm (clamav): Update to 0.103.0. * gnu/packages/patches/clamav-system-tomsfastmath.patch: Update patch.master
parent
2a372bedbf
commit
b7210a3241
|
@ -44,14 +44,14 @@
|
|||
(define-public clamav
|
||||
(package
|
||||
(name "clamav")
|
||||
(version "0.102.4")
|
||||
(version "0.103.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.clamav.net/downloads/production/"
|
||||
"clamav-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"06rrzyrhnr0rswryijpbbzywr6387rv8qjq8sb8cl3h2d1m45ggf"))
|
||||
"0ih5x1rscg2m64y0z20njj7435q8k7ss575cfw7aipdzfx979a9j"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Sun, 24 Feb 2019 15:50:37 +0100
|
||||
Date: Sat, 03 Oct 2020 22:10:20 +0200
|
||||
Subject: gnu: clamav: Add support for system tomsfastmath.
|
||||
|
||||
Adjusted from the original for clamav 0.101.1:
|
||||
Adjusted from the original for clamav 0.103.0:
|
||||
|
||||
From 756ff89526b5ffaa7a4f49b1bbecf2ecbd6f85f9 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
|
||||
|
@ -19,9 +19,10 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
|
|||
5 files changed, 28 insertions(+), 4 deletions(-)
|
||||
create mode 100644 m4/reorganization/libs/tomsfastmath.m4
|
||||
|
||||
--- a/configure.ac 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/configure.ac 2019-02-24 15:47:14.076992864 +0100
|
||||
@@ -89,6 +89,7 @@
|
||||
diff -Naur a/configure.ac b/configure.ac
|
||||
--- a/configure.ac 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/configure.ac 2020-10-03 22:04:00.535448352 +0200
|
||||
@@ -94,6 +94,7 @@
|
||||
m4_include([m4/reorganization/libs/json.m4])
|
||||
m4_include([m4/reorganization/libs/pcre.m4])
|
||||
m4_include([m4/reorganization/libs/libmspack.m4])
|
||||
|
@ -29,7 +30,7 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
|
|||
|
||||
if test "x$use_internal_mspack" = "xno"; then
|
||||
mspack_msg="External, $LIBMSPACK_CFLAGS $LIBMSPACK_LIBS"
|
||||
@@ -297,6 +298,7 @@
|
||||
@@ -361,6 +362,7 @@
|
||||
fi
|
||||
CL_MSG_STATUS([yara ],[$enable_yara],[$enable_yara])
|
||||
CL_MSG_STATUS([fts ],[yes],[$lfs_fts_msg])
|
||||
|
@ -37,9 +38,9 @@ Patch-Name: add-support-for-system-tomsfastmath.patch
|
|||
|
||||
|
||||
# Yep, downgrading the compiler avoids the bug too:
|
||||
diff -Naur clamav-0.101.1/libclamav/bignum.h clamav-0.101.1b/libclamav/bignum.h
|
||||
--- a/libclamav/bignum.h 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/libclamav/bignum.h 2019-02-24 15:46:36.216998323 +0100
|
||||
diff -Naur a/libclamav/bignum.h b/libclamav/bignum.h
|
||||
--- a/libclamav/bignum.h 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/libclamav/bignum.h 2020-10-03 22:04:00.535448352 +0200
|
||||
@@ -1,9 +1,13 @@
|
||||
#ifndef BIGNUM_H_
|
||||
#define BIGNUM_H_
|
||||
|
@ -54,11 +55,11 @@ diff -Naur clamav-0.101.1/libclamav/bignum.h clamav-0.101.1b/libclamav/bignum.h
|
|||
+
|
||||
typedef fp_int mp_int;
|
||||
#define mp_cmp fp_cmp
|
||||
#define mp_toradix_n(a,b,c,d) fp_toradix_n(a,b,c,d)
|
||||
diff -Naur clamav-0.101.1/libclamav/Makefile.am clamav-0.101.1b/libclamav/Makefile.am
|
||||
--- a/libclamav/Makefile.am 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/libclamav/Makefile.am 2019-02-24 15:46:36.216998323 +0100
|
||||
@@ -597,8 +597,10 @@
|
||||
#define mp_toradix_n(a, b, c, d) fp_toradix_n(a, b, c, d)
|
||||
diff -Naur a/libclamav/Makefile.am b/libclamav/Makefile.am
|
||||
--- a/libclamav/Makefile.am 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/libclamav/Makefile.am 2020-10-03 22:06:42.705447754 +0200
|
||||
@@ -588,8 +588,10 @@
|
||||
yara_clam.h
|
||||
endif
|
||||
|
||||
|
@ -71,7 +72,7 @@ diff -Naur clamav-0.101.1/libclamav/Makefile.am clamav-0.101.1b/libclamav/Makefi
|
|||
tomsfastmath/addsub/fp_add.c\
|
||||
tomsfastmath/addsub/fp_add_d.c\
|
||||
tomsfastmath/addsub/fp_addmod.c\
|
||||
@@ -680,6 +682,10 @@
|
||||
@@ -671,6 +673,10 @@
|
||||
tomsfastmath/sqr/fp_sqr_comba_generic.c\
|
||||
tomsfastmath/sqr/fp_sqr_comba_small_set.c\
|
||||
tomsfastmath/sqr/fp_sqrmod.c
|
||||
|
@ -80,11 +81,11 @@ diff -Naur clamav-0.101.1/libclamav/Makefile.am clamav-0.101.1b/libclamav/Makefi
|
|||
+libclamav_la_LIBADD += $(TOMSFASTMATH_LIBS)
|
||||
+endif
|
||||
|
||||
.PHONY: version.h.tmp
|
||||
.PHONY2: version.h.tmp
|
||||
version.c: version.h
|
||||
diff -Naur clamav-0.101.1/libclamav/xdp.c clamav-0.101.1b/libclamav/xdp.c
|
||||
--- a/libclamav/xdp.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/libclamav/xdp.c 2019-02-24 15:46:36.216998323 +0100
|
||||
diff -Naur a/libclamav/xdp.c b/libclamav/xdp.c
|
||||
--- a/libclamav/xdp.c 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/libclamav/xdp.c 2020-10-03 22:04:00.535448352 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
#include "scanners.h"
|
||||
#include "conv.h"
|
||||
|
@ -94,9 +95,9 @@ diff -Naur clamav-0.101.1/libclamav/xdp.c clamav-0.101.1b/libclamav/xdp.c
|
|||
#include "filetypes.h"
|
||||
|
||||
static char *dump_xdp(cli_ctx *ctx, const char *start, size_t sz);
|
||||
diff -Naur clamav-0.101.1/m4/reorganization/libs/tomsfastmath.m4 clamav-0.101.1b/m4/reorganization/libs/tomsfastmath.m4
|
||||
diff -Naur a/m4/reorganization/libs/tomsfastmath.m4 b/m4/reorganization/libs/tomsfastmath.m4
|
||||
--- a/m4/reorganization/libs/tomsfastmath.m4 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ b/m4/reorganization/libs/tomsfastmath.m4 2019-02-24 15:46:36.216998323 +0100
|
||||
+++ b/m4/reorganization/libs/tomsfastmath.m4 2020-10-03 22:04:00.535448352 +0200
|
||||
@@ -0,0 +1,12 @@
|
||||
+dnl Check for system tomsfastmath
|
||||
+PKG_CHECK_MODULES([TOMSFASTMATH], [tomsfastmath], [have_system_tomsfastmath=yes], [have_system_tomsfastmath=no])
|
||||
|
|
Reference in New Issue