me
/
guix
Archived
1
0
Fork 0

gnu: guile-email: Fix build.

* gnu/packages/patches/guile-email-fix-tests.patch: New file.
* gnu/local.mk (DIST_PATCH_DATA): Add it.
* gnu/packages/guile-xyz.scm (guile-email): Use it.
master
Mathieu Othacehe 2021-09-29 12:56:14 +00:00
parent 8d02c2c39e
commit b77782f702
No known key found for this signature in database
GPG Key ID: 8354763531769CA6
3 changed files with 39 additions and 1 deletions

View File

@ -1206,6 +1206,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-present-coding.patch \
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
%D%/packages/patches/guile-emacs-fix-configure.patch \
%D%/packages/patches/guile-email-fix-tests.patch \
%D%/packages/patches/guile-ssh-fix-test-suite.patch \
%D%/packages/patches/guile-ssh-read-error.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \

View File

@ -1285,7 +1285,9 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
version ".tar.lz"))
(sha256
(base32
"1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))))
"1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))
(patches
(search-patches "guile-email-fix-tests.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)

View File

@ -0,0 +1,35 @@
This patch has been proposed upstream:
https://lists.systemreboot.net/guile-email/87mtnv1r2p.fsf@gnu.org/T/#u.
From c21fe0f0e28b80b606973d3e372e2bc8528c9766 Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <othacehe@gnu.org>
Date: Wed, 29 Sep 2021 12:47:35 +0000
Subject: [PATCH 1/1] email: Do not use an empty bytevector to test the
charset.
Using an empty bytevector no longer throws an exception since this Guile
commit: 5ea8c69e9153a970952bf6f0b32c4fad6a28e839.
* email/email.scm (post-process-content-transfer-encoding): Use a bytevector
containg the 'e' character to test the charset validity.
---
email/email.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/email/email.scm b/email/email.scm
index 3f4e194..ac70463 100644
--- a/email/email.scm
+++ b/email/email.scm
@@ -832,7 +832,8 @@ values. The returned headers is a string and body is a bytevector."
(define (valid-charset? charset)
(catch #t
(lambda ()
- (bytevector->string (make-bytevector 0 0) charset)
+ ;; Try to convert a bytevector containg the 'e' character.
+ (bytevector->string (make-bytevector 1 48) charset)
#t)
(const #f)))
--
2.33.0