gnu: fuse: Update to 2.9.4.
* gnu/packages/patches/fuse-CVE-2015-3202.patch: Delete file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/linux.scm (fuse): Update to 2.9.4. [source]: Remove patch.master
parent
c7d0bf0071
commit
b7e7d1b9d3
|
@ -467,7 +467,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/flint-ldconfig.patch \
|
gnu/packages/patches/flint-ldconfig.patch \
|
||||||
gnu/packages/patches/fltk-shared-lib-defines.patch \
|
gnu/packages/patches/fltk-shared-lib-defines.patch \
|
||||||
gnu/packages/patches/freeimage-CVE-2015-0852.patch \
|
gnu/packages/patches/freeimage-CVE-2015-0852.patch \
|
||||||
gnu/packages/patches/fuse-CVE-2015-3202.patch \
|
|
||||||
gnu/packages/patches/gawk-shell.patch \
|
gnu/packages/patches/gawk-shell.patch \
|
||||||
gnu/packages/patches/gcc-arm-link-spec-fix.patch \
|
gnu/packages/patches/gcc-arm-link-spec-fix.patch \
|
||||||
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
||||||
|
|
|
@ -1242,15 +1242,18 @@ processes currently causing I/O.")
|
||||||
(define-public fuse
|
(define-public fuse
|
||||||
(package
|
(package
|
||||||
(name "fuse")
|
(name "fuse")
|
||||||
(version "2.9.3")
|
(version "2.9.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/fuse/fuse-"
|
(uri (let ((version-with-underscores
|
||||||
version ".tar.gz"))
|
(string-join (string-split version #\.) "_")))
|
||||||
|
(string-append
|
||||||
|
"https://github.com/libfuse/libfuse/"
|
||||||
|
"releases/download/" version-with-underscores
|
||||||
|
"/fuse-" version ".tar.gz")))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"071r6xjgssy8vwdn6m28qq1bqxsd2bphcd2mzhq0grf5ybm87sqb"))
|
"1qbwp63a2bp0bchabkwiyzszi9x5krlk2pwk2is6g35gyszw1sbb"))))
|
||||||
(patches (list (search-patch "fuse-CVE-2015-3202.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("util-linux" ,util-linux)))
|
(inputs `(("util-linux" ,util-linux)))
|
||||||
(arguments
|
(arguments
|
||||||
|
|
|
@ -1,65 +0,0 @@
|
||||||
The following patch was copied from Debian.
|
|
||||||
|
|
||||||
Description: Fix CVE-2015-3202
|
|
||||||
Missing scrubbing of the environment before executing a mount or umount
|
|
||||||
of a filesystem.
|
|
||||||
Origin: upstream
|
|
||||||
Author: Miklos Szeredi <miklos@szeredi.hu>
|
|
||||||
Last-Update: 2015-05-19
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/mount_util.c | 23 +++++++++++++++++------
|
|
||||||
1 file changed, 17 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
--- a/lib/mount_util.c
|
|
||||||
+++ b/lib/mount_util.c
|
|
||||||
@@ -95,10 +95,12 @@ static int add_mount(const char *prognam
|
|
||||||
goto out_restore;
|
|
||||||
}
|
|
||||||
if (res == 0) {
|
|
||||||
+ char *env = NULL;
|
|
||||||
+
|
|
||||||
sigprocmask(SIG_SETMASK, &oldmask, NULL);
|
|
||||||
setuid(geteuid());
|
|
||||||
- execl("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
|
|
||||||
- "-f", "-t", type, "-o", opts, fsname, mnt, NULL);
|
|
||||||
+ execle("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
|
|
||||||
+ "-f", "-t", type, "-o", opts, fsname, mnt, NULL, &env);
|
|
||||||
fprintf(stderr, "%s: failed to execute /bin/mount: %s\n",
|
|
||||||
progname, strerror(errno));
|
|
||||||
exit(1);
|
|
||||||
@@ -146,10 +148,17 @@ static int exec_umount(const char *progn
|
|
||||||
goto out_restore;
|
|
||||||
}
|
|
||||||
if (res == 0) {
|
|
||||||
+ char *env = NULL;
|
|
||||||
+
|
|
||||||
sigprocmask(SIG_SETMASK, &oldmask, NULL);
|
|
||||||
setuid(geteuid());
|
|
||||||
- execl("/bin/umount", "/bin/umount", "-i", rel_mnt,
|
|
||||||
- lazy ? "-l" : NULL, NULL);
|
|
||||||
+ if (lazy) {
|
|
||||||
+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
|
|
||||||
+ "-l", NULL, &env);
|
|
||||||
+ } else {
|
|
||||||
+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
|
|
||||||
+ NULL, &env);
|
|
||||||
+ }
|
|
||||||
fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
|
|
||||||
progname, strerror(errno));
|
|
||||||
exit(1);
|
|
||||||
@@ -205,10 +214,12 @@ static int remove_mount(const char *prog
|
|
||||||
goto out_restore;
|
|
||||||
}
|
|
||||||
if (res == 0) {
|
|
||||||
+ char *env = NULL;
|
|
||||||
+
|
|
||||||
sigprocmask(SIG_SETMASK, &oldmask, NULL);
|
|
||||||
setuid(geteuid());
|
|
||||||
- execl("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
|
|
||||||
- "--fake", mnt, NULL);
|
|
||||||
+ execle("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
|
|
||||||
+ "--fake", mnt, NULL, &env);
|
|
||||||
fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
|
|
||||||
progname, strerror(errno));
|
|
||||||
exit(1);
|
|
Reference in New Issue