From b8c66755e1f8349411bcb18b1fd2824edfa61ff3 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:46:25 +0200
Subject: [PATCH] gnu: Add texlive-colorwav.

* gnu/packages/tex.scm (texlive-colorwav): New variable.
---
 gnu/packages/tex.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 424ccbf610..84066fce59 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -76662,6 +76662,30 @@ table-colouring option of the @code{xcolor}.  However, @code{colortab} remains
 an adequate solution for use with Plain TeX.")
     (license license:lppl)))
 
+(define-public texlive-colorwav
+  (package
+    (name "texlive-colorwav")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/colorwav/"
+                   "source/latex/colorwav/"
+                   "tex/latex/colorwav/")
+             (base32
+              "1kcan6nzkis8xwkfnv7536qr7yxr2gvdi9kcxz5c98jwjapqph1k")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/colorwav")
+    (synopsis "Colours by wavelength of visible light")
+    (description
+     "The package allows the user to obtain an RGB value (suitable for use in the
+@code{color} package) from a wavelength of light.  The default unit is
+nanometres, but other units may be used.  Note that this function is also
+available within @code{xcolor}.")
+    ;; "colorwav.sty" mentions "This package is released under the GNU
+    ;; LGPL." Assume the latest one.
+    (license license:lgpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar