gnu: libxt: Update to 1.2.1.
* gnu/packages/xorg.scm (libxt): Update to 1.2.1. * gnu/packages/patches/libxt-guix-search-paths.patch: Adjust context.master
parent
a96a9934b5
commit
ba8dd0cdd4
|
@ -1,13 +1,9 @@
|
||||||
diff --git a/src/Intrinsic.c b/src/Intrinsic.c
|
diff --git a/src/Intrinsic.c b/src/Intrinsic.c
|
||||||
index c9624ec..addcdba 100644
|
|
||||||
--- a/src/Intrinsic.c
|
--- a/src/Intrinsic.c
|
||||||
+++ b/src/Intrinsic.c
|
+++ b/src/Intrinsic.c
|
||||||
@@ -1312,21 +1312,101 @@ static void FillInLangSubs(
|
@@ -1345,21 +1345,99 @@ FillInLangSubs(Substitution subs, XtPerDisplay pd)
|
||||||
} else (void) strcpy(*rest, string);
|
|
||||||
}
|
}
|
||||||
|
|
||||||
+
|
|
||||||
+
|
|
||||||
/*
|
/*
|
||||||
- * default path used if environment variable XFILESEARCHPATH
|
- * default path used if environment variable XFILESEARCHPATH
|
||||||
- * is not defined. Also substitued for %D.
|
- * is not defined. Also substitued for %D.
|
||||||
|
@ -24,8 +20,9 @@ index c9624ec..addcdba 100644
|
||||||
+ These values provide the default paths where Guix/GuixSD can expect
|
+ These values provide the default paths where Guix/GuixSD can expect
|
||||||
+ to find resources for installed packages.
|
+ to find resources for installed packages.
|
||||||
*/
|
*/
|
||||||
-static const char *implementation_default_path(void)
|
static const char *
|
||||||
+static const char *guix_default_path(void)
|
-implementation_default_path(void)
|
||||||
|
+guix_default_path(void)
|
||||||
{
|
{
|
||||||
-#if defined(WIN32)
|
-#if defined(WIN32)
|
||||||
- static char xfilesearchpath[] = "";
|
- static char xfilesearchpath[] = "";
|
||||||
|
@ -115,7 +112,7 @@ index c9624ec..addcdba 100644
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
@@ -1354,7 +1434,7 @@ _XtString XtResolvePathname(
|
@@ -1388,7 +1466,7 @@ XtResolvePathname(Display *dpy,
|
||||||
{
|
{
|
||||||
XtPerDisplay pd;
|
XtPerDisplay pd;
|
||||||
static const char *defaultPath = NULL;
|
static const char *defaultPath = NULL;
|
||||||
|
|
|
@ -5579,7 +5579,7 @@ draggable titlebars and borders.")
|
||||||
(define-public libxt
|
(define-public libxt
|
||||||
(package
|
(package
|
||||||
(name "libxt")
|
(name "libxt")
|
||||||
(version "1.2.0")
|
(version "1.2.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5589,7 +5589,7 @@ draggable titlebars and borders.")
|
||||||
".tar.bz2"))
|
".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0cbqlyssr8aia88c8i7z59z9d0kp3p2hp6683xhz9ndyv8qza7dk"))
|
"0q1x7842r8rcn2m0q4q9f69h4qa097fyizs8brzx5ns62s7w1737"))
|
||||||
(patches (search-patches "libxt-guix-search-paths.patch"))))
|
(patches (search-patches "libxt-guix-search-paths.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(outputs '("out"
|
(outputs '("out"
|
||||||
|
|
Reference in New Issue