gnu: python-django: Update to 1.10.3 [fixes CVE-2016-{9013,9014}].
* gnu/packages/django.scm (python-django, python2-django): Update to 1.10.3. [source]: Remove patch. * gnu/packages/patches/python-django-fix-testcase.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
b56d9ce304
commit
bac3d6095d
|
@ -804,7 +804,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-3-search-paths.patch \
|
||||
%D%/packages/patches/python-dendropy-exclude-failing-tests.patch \
|
||||
%D%/packages/patches/python-disable-ssl-test.patch \
|
||||
%D%/packages/patches/python-django-fix-testcase.patch \
|
||||
%D%/packages/patches/python-fix-tests.patch \
|
||||
%D%/packages/patches/python-ipython-inputhook-ctype.patch \
|
||||
%D%/packages/patches/python-rarfile-fix-tests.patch \
|
||||
|
|
|
@ -29,14 +29,13 @@
|
|||
(define-public python-django
|
||||
(package
|
||||
(name "python-django")
|
||||
(version "1.10")
|
||||
(version "1.10.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "Django" version))
|
||||
(sha256
|
||||
(base32
|
||||
"01bh5yra6zyxcpqacahbwfbn0y4ivw07j2jsw3crvmjzivb6if26"))
|
||||
(patches (search-patches "python-django-fix-testcase.patch"))))
|
||||
"0c4c8zs7kzb0bdlpy4vlzv6va26dbazr32h91rldf6waxs6z14kg"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
'(#:phases
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
From 24123c31362b5f3783d84d133c160e9fe16805fe Mon Sep 17 00:00:00 2001
|
||||
From: Tim Graham <timograham@gmail.com>
|
||||
Date: Mon, 1 Aug 2016 15:40:46 -0400
|
||||
Subject: [PATCH] Fixed admin_utils test failures due to translation updates.
|
||||
|
||||
https://github.com/django/django/commit/24123c31362b5f3783d84d133c160e9fe16805fe
|
||||
|
||||
---
|
||||
tests/admin_utils/test_logentry.py | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tests/admin_utils/test_logentry.py b/tests/admin_utils/test_logentry.py
|
||||
index 7798373..8259bf0 100644
|
||||
--- a/tests/admin_utils/test_logentry.py
|
||||
+++ b/tests/admin_utils/test_logentry.py
|
||||
@@ -59,7 +59,7 @@ class LogEntryTests(TestCase):
|
||||
logentry = LogEntry.objects.filter(content_type__model__iexact='article').latest('id')
|
||||
self.assertEqual(logentry.get_change_message(), 'Changed title and hist.')
|
||||
with translation.override('fr'):
|
||||
- self.assertEqual(logentry.get_change_message(), 'Modification de title et hist.')
|
||||
+ self.assertEqual(logentry.get_change_message(), 'Title et hist modifié(s).')
|
||||
|
||||
add_url = reverse('admin:admin_utils_article_add')
|
||||
post_data['title'] = 'New'
|
||||
@@ -117,11 +117,12 @@ class LogEntryTests(TestCase):
|
||||
'Changed domain. Added article "Article object". '
|
||||
'Changed title for article "Article object". Deleted article "Article object".'
|
||||
)
|
||||
+
|
||||
with translation.override('fr'):
|
||||
self.assertEqual(
|
||||
logentry.get_change_message(),
|
||||
- 'Modification de domain. Article « Article object » ajouté. '
|
||||
- 'Modification de title pour l\'objet article « Article object ». Article « Article object » supprimé.'
|
||||
+ "Domain modifié(s). Article « Article object » ajouté. "
|
||||
+ "Title modifié(s) pour l'objet article « Article object ». Article « Article object » supprimé."
|
||||
)
|
||||
|
||||
def test_logentry_get_edited_object(self):
|
||||
--
|
||||
2.7.4
|
||||
|
Reference in New Issue