gnu: libxslt: Update to 1.1.34.
* gnu/packages/xml.scm (libxslt): Update to 1.1.34. [arguments]: Add phase to disable fuzz tests. * gnu/packages/patches/libxslt-generated-ids.patch: Adjust for upstream changes.master
parent
066398768d
commit
badcb119c5
|
@ -162,10 +162,10 @@ diff --git a/libxslt/xsltInternals.h b/libxslt/xsltInternals.h
|
||||||
index 95e8fe6..8eedae4 100644
|
index 95e8fe6..8eedae4 100644
|
||||||
--- a/libxslt/xsltInternals.h
|
--- a/libxslt/xsltInternals.h
|
||||||
+++ b/libxslt/xsltInternals.h
|
+++ b/libxslt/xsltInternals.h
|
||||||
@@ -1786,6 +1786,8 @@ struct _xsltTransformContext {
|
@@ -1782,6 +1782,8 @@ struct _xsltTransformContext {
|
||||||
int funcLevel; /* Needed to catch recursive functions issues */
|
|
||||||
int maxTemplateDepth;
|
|
||||||
int maxTemplateVars;
|
int maxTemplateVars;
|
||||||
|
unsigned long opLimit;
|
||||||
|
unsigned long opCount;
|
||||||
+
|
+
|
||||||
+ unsigned long nextid;/* for generating stable ids */
|
+ unsigned long nextid;/* for generating stable ids */
|
||||||
};
|
};
|
||||||
|
|
|
@ -212,16 +212,26 @@ project (but it is usable outside of the Gnome platform).")
|
||||||
(define-public libxslt
|
(define-public libxslt
|
||||||
(package
|
(package
|
||||||
(name "libxslt")
|
(name "libxslt")
|
||||||
(version "1.1.33")
|
(version "1.1.34")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
|
(uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1j1q1swnsy8jgi9x7mclvkrqhfgn09886gdlr9wzk7a08i8n0dlf"))
|
"0zrzz6kjdyavspzik6fbkpvfpbd25r2qg6py5nnjaabrsr3bvccq"))
|
||||||
(patches (search-patches "libxslt-generated-ids.patch"))))
|
(patches (search-patches "libxslt-generated-ids.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:phases (modify-phases %standard-phases
|
||||||
|
(add-before 'check 'disable-fuzz-tests
|
||||||
|
(lambda _
|
||||||
|
;; Disable libFuzzer tests, because they require
|
||||||
|
;; instrumentation builds of libxml2 and libxslt.
|
||||||
|
(substitute* "tests/Makefile"
|
||||||
|
(("exslt plugins fuzz")
|
||||||
|
"exslt plugins"))
|
||||||
|
#t)))))
|
||||||
(home-page "http://xmlsoft.org/XSLT/index.html")
|
(home-page "http://xmlsoft.org/XSLT/index.html")
|
||||||
(synopsis "C library for applying XSLT stylesheets to XML documents")
|
(synopsis "C library for applying XSLT stylesheets to XML documents")
|
||||||
(inputs `(("libgcrypt" ,libgcrypt)
|
(inputs `(("libgcrypt" ,libgcrypt)
|
||||||
|
|
Reference in New Issue