gnu: geoclue: Update to 2.6.0 and remove input labels.
* gnu/packages/gnome.scm (geoclue): Update to 2.6.0. [native-inputs]: Replace intltool with gettext-minimal. Add vala. [inputs]: Delete labels. * gnu/packages/patches/geoclue-config.patch: Refresh patch.master
parent
5f7b0141d6
commit
bbe444bcc1
|
@ -5393,7 +5393,7 @@ output devices.")
|
||||||
(define-public geoclue
|
(define-public geoclue
|
||||||
(package
|
(package
|
||||||
(name "geoclue")
|
(name "geoclue")
|
||||||
(version "2.5.7")
|
(version "2.6.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5401,7 +5401,7 @@ output devices.")
|
||||||
(string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
|
(string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
|
||||||
version "/geoclue-" version ".tar.bz2"))
|
version "/geoclue-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "09ww26a76kanldhgwnn5sqy9ly2940k45zpp68spykkv2zjdpivc"))
|
(base32 "1854i8lih1jkks5w38xv8k5gs7s8629qjg3cg96ji0ffk35yzjfd"))
|
||||||
(patches (search-patches "geoclue-config.patch"))))
|
(patches (search-patches "geoclue-config.patch"))))
|
||||||
(build-system meson-build-system)
|
(build-system meson-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
|
@ -5412,13 +5412,14 @@ output devices.")
|
||||||
modem-manager
|
modem-manager
|
||||||
libnotify
|
libnotify
|
||||||
gtk-doc/stable
|
gtk-doc/stable
|
||||||
intltool))
|
gettext-minimal
|
||||||
|
vala))
|
||||||
(inputs
|
(inputs
|
||||||
`(("avahi" ,avahi)
|
(list avahi
|
||||||
("glib:bin" ,glib "bin")
|
`(,glib "bin")
|
||||||
("glib-networking" ,glib-networking)
|
glib-networking
|
||||||
("json-glib" ,json-glib)
|
json-glib
|
||||||
("libsoup" ,libsoup-minimal-2)))
|
libsoup-minimal-2))
|
||||||
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
|
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
|
||||||
(synopsis "Geolocation service")
|
(synopsis "Geolocation service")
|
||||||
(description "Geoclue is a D-Bus service that provides location
|
(description "Geoclue is a D-Bus service that provides location
|
||||||
|
|
|
@ -1,25 +1,25 @@
|
||||||
Allow the configuration file to be specified via an environment variable.
|
diff --git a/src/gclue-config.c b/src/gclue-config.c
|
||||||
|
index 7ab2a67..e41f3df 100644
|
||||||
--- geoclue-2.1.10/src/gclue-config.c 2015-04-07 09:50:07.721074380 +0200
|
--- a/src/gclue-config.c
|
||||||
+++ geoclue-2.1.10/src/gclue-config.c 2015-04-07 10:27:26.613171960 +0200
|
+++ b/src/gclue-config.c
|
||||||
@@ -235,6 +235,11 @@
|
@@ -332,6 +332,11 @@ static void
|
||||||
gclue_config_init (GClueConfig *config)
|
gclue_config_init (GClueConfig *config)
|
||||||
{
|
{
|
||||||
GError *error = NULL;
|
GError *error = NULL;
|
||||||
+ const char *config_file_path;
|
+ const char *config_file_path;
|
||||||
+
|
+
|
||||||
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
|
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
|
||||||
+ if (config_file_path == NULL)
|
+ if (!config_file_path)
|
||||||
+ config_file_path = CONFIG_FILE_PATH;
|
+ config_file_path = CONFIG_FILE_PATH;
|
||||||
|
|
||||||
config->priv =
|
config->priv = gclue_config_get_instance_private(config);
|
||||||
G_TYPE_INSTANCE_GET_PRIVATE (config,
|
|
||||||
@@ -242,7 +247,7 @@
|
|
||||||
GClueConfigPrivate);
|
|
||||||
config->priv->key_file = g_key_file_new ();
|
config->priv->key_file = g_key_file_new ();
|
||||||
g_key_file_load_from_file (config->priv->key_file,
|
@@ -341,7 +346,7 @@ gclue_config_init (GClueConfig *config)
|
||||||
- CONFIG_FILE_PATH,
|
|
||||||
+ config_file_path,
|
|
||||||
0,
|
|
||||||
&error);
|
&error);
|
||||||
if (error != NULL) {
|
if (error != NULL) {
|
||||||
|
g_critical ("Failed to load configuration file '%s': %s",
|
||||||
|
- CONFIG_FILE_PATH, error->message);
|
||||||
|
+ config_file_path, error->message);
|
||||||
|
g_error_free (error);
|
||||||
|
|
||||||
|
return;
|
||||||
|
|
Reference in New Issue