gnu: ntfs-3g: Fix patch for CVE-2017-0358.
This is a followup to commit 1a82ba660e
.
* gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch: Make patch apply.
This commit is contained in:
parent
365950ce92
commit
bd1450f1e4
1 changed files with 17 additions and 16 deletions
|
@ -2,25 +2,26 @@ Fix CVE-2017-0358:
|
||||||
http://seclists.org/oss-sec/2017/q1/259
|
http://seclists.org/oss-sec/2017/q1/259
|
||||||
This patch was copied from the above URL.
|
This patch was copied from the above URL.
|
||||||
|
|
||||||
diff -ur ntfs-3g.old/src/lowntfs-3g.c ntfs-3g/src/lowntfs-3g.c
|
diff --git a/src/lowntfs-3g.c b/src/lowntfs-3g.c
|
||||||
--- ntfs-3g.old/src/lowntfs-3g.c 2017-02-09 15:01:04.074331542 -0500
|
index 0bb38f9..c6d1dad 100644
|
||||||
+++ ntfs-3g/src/lowntfs-3g.c 2017-02-09 15:06:35.757580937 -0500
|
--- a/src/lowntfs-3g.c
|
||||||
@@ -3827,13 +3827,14 @@
|
+++ b/src/lowntfs-3g.c
|
||||||
struct stat st;
|
@@ -3827,13 +3827,14 @@ static fuse_fstype load_fuse_module(void)
|
||||||
pid_t pid;
|
struct stat st;
|
||||||
const char *cmd = "/sbin/modprobe";
|
pid_t pid;
|
||||||
|
const char *cmd = "/sbin/modprobe";
|
||||||
+ char *env = (char*)NULL;
|
+ char *env = (char*)NULL;
|
||||||
struct timespec req = { 0, 100000000 }; /* 100 msec */
|
struct timespec req = { 0, 100000000 }; /* 100 msec */
|
||||||
fuse_fstype fstype;
|
fuse_fstype fstype;
|
||||||
|
|
||||||
if (!stat(cmd, &st) && !geteuid()) {
|
if (!stat(cmd, &st) && !geteuid()) {
|
||||||
pid = fork();
|
pid = fork();
|
||||||
if (!pid) {
|
if (!pid) {
|
||||||
- execl(cmd, cmd, "fuse", NULL);
|
- execl(cmd, cmd, "fuse", NULL);
|
||||||
+ execle(cmd, cmd, "fuse", NULL, &env);
|
+ execle(cmd, cmd, "fuse", NULL, &env);
|
||||||
_exit(1);
|
_exit(1);
|
||||||
} else if (pid != -1)
|
} else if (pid != -1)
|
||||||
waitpid(pid, NULL, 0);
|
waitpid(pid, NULL, 0);
|
||||||
diff -ur ntfs-3g.old/src/ntfs-3g.c ntfs-3g/src/ntfs-3g.c
|
diff -ur ntfs-3g.old/src/ntfs-3g.c ntfs-3g/src/ntfs-3g.c
|
||||||
--- ntfs-3g.old/src/ntfs-3g.c 2017-02-09 15:01:04.074331542 -0500
|
--- ntfs-3g.old/src/ntfs-3g.c 2017-02-09 15:01:04.074331542 -0500
|
||||||
+++ ntfs-3g/src/ntfs-3g.c 2017-02-09 15:06:26.077252571 -0500
|
+++ ntfs-3g/src/ntfs-3g.c 2017-02-09 15:06:26.077252571 -0500
|
||||||
|
|
Reference in a new issue