gnu: emacs-telega: Update to 0.8.255.
* gnu/packages/emacs-xyz.scm (emacs-telega): Update to 0.8.255. * gnu/packages/patches/emacs-telega-path-placeholder.patch: Update patch. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: I8cec5a5170318f0ae99116a98afcefe31203b585master
parent
f736a784e1
commit
bdba291a72
|
@ -34992,11 +34992,11 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
|
||||||
(license license:gpl3+)))
|
(license license:gpl3+)))
|
||||||
|
|
||||||
(define-public emacs-telega-server
|
(define-public emacs-telega-server
|
||||||
(let ((commit "d1cf1ffe289a18f366b7f3b64f827f0d0755947a")
|
(let ((commit "30615199c76333af9f71992e0992ac691ca5e197")
|
||||||
(revision "0"))
|
(revision "0"))
|
||||||
(package
|
(package
|
||||||
(name "emacs-telega-server")
|
(name "emacs-telega-server")
|
||||||
(version (git-version "0.8.250" revision commit))
|
(version (git-version "0.8.255" revision commit))
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -35004,7 +35004,7 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
|
||||||
(url "https://github.com/zevlg/telega.el")
|
(url "https://github.com/zevlg/telega.el")
|
||||||
(commit commit)))
|
(commit commit)))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0s1w4zb252d70n05dbsv2rnlfsg53paklafqxasl566nnzbi0d2q"))
|
(base32 "1kdp4wg4fkv5iiihvlkcb633d07vlqzndlv3qgak0s05vylhs72r"))
|
||||||
(file-name (git-file-name "emacs-telega" version))
|
(file-name (git-file-name "emacs-telega" version))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "emacs-telega-path-placeholder.patch"
|
(search-patches "emacs-telega-path-placeholder.patch"
|
||||||
|
|
|
@ -1,31 +1,32 @@
|
||||||
From bfcd616f2870c8c3ffc9a526fcd574eb5e726a96 Mon Sep 17 00:00:00 2001
|
From 52b9a0f91094888b9dd55d3d5a50cb44887ff3d3 Mon Sep 17 00:00:00 2001
|
||||||
From: Andrew Tropin <andrew@trop.in>
|
From: Andrew Tropin <andrew@trop.in>
|
||||||
Date: Sat, 14 Jan 2023 09:33:34 +0400
|
Date: Mon, 6 May 2024 10:41:53 +0200
|
||||||
Subject: [PATCH] Add path placeholder for telega-server-command and etc-file.
|
Subject: [PATCH] Add path placeholder for telega-server-command and etc-file.
|
||||||
|
|
||||||
---
|
---
|
||||||
telega-core.el | 2 +-
|
telega-core.el | 3 +--
|
||||||
telega-customize.el | 2 +-
|
telega-customize.el | 2 +-
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/telega-core.el b/telega-core.el
|
diff --git a/telega-core.el b/telega-core.el
|
||||||
index 36f121e..f9f7976 100644
|
index f798b40..2db0d64 100644
|
||||||
--- a/telega-core.el
|
--- a/telega-core.el
|
||||||
+++ b/telega-core.el
|
+++ b/telega-core.el
|
||||||
@@ -41,7 +41,7 @@
|
@@ -45,8 +45,7 @@
|
||||||
|
|
||||||
(defun telega-etc-file (filename)
|
(defun telega-etc-file (filename)
|
||||||
"Return absolute path to FILENAME from etc/ directory in telega."
|
"Return absolute path to FILENAME from etc/ directory in telega.
|
||||||
- (expand-file-name (concat "etc/" filename) telega--lib-directory))
|
Use FILENAME as is if resulting file does not exist."
|
||||||
+ (concat "@TELEGA_SHARE@" "/" filename))
|
- (let ((abspath (expand-file-name (concat "etc/" filename)
|
||||||
|
- telega--lib-directory)))
|
||||||
(defconst telega-spoiler-translation-table
|
+ (let ((abspath (concat "@TELEGA_SHARE@" "/" filename)))
|
||||||
(let ((table (make-char-table 'translation-table)))
|
(if (file-exists-p abspath)
|
||||||
|
abspath
|
||||||
|
filename)))
|
||||||
diff --git a/telega-customize.el b/telega-customize.el
|
diff --git a/telega-customize.el b/telega-customize.el
|
||||||
index 0efb001..77cec5f 100644
|
index 8393f0f..cb21465 100644
|
||||||
--- a/telega-customize.el
|
--- a/telega-customize.el
|
||||||
+++ b/telega-customize.el
|
+++ b/telega-customize.el
|
||||||
@@ -633,7 +633,7 @@ In range [1..3]. Use 1."
|
@@ -678,7 +678,7 @@ In range [1..3]. Use 1."
|
||||||
:prefix "telega-server-"
|
:prefix "telega-server-"
|
||||||
:group 'telega)
|
:group 'telega)
|
||||||
|
|
||||||
|
@ -35,4 +36,4 @@ index 0efb001..77cec5f 100644
|
||||||
It should be absolute path or binary file searchable in `exec-path'."
|
It should be absolute path or binary file searchable in `exec-path'."
|
||||||
:type 'string
|
:type 'string
|
||||||
--
|
--
|
||||||
2.38.1
|
2.41.0
|
||||||
|
|
Reference in New Issue