gnu: xpra: Update to 5.0.2
* gnu/packages/patches/xpra-4.2-install_libs.patch: Move to ... * gnu/packages/patches/xpra-5.0-install_libs.patch: ... this file. * gnu/packages/patches/xpra-4.2-systemd-run.patch: Move to ... * gnu/packages/patches/xpra-5.0-systemd-run.patch: ... this file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/xorg.scm (xpra): Update to 5.0.2. [source] <patches>: Rename per version changes [inputs]: Add cups. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
parent
fe7b5df00c
commit
be9b7e0f65
|
@ -2133,8 +2133,8 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/xplanet-1.3.1-libdisplay_DisplayOutput.cpp.patch \
|
%D%/packages/patches/xplanet-1.3.1-libdisplay_DisplayOutput.cpp.patch \
|
||||||
%D%/packages/patches/xplanet-1.3.1-libimage_gif.c.patch \
|
%D%/packages/patches/xplanet-1.3.1-libimage_gif.c.patch \
|
||||||
%D%/packages/patches/xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch \
|
%D%/packages/patches/xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch \
|
||||||
%D%/packages/patches/xpra-4.2-systemd-run.patch \
|
%D%/packages/patches/xpra-5.0-systemd-run.patch \
|
||||||
%D%/packages/patches/xpra-4.2-install_libs.patch \
|
%D%/packages/patches/xpra-5.0-install_libs.patch \
|
||||||
%D%/packages/patches/xsane-fix-memory-leak.patch \
|
%D%/packages/patches/xsane-fix-memory-leak.patch \
|
||||||
%D%/packages/patches/xsane-fix-pdf-floats.patch \
|
%D%/packages/patches/xsane-fix-pdf-floats.patch \
|
||||||
%D%/packages/patches/xsane-fix-snprintf-buffer-length.patch \
|
%D%/packages/patches/xsane-fix-snprintf-buffer-length.patch \
|
||||||
|
|
|
@ -1,18 +1,32 @@
|
||||||
|
Distribution specific patch, not going upstream
|
||||||
|
|
||||||
This workaround for Gentoo interferes with our use of --no-compile during
|
This workaround for Gentoo interferes with our use of --no-compile during
|
||||||
the 'install stage.
|
the 'install stage.
|
||||||
|
|
||||||
--- a/setup.py 2022-01-04 10:10:05.039825000 +0100
|
diff --git a/setup.py b/setup.py
|
||||||
+++ b/setup.py 2022-01-06 15:10:31.952656039 +0100
|
index e254bf99c..90db55c3f 100755
|
||||||
@@ -589,8 +589,6 @@
|
--- a/setup.py
|
||||||
})
|
+++ b/setup.py
|
||||||
|
@@ -663,8 +663,6 @@ if modules_ENABLED:
|
||||||
|
# Utility methods for building with Cython
|
||||||
|
|
||||||
def add_cython_ext(*args, **kwargs):
|
def add_cython_ext(*args, **kwargs):
|
||||||
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
|
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
|
||||||
- return
|
- return
|
||||||
assert cython_ENABLED, "cython compilation is disabled"
|
if not cython_ENABLED:
|
||||||
|
raise ValueError(f"cannot build {args}: cython compilation is disabled")
|
||||||
if cython_tracing_ENABLED:
|
if cython_tracing_ENABLED:
|
||||||
kwargs["define_macros"] = [
|
@@ -1809,9 +1807,6 @@ else:
|
||||||
@@ -1703,14 +1701,6 @@
|
if root_prefix.endswith("/usr"):
|
||||||
|
#ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
|
||||||
|
root_prefix = root_prefix[:-4]
|
||||||
|
- for x in sys.argv:
|
||||||
|
- if x.startswith("--root="):
|
||||||
|
- root_prefix = x[len("--root="):]
|
||||||
|
print(f"install_data_override.run() root_prefix={root_prefix}")
|
||||||
|
build_xpra_conf(root_prefix)
|
||||||
|
|
||||||
|
@@ -1955,13 +1950,6 @@ else:
|
||||||
if uinput_ENABLED:
|
if uinput_ENABLED:
|
||||||
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
|
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
|
||||||
|
|
||||||
|
@ -23,7 +37,6 @@ the 'install stage.
|
||||||
- #otherwise we use the flags to skip pkgconfig
|
- #otherwise we use the flags to skip pkgconfig
|
||||||
- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
|
- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
|
||||||
- pkgconfig = no_pkgconfig
|
- pkgconfig = no_pkgconfig
|
||||||
-
|
|
||||||
if OSX and "py2app" in sys.argv:
|
if OSX and "py2app" in sys.argv:
|
||||||
import py2app #@UnresolvedImport
|
import py2app #@UnresolvedImport
|
||||||
assert py2app is not None
|
|
|
@ -1,13 +1,16 @@
|
||||||
|
Distriction specific patch, not going upstream
|
||||||
|
|
||||||
Disable systemd-run if the command is not found.
|
Disable systemd-run if the command is not found.
|
||||||
|
|
||||||
diff -ru xpra-4.2~/xpra/scripts/main.py xpra-4.2/xpra/scripts/main.py
|
diff --git a/xpra/scripts/main.py b/xpra/scripts/main.py
|
||||||
--- xpra-4.2~/xpra/scripts/main.py 2021-06-06 08:51:13.756815842 -0700
|
index 3813331a5..46e2c83a6 100755
|
||||||
+++ xpra-4.2/xpra/scripts/main.py 2021-06-06 16:07:13.371024486 -0700
|
--- a/xpra/scripts/main.py
|
||||||
@@ -331,23 +331,26 @@
|
+++ b/xpra/scripts/main.py
|
||||||
if not is_systemd_pid1():
|
@@ -337,23 +337,26 @@ def use_systemd_run(s) -> bool:
|
||||||
return False # pragma: no cover
|
cmd = ["systemd-run", "--quiet"]
|
||||||
#test it:
|
if getuid()!=0:
|
||||||
- cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
|
cmd += ["--user"]
|
||||||
|
- cmd += ["--scope", "--", "true"]
|
||||||
- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
||||||
try:
|
try:
|
||||||
- proc.communicate(timeout=2)
|
- proc.communicate(timeout=2)
|
||||||
|
@ -15,13 +18,13 @@ diff -ru xpra-4.2~/xpra/scripts/main.py xpra-4.2/xpra/scripts/main.py
|
||||||
- except TimeoutExpired: # pragma: no cover
|
- except TimeoutExpired: # pragma: no cover
|
||||||
- r = None
|
- r = None
|
||||||
- if r is None:
|
- if r is None:
|
||||||
+ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
|
- try:
|
||||||
+ proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
|
||||||
try:
|
|
||||||
- proc.terminate()
|
- proc.terminate()
|
||||||
- except Exception:
|
- except Exception:
|
||||||
- pass
|
- pass
|
||||||
- try:
|
+ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
|
||||||
|
+ proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
||||||
|
try:
|
||||||
- proc.communicate(timeout=1)
|
- proc.communicate(timeout=1)
|
||||||
+ proc.communicate(timeout=2)
|
+ proc.communicate(timeout=2)
|
||||||
+ r = proc.returncode
|
+ r = proc.returncode
|
||||||
|
@ -41,5 +44,5 @@ diff -ru xpra-4.2~/xpra/scripts/main.py xpra-4.2/xpra/scripts/main.py
|
||||||
+ except FileNotFoundError:
|
+ except FileNotFoundError:
|
||||||
+ return False
|
+ return False
|
||||||
|
|
||||||
|
def verify_gir():
|
||||||
def run_mode(script_file, error_cb, options, args, mode, defaults):
|
try:
|
|
@ -72,6 +72,7 @@
|
||||||
#:use-module (gnu packages bash)
|
#:use-module (gnu packages bash)
|
||||||
#:use-module (gnu packages bison)
|
#:use-module (gnu packages bison)
|
||||||
#:use-module (gnu packages check)
|
#:use-module (gnu packages check)
|
||||||
|
#:use-module (gnu packages cups)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
#:use-module (gnu packages emacs)
|
#:use-module (gnu packages emacs)
|
||||||
#:use-module (gnu packages flex)
|
#:use-module (gnu packages flex)
|
||||||
|
@ -6110,16 +6111,16 @@ basic eye-candy effects.")
|
||||||
(define-public xpra
|
(define-public xpra
|
||||||
(package
|
(package
|
||||||
(name "xpra")
|
(name "xpra")
|
||||||
(version "4.4.6")
|
(version "5.0.2")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://www.xpra.org/src/xpra-"
|
(uri (string-append "https://www.xpra.org/src/xpra-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0d3s13wqbn9jwqp4i55mn4chgjkrckq3jx4jrq1bcjjz5agzfrq5"))
|
(base32 "0gxv0h1spg2jl3g9cc6qxxkq6a7prmb92dqqwk0s6pvrj8w3izlk"))
|
||||||
(patches (search-patches "xpra-4.2-systemd-run.patch"
|
(patches (search-patches "xpra-5.0-systemd-run.patch"
|
||||||
"xpra-4.2-install_libs.patch"))))
|
"xpra-5.0-install_libs.patch"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
(list bash-minimal ; for wrap-program
|
(list bash-minimal ; for wrap-program
|
||||||
|
@ -6158,7 +6159,8 @@ basic eye-candy effects.")
|
||||||
python-dbus ; For desktop notifications.
|
python-dbus ; For desktop notifications.
|
||||||
dbus ; For dbus-launch command.
|
dbus ; For dbus-launch command.
|
||||||
python-lz4 ; Faster compression than zlib.
|
python-lz4 ; Faster compression than zlib.
|
||||||
python-netifaces))
|
python-netifaces
|
||||||
|
python-pycups))
|
||||||
(native-inputs (list pkg-config pandoc python-cython))
|
(native-inputs (list pkg-config pandoc python-cython))
|
||||||
(arguments
|
(arguments
|
||||||
(list
|
(list
|
||||||
|
@ -6193,7 +6195,7 @@ basic eye-candy effects.")
|
||||||
(format #f "~s" (search-input-file inputs "bin/xauth"))))
|
(format #f "~s" (search-input-file inputs "bin/xauth"))))
|
||||||
;; Fix directory of config files.
|
;; Fix directory of config files.
|
||||||
(substitute* '("xpra/scripts/config.py"
|
(substitute* '("xpra/scripts/config.py"
|
||||||
"xpra/platform/xposix/paths.py")
|
"xpra/platform/posix/paths.py")
|
||||||
(("\"/etc/xpra/?\"")
|
(("\"/etc/xpra/?\"")
|
||||||
(string-append "\"" #$output "/etc/xpra/\"")))
|
(string-append "\"" #$output "/etc/xpra/\"")))
|
||||||
;; XXX: Stolen from (gnu packages linux)
|
;; XXX: Stolen from (gnu packages linux)
|
||||||
|
|
Reference in New Issue