gnu: libgit2: Reintroduce 1.1.0.
* gnu/packages/version-control.scm (libgit2-1.1): New variable. * gnu/packages/patches/libgit2-mtime-0.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
19dc16ce4b
commit
c0e7242aa1
|
@ -1348,6 +1348,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libcyaml-libyaml-compat.patch \
|
%D%/packages/patches/libcyaml-libyaml-compat.patch \
|
||||||
%D%/packages/patches/libexpected-nofetch.patch \
|
%D%/packages/patches/libexpected-nofetch.patch \
|
||||||
%D%/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch \
|
%D%/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch \
|
||||||
|
%D%/packages/patches/libgit2-mtime-0.patch \
|
||||||
%D%/packages/patches/libgnome-encoding.patch \
|
%D%/packages/patches/libgnome-encoding.patch \
|
||||||
%D%/packages/patches/libgnomeui-utf8.patch \
|
%D%/packages/patches/libgnomeui-utf8.patch \
|
||||||
%D%/packages/patches/libgrss-CVE-2016-2001.patch \
|
%D%/packages/patches/libgrss-CVE-2016-2001.patch \
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
The Clar test framework has a bug whereby it skips the parsing phase
|
||||||
|
on files with mtime=0.
|
||||||
|
|
||||||
|
Reported upstream at <https://github.com/vmg/clar/pull/78>.
|
||||||
|
|
||||||
|
diff --git a/tests/generate.py b/tests/generate.py
|
||||||
|
index b639c8f..111ca41 100644
|
||||||
|
--- a/tests/generate.py
|
||||||
|
+++ b/tests/generate.py
|
||||||
|
@@ -63,3 +63,3 @@ class Module(object):
|
||||||
|
|
||||||
|
- self.mtime = 0
|
||||||
|
+ self.mtime = None # Guix sets all file mtimes to '0'
|
||||||
|
self.enabled = True
|
|
@ -850,6 +850,24 @@ write native speed custom Git applications in any language with bindings.")
|
||||||
;; GPLv2 with linking exception
|
;; GPLv2 with linking exception
|
||||||
(license license:gpl2)))
|
(license license:gpl2)))
|
||||||
|
|
||||||
|
(define-public libgit2-1.1
|
||||||
|
(package
|
||||||
|
(inherit libgit2)
|
||||||
|
(name "libgit2")
|
||||||
|
(version "1.1.0")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "https://github.com/libgit2/libgit2/"
|
||||||
|
"releases/download/v" version
|
||||||
|
"/libgit2-" version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
|
||||||
|
(patches (search-patches "libgit2-mtime-0.patch"))
|
||||||
|
(snippet '(begin
|
||||||
|
(delete-file-recursively "deps") #t))
|
||||||
|
(modules '((guix build utils)))))))
|
||||||
|
|
||||||
(define-public git-crypt
|
(define-public git-crypt
|
||||||
(package
|
(package
|
||||||
(name "git-crypt")
|
(name "git-crypt")
|
||||||
|
|
Reference in New Issue