gnu: ucx: Update to 1.14.0.
* gnu/packages/fabric-management.scm (ucx): Update to 1.14.0. * gnu/packages/patches/ucx-tcp-iface-ioctl.patch: Adapt patch to new ucx version.master
parent
0ac126e4f2
commit
c10bfa8885
|
@ -183,7 +183,7 @@ testing InfiniBand networks.")
|
|||
(define-public ucx
|
||||
(package
|
||||
(name "ucx")
|
||||
(version "1.9.0")
|
||||
(version "1.14.0")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -193,7 +193,7 @@ testing InfiniBand networks.")
|
|||
(patches (search-patches "ucx-tcp-iface-ioctl.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0i0ji5ivzxjqh3ys1m517ghw3am7cw1hvf40ma7hsq3wznsyx5s1"))))
|
||||
"0ki2r768wqm92qv06wxrh3kv2nl2yj4ds9fz0s0b5rr2ycjiw9ir"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
|
|
@ -54,7 +54,7 @@ index cad4a2709..7c1d2c9de 100644
|
|||
+ for (i = 0; i < conf.ifc_len / sizeof(struct ifreq); i++) {
|
||||
+ const char *name = reqs[i].ifr_name;
|
||||
+
|
||||
+ if (!ucs_netif_is_active(name)) {
|
||||
+ if (!ucs_netif_is_active(name, AF_INET)) {
|
||||
+ continue;
|
||||
+ }
|
||||
+
|
||||
|
@ -87,9 +87,9 @@ index cad4a2709..7c1d2c9de 100644
|
|||
unsigned *num_devices_p)
|
||||
@@ -599,9 +663,9 @@ ucs_status_t uct_tcp_query_devices(uct_md_h md,
|
||||
|
||||
dir = opendir(netdev_dir);
|
||||
dir = opendir(UCT_TCP_IFACE_NETDEV_DIR);
|
||||
if (dir == NULL) {
|
||||
- ucs_error("opendir(%s) failed: %m", netdev_dir);
|
||||
- ucs_error("opendir(%s) failed: %m", UCT_TCP_IFACE_NETDEV_DIR);
|
||||
- status = UCS_ERR_IO_ERROR;
|
||||
- goto out;
|
||||
+ /* When /sys is unavailable, as can be the case in a container,
|
||||
|
|
Reference in New Issue