me
/
guix
Archived
1
0
Fork 0

gnu: valgrind: Update to 3.20.0.

* gnu/packages/valgrind.scm (valgrind): Update to 3.20.0. Remove patch.
[arguments]<phases>: Remove trailing #t.
* gnu/packages/patches/valgrind-enable-arm.patch: Delete file.
* gnu/packages/valgrind.scm (dist_patch_DATA): Unregister patch.

Signed-off-by: Andreas Enge <andreas@enge.fr>
master
zimoun 2023-04-20 15:23:33 +02:00 committed by Andreas Enge
parent 50dcd1acd7
commit c3509c2148
No known key found for this signature in database
GPG Key ID: F7D5C9BF765C61E3
3 changed files with 4 additions and 35 deletions

View File

@ -2015,7 +2015,6 @@ dist_patch_DATA = \
%D%/packages/patches/unzip-32bit-zipbomb-fix.patch \
%D%/packages/patches/ustr-fix-build-with-gcc-5.patch \
%D%/packages/patches/util-linux-tests.patch \
%D%/packages/patches/valgrind-enable-arm.patch \
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \

View File

@ -1,15 +0,0 @@
Accept "arm" instead of "armv7" in configure, see
http://valgrind.10908.n7.nabble.com/building-for-arm-td39382.html .
diff -u -r valgrind-3.11.0.orig/configure valgrind-3.11.0/configure
--- valgrind-3.11.0.orig/configure 2015-10-02 20:37:41.915721386 +0200
+++ valgrind-3.11.0/configure 2015-10-02 20:37:54.886746395 +0200
@@ -5607,7 +5607,7 @@
ARCH_MAX="s390x"
;;
- armv7*)
+ arm*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ok (${host_cpu})" >&5
$as_echo "ok (${host_cpu})" >&6; }
ARCH_MAX="arm"

View File

@ -38,9 +38,7 @@
(define-public valgrind
(package
(name "valgrind")
;; Note: check "guix refresh -l -e '(@ (gnu packages valgrind) valgrind)'"
;; when updating this package to find which branch it should go to.
(version "3.17.0")
(version "3.20.0")
(source (origin
(method url-fetch)
(uri (list (string-append "https://sourceware.org/pub/valgrind"
@ -49,8 +47,7 @@
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
"18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
(patches (search-patches "valgrind-enable-arm.patch"))))
"1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
(build-system gnu-build-system)
(outputs '("doc" ;16 MB
"out"))
@ -69,15 +66,13 @@
(substitute* (find-files dir "\\.supp$")
(("obj:/lib") "obj:*/lib")
(("obj:/usr/X11R6/lib") "obj:*/lib")
(("obj:/usr/lib") "obj:*/lib"))
#t)))
(("obj:/usr/lib") "obj:*/lib")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((orig (format #f "~a/share/doc" (assoc-ref outputs "out")))
(dest (format #f "~a/share" (assoc-ref outputs "doc"))))
(mkdir-p dest)
(rename-file orig dest)
#t))))))
(rename-file orig dest)))))))
(native-inputs
(list perl))
(home-page "https://www.valgrind.org/")
@ -97,16 +92,6 @@ also use Valgrind to build new tools.")
(define-public valgrind/interactive
(package/inherit
valgrind
(version "3.20.0")
(source (origin
(method url-fetch)
(uri (list (string-append "https://sourceware.org/pub/valgrind"
"/valgrind-" version ".tar.bz2")
(string-append "ftp://sourceware.org/pub/valgrind"
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
"1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
(list gdb `(,(canonical-package glibc) "debug")))