gnu: gdb: Remove obsolete patch.
* gnu/packages/patches/gdb-python-3.7.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gdb.scm (gdb)[source](patches): Remove field.master
parent
65ba72d749
commit
c37e932764
|
@ -716,7 +716,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gd-CVE-2018-5711.patch \
|
||||
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
||||
%D%/packages/patches/gd-freetype-test-failure.patch \
|
||||
%D%/packages/patches/gdb-python-3.7.patch \
|
||||
%D%/packages/patches/gdm-CVE-2018-14424.patch \
|
||||
%D%/packages/patches/gemma-intel-compat.patch \
|
||||
%D%/packages/patches/geoclue-config.patch \
|
||||
|
|
|
@ -42,7 +42,6 @@
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/gdb/gdb-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "gdb-python-3.7.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0g6hv9xk12aa58w77fydaldqr9a6b0a6bnwsq87jfc6lkcbc7p4p"))))
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
Fix build failure with Python 3.7 and newer.
|
||||
|
||||
Taken from this upstream commit, sans ChangeLog update:
|
||||
|
||||
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=aeab512851bf6ed623d1c6c4305b6ce05e51a10c
|
||||
|
||||
diff --git a/gdb/python/python.c b/gdb/python/python.c
|
||||
index 1805c90..20fc674 100644
|
||||
--- a/gdb/python/python.c
|
||||
+++ b/gdb/python/python.c
|
||||
@@ -1667,6 +1667,17 @@ finalize_python (void *ignore)
|
||||
restore_active_ext_lang (previous_active);
|
||||
}
|
||||
|
||||
+#ifdef IS_PY3K
|
||||
+/* This is called via the PyImport_AppendInittab mechanism called
|
||||
+ during initialization, to make the built-in _gdb module known to
|
||||
+ Python. */
|
||||
+PyMODINIT_FUNC
|
||||
+init__gdb_module (void)
|
||||
+{
|
||||
+ return PyModule_Create (&python_GdbModuleDef);
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
static bool
|
||||
do_start_initialization ()
|
||||
{
|
||||
@@ -1707,6 +1718,9 @@ do_start_initialization ()
|
||||
remain alive for the duration of the program's execution, so
|
||||
it is not freed after this call. */
|
||||
Py_SetProgramName (progname_copy);
|
||||
+
|
||||
+ /* Define _gdb as a built-in module. */
|
||||
+ PyImport_AppendInittab ("_gdb", init__gdb_module);
|
||||
#else
|
||||
Py_SetProgramName (progname.release ());
|
||||
#endif
|
||||
@@ -1716,9 +1730,7 @@ do_start_initialization ()
|
||||
PyEval_InitThreads ();
|
||||
|
||||
#ifdef IS_PY3K
|
||||
- gdb_module = PyModule_Create (&python_GdbModuleDef);
|
||||
- /* Add _gdb module to the list of known built-in modules. */
|
||||
- _PyImport_FixupBuiltin (gdb_module, "_gdb");
|
||||
+ gdb_module = PyImport_ImportModule ("_gdb");
|
||||
#else
|
||||
gdb_module = Py_InitModule ("_gdb", python_GdbMethods);
|
||||
#endif
|
||||
--
|
||||
2.9.3
|
||||
|
Reference in New Issue