gnu: biber: Update to 2.16.
* gnu/packages/tex.scm (biber): Update to 2.16. [source]: Remove 'patches'. [inputs]: Add 'perl-io-string', 'perl-parse-recdescent', and 'perl-unicode-collate' (upstream appears to have fixed the issue initially mentioned as a comment: recent issue was closed after telling user to use perl-unicode-collate 1.29, which is the one available; see <https://github.com/plk/biber/issues/378>.) * gnu/packages/patches/biber-fix-encoding-write.patch, gnu/packages/patches/biber-sortinithash.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Co-authored-by: Ludovic Courtès <ludo@gnu.org>master
parent
313c69a100
commit
c3e33474b9
|
@ -876,8 +876,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/beets-werkzeug-compat.patch \
|
||||
%D%/packages/patches/behave-skip-a-couple-of-tests.patch \
|
||||
%D%/packages/patches/beignet-correct-file-names.patch \
|
||||
%D%/packages/patches/biber-fix-encoding-write.patch \
|
||||
%D%/packages/patches/biber-sortinithash.patch \
|
||||
%D%/packages/patches/bidiv-update-fribidi.patch \
|
||||
%D%/packages/patches/binutils-boot-2.20.1a.patch \
|
||||
%D%/packages/patches/binutils-libiberty-endianness-bug.patch \
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
From 2a9b15aefb842a734637f3d230936ea1b7c60096 Mon Sep 17 00:00:00 2001
|
||||
From: Philip Kime <Philip@kime.org.uk>
|
||||
Date: Thu, 8 Nov 2018 22:02:09 +0100
|
||||
Subject: [PATCH] Fix to address #239
|
||||
|
||||
---
|
||||
lib/Biber.pm | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/Biber.pm b/lib/Biber.pm
|
||||
index 8b1f80a5..d97fca29 100644
|
||||
--- a/lib/Biber.pm
|
||||
+++ b/lib/Biber.pm
|
||||
@@ -311,6 +311,8 @@ sub parse_ctrlfile {
|
||||
unless (eval {$checkbuf = File::Slurper::read_text($ctrl_file_path, 'latin1')}) {
|
||||
biber_error("$ctrl_file_path is not UTF-8 or even latin1, how horrible.");
|
||||
}
|
||||
+ # Write ctrl file as UTF-8
|
||||
+ File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary
|
||||
}
|
||||
|
||||
$checkbuf = NFD($checkbuf);# Unicode NFD boundary
|
||||
@@ -319,8 +321,6 @@ sub parse_ctrlfile {
|
||||
unlink($output) unless $output eq '-';# ignore deletion of STDOUT marker
|
||||
biber_error("$ctrl_file_path is malformed, last biblatex run probably failed. Deleted $output");
|
||||
}
|
||||
- # Write ctrl file as UTF-8
|
||||
- File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary
|
||||
|
||||
# Validate if asked to
|
||||
if (Biber::Config->getoption('validate_control')) {
|
File diff suppressed because it is too large
Load Diff
|
@ -6966,20 +6966,16 @@ values (strings, macros, or numbers) pasted together.")
|
|||
;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
|
||||
;; at <https://ctan.org/pkg/biblatex>.
|
||||
(name "biber")
|
||||
(version "2.12")
|
||||
(version "2.16")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/plk/biber/")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
;; TODO: Patch awaiting inclusion upstream (see:
|
||||
;; https://github.com/plk/biber/issues/239).
|
||||
(patches (search-patches "biber-fix-encoding-write.patch"
|
||||
"biber-sortinithash.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
|
||||
"0586q8y1f2k23mvb02ccm3qsb35cwskafksixsjaih7a7xcf5gxx"))))
|
||||
(build-system perl-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -7002,6 +6998,7 @@ values (strings, macros, or numbers) pasted together.")
|
|||
("perl-datetime-format-builder" ,perl-datetime-format-builder)
|
||||
("perl-datetime-calendar-julian" ,perl-datetime-calendar-julian)
|
||||
("perl-file-slurper" ,perl-file-slurper)
|
||||
("perl-io-string" ,perl-io-string)
|
||||
("perl-ipc-cmd" ,perl-ipc-cmd)
|
||||
("perl-ipc-run3" ,perl-ipc-run3)
|
||||
("perl-list-allutils" ,perl-list-allutils)
|
||||
|
@ -7009,10 +7006,8 @@ values (strings, macros, or numbers) pasted together.")
|
|||
("perl-mozilla-ca" ,perl-mozilla-ca)
|
||||
("perl-regexp-common" ,perl-regexp-common)
|
||||
("perl-log-log4perl" ,perl-log-log4perl)
|
||||
;; We cannot use perl-unicode-collate here, because otherwise the
|
||||
;; hardcoded hashes in the tests would differ. See
|
||||
;; https://mail-archive.com/debian-bugs-dist@lists.debian.org/msg1469249.html
|
||||
;;("perl-unicode-collate" ,perl-unicode-collate)
|
||||
("perl-parse-recdescent" ,perl-parse-recdescent)
|
||||
("perl-unicode-collate" ,perl-unicode-collate)
|
||||
("perl-unicode-normalize" ,perl-unicode-normalize)
|
||||
("perl-unicode-linebreak" ,perl-unicode-linebreak)
|
||||
("perl-encode-eucjpascii" ,perl-encode-eucjpascii)
|
||||
|
|
Reference in New Issue