gnu: grep: Update to 3.8.
* gnu/packages/base.scm (grep): Update to 3.8. * gnu/packages/commencement.scm (grep-mesboot)[native-inputs]: Add SED-MESBOOT. * gnu/packages/autotools.scm (libtool)[source](patches): Add patch. * gnu/packages/patches/libtool-grep-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.master
parent
d4485c5af7
commit
c527b0ce23
|
@ -1420,6 +1420,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libtirpc-CVE-2021-46828.patch \
|
%D%/packages/patches/libtirpc-CVE-2021-46828.patch \
|
||||||
%D%/packages/patches/libtirpc-hurd.patch \
|
%D%/packages/patches/libtirpc-hurd.patch \
|
||||||
%D%/packages/patches/libtommath-fix-linkage.patch \
|
%D%/packages/patches/libtommath-fix-linkage.patch \
|
||||||
|
%D%/packages/patches/libtool-grep-compat.patch \
|
||||||
%D%/packages/patches/libtool-skip-tests2.patch \
|
%D%/packages/patches/libtool-skip-tests2.patch \
|
||||||
%D%/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch \
|
%D%/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch \
|
||||||
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
||||||
|
|
|
@ -439,7 +439,8 @@ Makefile, simplifying the entire process for the developer.")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
|
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
|
||||||
(patches (search-patches "libtool-skip-tests2.patch"))))
|
(patches (search-patches "libtool-skip-tests2.patch"
|
||||||
|
"libtool-grep-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(propagated-inputs (list m4))
|
(propagated-inputs (list m4))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
|
|
|
@ -105,14 +105,14 @@ command-line arguments, multiple languages, and so on.")
|
||||||
(define-public grep
|
(define-public grep
|
||||||
(package
|
(package
|
||||||
(name "grep")
|
(name "grep")
|
||||||
(version "3.7")
|
(version "3.8")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/grep/grep-"
|
(uri (string-append "mirror://gnu/grep/grep-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0g42svbc1nq5bamxfj6x7320wli4dlj86padk0hwgbk04hqxl42w"))
|
"10n3mc9n1xmg85hpxyr4wiqzfp27ffxzwhvkv021j27vnk0pr3a9"))
|
||||||
(patches (search-patches "grep-timing-sensitive-test.patch"))))
|
(patches (search-patches "grep-timing-sensitive-test.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs (list perl)) ;some of the tests require it
|
(native-inputs (list perl)) ;some of the tests require it
|
||||||
|
|
|
@ -1845,7 +1845,6 @@ exec " gcc "/bin/" program
|
||||||
;; In the future, Gash et al. could handle it directly, but it's not
|
;; In the future, Gash et al. could handle it directly, but it's not
|
||||||
;; ready yet.
|
;; ready yet.
|
||||||
(define bash-mesboot (mesboot-package "bash-mesboot" static-bash))
|
(define bash-mesboot (mesboot-package "bash-mesboot" static-bash))
|
||||||
(define grep-mesboot (mesboot-package "grep-mesboot" grep))
|
|
||||||
(define sed-mesboot (mesboot-package "sed-mesboot" sed))
|
(define sed-mesboot (mesboot-package "sed-mesboot" sed))
|
||||||
|
|
||||||
;; "sed" from Gash-Utils lacks the 'w' command as of 0.2.0.
|
;; "sed" from Gash-Utils lacks the 'w' command as of 0.2.0.
|
||||||
|
@ -1857,6 +1856,14 @@ exec " gcc "/bin/" program
|
||||||
`(("sed" ,sed-mesboot)
|
`(("sed" ,sed-mesboot)
|
||||||
,@(package-native-inputs pkg))))))
|
,@(package-native-inputs pkg))))))
|
||||||
|
|
||||||
|
(define grep-mesboot
|
||||||
|
(let ((pkg (mesboot-package "grep-mesboot" grep)))
|
||||||
|
(package
|
||||||
|
(inherit pkg)
|
||||||
|
(native-inputs
|
||||||
|
`(("sed" ,sed-mesboot)
|
||||||
|
,@(package-native-inputs pkg))))))
|
||||||
|
|
||||||
;; The XZ implementation in Bootar cannot decompress 'tar'.
|
;; The XZ implementation in Bootar cannot decompress 'tar'.
|
||||||
(define xz-mesboot
|
(define xz-mesboot
|
||||||
(let ((pkg (mesboot-package "xz-mesboot" xz)))
|
(let ((pkg (mesboot-package "xz-mesboot" xz)))
|
||||||
|
|
|
@ -0,0 +1,51 @@
|
||||||
|
Don't escape forward slashes to prevent a warning from grep 3.8.
|
||||||
|
|
||||||
|
diff --git a/tests/link-order.at b/tests/link-order.at
|
||||||
|
--- a/tests/link-order.at
|
||||||
|
+++ b/tests/link-order.at
|
||||||
|
@@ -99,12 +99,12 @@ aix* | interix*) ;; # These systems have different path syntax
|
||||||
|
case $hardcode_direct$hardcode_direct_absolute in
|
||||||
|
yesno)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
|
||||||
|
+ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
|
||||||
|
+ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
diff --git a/tests/testsuite b/tests/testsuite
|
||||||
|
--- a/tests/testsuite
|
||||||
|
+++ b/tests/testsuite
|
||||||
|
@@ -20611,11 +20611,11 @@ aix* | interix*) ;; # These systems have different path syntax
|
||||||
|
yesno)
|
||||||
|
{ set +x
|
||||||
|
$as_echo "$at_srcdir/link-order.at:101: if \$EGREP relinking stderr; then
|
||||||
|
- \$EGREP \" .*\\/new\\/lib/libb\$shared_ext .*\\/old\\/lib/libcee\$shared_ext\" stdout
|
||||||
|
+ \$EGREP \" .*/new/lib/libb\$shared_ext .*/old/lib/libcee\$shared_ext\" stdout
|
||||||
|
else :; fi"
|
||||||
|
at_fn_check_prepare_notrace 'an embedded newline' "link-order.at:101"
|
||||||
|
( $at_check_trace; if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
|
||||||
|
+ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
|
||||||
|
else :; fi
|
||||||
|
) >>"$at_stdout" 2>>"$at_stderr" 5>&-
|
||||||
|
at_status=$? at_failed=false
|
||||||
|
@@ -20633,11 +20633,11 @@ $at_traceon; }
|
||||||
|
*)
|
||||||
|
{ set +x
|
||||||
|
$as_echo "$at_srcdir/link-order.at:106: if \$EGREP relinking stderr; then
|
||||||
|
- \$EGREP \" -L.*\\/new\\/lib -lb -L.*\\/old\\/lib -lcee\" stdout
|
||||||
|
+ \$EGREP \" -L.*/new\\/lib -lb -L.*/old/lib -lcee\" stdout
|
||||||
|
else :; fi"
|
||||||
|
at_fn_check_prepare_notrace 'an embedded newline' "link-order.at:106"
|
||||||
|
( $at_check_trace; if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
|
||||||
|
+ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
|
||||||
|
else :; fi
|
||||||
|
) >>"$at_stdout" 2>>"$at_stderr" 5>&-
|
||||||
|
at_status=$? at_failed=false
|
Reference in New Issue