me
/
guix
Archived
1
0
Fork 0

gnu: emacs-ess: Update to 18.10.2-1.3691ecc.

* gnu/packages/statistics.scm (emacs-ess): Update to 18.10.2-1.3691ecc.
[arguments]: Skip failing tests.
* gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch: Delete file.
* gnu/local.mk: Apply file removal.

Change-Id: If8cd54c32c44cd2465f2cdb78317e8f8339f6bc3
master
Nicolas Goaziou 2024-01-04 15:02:50 +01:00
parent 0eec27846b
commit c61532c4b4
No known key found for this signature in database
GPG Key ID: DA00B4F048E92F2D
3 changed files with 27 additions and 32 deletions

View File

@ -1111,7 +1111,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-elpy-dup-test-name.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \
%D%/packages/patches/emacs-git-email-missing-parens.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \

View File

@ -1,23 +0,0 @@
From 9cc5520e1998d03f5dec0fbb1fe71b7cdec38b65 Mon Sep 17 00:00:00 2001
From: Alex Branham <alex.branham@gmail.com>
Date: Wed, 6 Jan 2021 06:41:20 -0500
Subject: [PATCH] Add required when to obsolete function alias
Closes #1085
---
lisp/ess-r-package.el | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lisp/ess-r-package.el b/lisp/ess-r-package.el
index 260959955..397ce14e6 100644
--- a/lisp/ess-r-package.el
+++ b/lisp/ess-r-package.el
@@ -577,7 +577,7 @@ package mode. Use this function if state of the buffer such as
(error "As of ESS 16.04, `ess-developer' is deprecated. Use `ess-r-set-evaluation-env' instead"))
(defalias 'ess-toggle-developer 'ess-developer)
-(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder)
+(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder "18.04")
(define-obsolete-function-alias 'ess-r-devtools-ask 'ess-r-devtools-execute-command "18.04")
(make-obsolete-variable 'ess-developer "Please use `ess-developer-select-package' and `ess-r-set-evaluation-env' instead." "16.04")

View File

@ -6757,11 +6757,9 @@ Java package that provides routines for various statistical distributions.")
(license license:gpl2+)))
(define-public emacs-ess
;; Latest release is old. This is not the latest commit either due to bug
;; reported here: <https://github.com/emacs-ess/ESS/issues/987>.
(let ((commit "24da603184ce39246611dd5b8602e769d7ebd5bf")
(let ((commit "3691ecc642eab5d016887e42699648e0eeeef566")
(version "18.10.2")
(revision "0"))
(revision "1"))
(package
(name "emacs-ess")
(version (git-version version revision commit))
@ -6772,7 +6770,7 @@ Java package that provides routines for various statistical distributions.")
(url "https://github.com/emacs-ess/ESS")
(commit commit)))
(sha256
(base32 "0j98lv07nzwzd54d4dgcfz01wy5gj48m0mnirxzh5r45ik2myh1r"))
(base32 "19p8djsbgvahpsx1w8i6h3qvpbdr4isjwm3wi82yk2648ri0qsq1"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
@ -6803,9 +6801,7 @@ Java package that provides routines for various statistical distributions.")
"$(MAKE) -C lisp install; $(MAKE) -C doc install")
(("\\$\\(INSTALL) -R \\./\\* \\$\\(ESSDESTDIR)/")
"$(MAKE) -C etc install"))
#t))
(patches
(search-patches "emacs-ess-fix-obsolete-function-alias.patch"))))
#t))))
(build-system gnu-build-system)
(arguments
(let ((base-directory "/share/emacs/site-lisp"))
@ -6819,6 +6815,29 @@ Java package that provides routines for various statistical distributions.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'check 'skip-failing-tests
;; XXX: Skip 10 failing tests (out of 187).
(lambda _
(let-syntax
((disable-tests
(syntax-rules ()
((_ file ())
(syntax-error "test names list must not be empty"))
((_ file (test-name ...))
(substitute* file
(((string-append "^\\(ert-deftest " test-name ".*") all)
(string-append all "(skip-unless nil)\n")) ...)))))
(disable-tests (list "test/ess-test-inf.el" "test/ess-test-r.el")
("ess--derive-connection-path"
"ess-eval-line-test"
"ess-eval-region-test"
"ess-mock-remote-process"
"ess-r-load-ESSR-github-fetch-no"
"ess-r-load-ESSR-github-fetch-yes"
"ess-r-eval-ns-env-roxy-tracebug-test"
"ess-r-eval-sink-freeze-test"
"ess-set-working-directory-test"
"ess-test-r-startup-directory")))))
(replace 'check
(lambda _ (invoke "make" "test")))))))
(native-inputs