me
/
guix
Archived
1
0
Fork 0

gnu: python-jedi: Update to 0.17.2.

* gnu/packages/python-xyz.scm (python-jedi): Update to 0.17.2.
[source, arguments]: Remove upstreamed patching.
* gnu/packages/patches/python-jedi-sort-project-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2020-07-27 03:40:33 +02:00
parent 083bc36215
commit c64f0eea88
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 2 additions and 31 deletions

View File

@ -1454,7 +1454,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-jedi-sort-project-test.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \

View File

@ -1,18 +0,0 @@
Sort the result of file system traversal to avoid test failure on different
file systems.
Taken from upstream:
https://github.com/davidhalter/jedi/commit/7ff76bb7d0d94514e17cd1647f4ffaf533dd55f5
diff --git a/test/test_api/test_project.py b/test/test_api/test_project.py
--- a/test/test_api/test_project.py
+++ b/test/test_api/test_project.py
@@ -135,7 +135,7 @@ def test_search(string, full_names, kwargs, skip_pre_python36):
defs = project.complete_search(string, **kwargs)
else:
defs = project.search(string, **kwargs)
- assert [('stub:' if d.is_stub() else '') + d.full_name for d in defs] == full_names
+ assert sorted([('stub:' if d.is_stub() else '') + d.full_name for d in defs]) == full_names
@pytest.mark.parametrize(

View File

@ -12607,27 +12607,17 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
(version "0.17.0")
(version "0.17.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
(patches (search-patches "python-jedi-sort-project-test.patch"))
(sha256
(base32
"0c1h9x3a9klvk2g288wl328x8xgzw7136k6vs9hkd56b85vcjh6z"))))
(base32 "080xyf97ifabdz7jp8clg00b8zv5g33fva1fb2xf80q6fndpvvc6"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-before 'check 'adjust-test-for-python-3.8
(lambda _
;; Mimic upstream commit e7feeef64 to allow for extra output lines
;; in TestSetupReadline on Python 3.8. Remove for jedi > 0.17.0.
(substitute* "test/test_utils.py"
(("assert len\\(difference\\) < 20")
"assert len(difference) < 22"))
#t))
(replace 'check
(lambda _
(setenv "HOME" "/tmp")