From c67828a38aaa304f78bb957dc06d5d3a0dc3062b Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:53:05 +0200
Subject: [PATCH] gnu: Add texlive-inversepath.

* gnu/packages/tex.scm (texlive-inversepath): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index de50ac3a81..442c07cf9b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -85697,6 +85697,26 @@ facilities such as the pdfTeX @code{\\pdfelapsedtime} primitive.")
 hyperlink.")
     (license license:lppl1.3c)))
 
+(define-public texlive-inversepath
+  (package
+    (name "texlive-inversepath")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/inversepath/"
+                   "source/latex/inversepath/"
+                   "tex/latex/inversepath/")
+             (base32
+              "1mbvx1lj1h0p2li4qjc5s238iiwnp9cg0vsdlxxwdlng8ahc62p0")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/inversepath")
+    (synopsis "Calculate inverse file paths")
+    (description
+     "The package calculates inverse relative paths.  Such things may be useful,
+for example, when writing an auxiliary file to a different directory.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar