From c6a3b6605a429b32021a3cb0e5f67d9202362a42 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:44:52 +0200
Subject: [PATCH] gnu: Add texlive-bithesis.

* gnu/packages/tex.scm (texlive-bithesis): New variable.
---
 gnu/packages/tex.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9efb058988..381b69e0c9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -74450,6 +74450,27 @@ include:
 @end itemize")
     (license (list license:lppl license:gpl3+))))
 
+(define-public texlive-bithesis
+  (package
+    (name "texlive-bithesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bithesis/"
+                   "source/latex/bithesis/"
+                   "tex/latex/bithesis/")
+             (base32
+              "0s6j62cb5qa6vkpiq82i9wcahvj5ykrf9fl4hjghlww5jqiyd08h")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bithesis")
+    (synopsis "Templates for the Beijing Institute of Technology")
+    (description
+     "This package establishes a simple and easy-to-use LaTeX template for Beijing
+Institute of Technology dissertations, including general undergraduate theses
+and master theses.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar